summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-01-14 23:12:19 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-01-14 23:12:19 +0000
commite25ba3a0eb783c8897946e5ae6286bed2ce8b0a8 (patch)
treed6bc1dbdafba181ac4300a06e524ebfbf9c0204e /net-p2p
parentVersion bumped. Closes 37837 (diff)
downloadhistorical-e25ba3a0eb783c8897946e5ae6286bed2ce8b0a8.tar.gz
historical-e25ba3a0eb783c8897946e5ae6286bed2ce8b0a8.tar.bz2
historical-e25ba3a0eb783c8897946e5ae6286bed2ce8b0a8.zip
Version bumped. Closes 37837
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/gnunet/Manifest4
-rw-r--r--net-p2p/gnunet/files/digest-gnunet-0.6.1a1
-rw-r--r--net-p2p/gnunet/gnunet-0.6.1a.ebuild46
3 files changed, 49 insertions, 2 deletions
diff --git a/net-p2p/gnunet/Manifest b/net-p2p/gnunet/Manifest
index adb28eb9c770..4ad61e8bb8ec 100644
--- a/net-p2p/gnunet/Manifest
+++ b/net-p2p/gnunet/Manifest
@@ -1,9 +1,9 @@
-MD5 45476034dd619f84333f5b054d4093b4 ChangeLog 2411
+MD5 1c3b0243a9c19e8214d1e0ae503c3087 ChangeLog 2543
MD5 d15feb86e09bb61aebf6e1e33b3c08d6 gnunet-0.5.4-r1.ebuild 1224
MD5 152b27b6f78257bb76c90b30bedb9a9a gnunet-0.5.5.ebuild 1222
MD5 08cebc61d2f3a582ab8b6052e2957d4d gnunet-0.6.0.ebuild 1185
MD5 1fe7a935d4ca6da42397ddf17af90200 gnunet-0.6.0a.ebuild 1186
-MD5 8cd6b446356b756a9d39e9254f6237e1 gnunet-0.6.1a.ebuild 1186
+MD5 af40663d414a00003cb68ac323446328 gnunet-0.6.1a.ebuild 1184
MD5 12b0bdd38d4a838fcc6d4e8b970870f5 files/digest-gnunet-0.5.4-r1 65
MD5 c9f162707edf3372ba994a5d274c1280 files/digest-gnunet-0.5.5 65
MD5 9e8613dc69495f49622a2588b1a816a8 files/digest-gnunet-0.6.0 65
diff --git a/net-p2p/gnunet/files/digest-gnunet-0.6.1a b/net-p2p/gnunet/files/digest-gnunet-0.6.1a
new file mode 100644
index 000000000000..9accb6805d75
--- /dev/null
+++ b/net-p2p/gnunet/files/digest-gnunet-0.6.1a
@@ -0,0 +1 @@
+MD5 4a82b579007afe3e1a64fa7d6a9cd028 GNUnet-0.6.1a.tar.bz2 1055361
diff --git a/net-p2p/gnunet/gnunet-0.6.1a.ebuild b/net-p2p/gnunet/gnunet-0.6.1a.ebuild
new file mode 100644
index 000000000000..d14b2cefe299
--- /dev/null
+++ b/net-p2p/gnunet/gnunet-0.6.1a.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/gnunet-0.6.1a.ebuild,v 1.1 2004/01/14 23:11:54 mholzer Exp $
+
+inherit libtool
+
+S="${WORKDIR}/GNUnet-${PV}"
+DESCRIPTION="GNUnet is an anonymous, distributed, reputation based network."
+HOMEPAGE="http://www.ovmj.org/GNUnet/"
+SRC_URI="http://www.ovmj.org/GNUnet/download/GNUnet-${PV}.tar.bz2"
+
+IUSE="ipv6"
+
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=dev-libs/openssl-0.9.6d
+ >=sys-libs/gdbm-1.8.0
+ =dev-libs/glib-1.2*
+ =x11-libs/gtk+-1.2*
+ >=dev-libs/libextractor-0.2.6"
+
+src_compile() {
+ elibtoolize
+ econf `use_enable ipv6` || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc AUTHORS ChangeLog PLATFORMS README UPDATING
+ insinto /etc
+ newins contrib/gnunet.conf.root gnunet.conf
+ docinto contrib
+ dodoc contrib/*
+}
+
+pkg_postinst() {
+ use ipv6 && ewarn "ipv6 support is -very- experimental and prone to bug"
+ einfo
+ einfo "now copy an appropriate config file from"
+ einfo "/usr/share/doc/${P}/contrib"
+ einfo "to ~/.gnunet/gnunet.conf"
+ einfo
+}