summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2006-05-10 21:26:36 +0000
committerAlin Năstac <mrness@gentoo.org>2006-05-10 21:26:36 +0000
commit8d93533f30338157ea1c158a8fea5b87de672ab1 (patch)
tree81c7c4bbb0ed926604e2649750a59a8e9c0048c8 /net-wireless/gnome-bluetooth/files
parentFixing dependencies for openal. (diff)
downloadhistorical-8d93533f30338157ea1c158a8fea5b87de672ab1.tar.gz
historical-8d93533f30338157ea1c158a8fea5b87de672ab1.tar.bz2
historical-8d93533f30338157ea1c158a8fea5b87de672ab1.zip
Fix broken build when linked with --as-needed (#131416).
Package-Manager: portage-2203-svn
Diffstat (limited to 'net-wireless/gnome-bluetooth/files')
-rw-r--r--net-wireless/gnome-bluetooth/files/gnome-bluetooth-0.7.0-as-needed.patch75
1 files changed, 75 insertions, 0 deletions
diff --git a/net-wireless/gnome-bluetooth/files/gnome-bluetooth-0.7.0-as-needed.patch b/net-wireless/gnome-bluetooth/files/gnome-bluetooth-0.7.0-as-needed.patch
new file mode 100644
index 000000000000..30af537f43e6
--- /dev/null
+++ b/net-wireless/gnome-bluetooth/files/gnome-bluetooth-0.7.0-as-needed.patch
@@ -0,0 +1,75 @@
+Index: gnome-bluetooth-0.7.0/src/Makefile.am
+===================================================================
+--- gnome-bluetooth-0.7.0.orig/src/Makefile.am
++++ gnome-bluetooth-0.7.0/src/Makefile.am
+@@ -33,41 +33,42 @@ gnomebt-chooser.lo: gnomebt-controller.h
+
+ libgnomebt_la_LDFLAGS = \
+ -version-info $(GNOMEBT_LT_VERSION)
++libgnomebt_la_LIBADD = $(GNOME_BLUETOOTH_LIBS)
+
+ gnomebt_chooser_test_SOURCES = \
+ gnomebt-chooser-test.c
+
+ gnomebt_chooser_test_LDADD = \
+- $(GNOME_BLUETOOTH_LIBS) libgnomebt.la
++ libgnomebt.la $(GNOME_BLUETOOTH_LIBS)
+
+ gnomebt_controller_test_SOURCES = \
+ gnomebt-controller-test.c
+
+ gnomebt_controller_test_LDADD = \
+- $(GNOME_BLUETOOTH_LIBS) libgnomebt.la
++ libgnomebt.la $(GNOME_BLUETOOTH_LIBS)
+
+ gnomebt_fileactiondialog_test_SOURCES = \
+ gnomebt-fileactiondialog-test.c
+
+ gnomebt_fileactiondialog_test_LDADD = \
+- $(GNOME_BLUETOOTH_LIBS) libgnomebt.la
++ libgnomebt.la $(GNOME_BLUETOOTH_LIBS)
+
+ gnomebt_permissiondialog_test_SOURCES = \
+ gnomebt-permissiondialog-test.c
+
+ gnomebt_permissiondialog_test_LDADD = \
+- $(GNOME_BLUETOOTH_LIBS) libgnomebt.la
++ libgnomebt.la $(GNOME_BLUETOOTH_LIBS)
+
+ spinner_test_SOURCES = \
+ spinner-test.c
+
+ spinner_test_LDADD = \
+- $(GNOME_BLUETOOTH_LIBS) libgnomebt.la
++ libgnomebt.la $(GNOME_BLUETOOTH_LIBS)
+
+ gconftest_SOURCES = \
+ gconftest.c
+
+-gconftest_LDFLAGS = \
++gconftest_LDADD = \
+ $(GNOME_BLUETOOTH_LIBS) $(BLUETOOTH_LIBS)
+
+ GOB_DIST = \
+@@ -121,13 +122,13 @@ gnomebt-chooser-py.c: gnomebt-chooser.de
+ pydir = @pythondir@/gnomebt/
+
+ controller_la_SOURCES = gnomebt-controller-py.c gnomebt-controller-pymodule.c
+-controller_la_LIBADD = libgnomebt.la
+-controller_la_LDFLAGS = $(GNOME_BLUETOOTH_PYTHON_LIBS) \
+- $(GNOME_BLUETOOTH_LIBS) \
+- -module -avoid-version
++controller_la_LIBADD = libgnomebt.la \
++ $(GNOME_BLUETOOTH_PYTHON_LIBS) \
++ $(GNOME_BLUETOOTH_LIBS)
++controller_la_LDFLAGS = -module -avoid-version
+
+ chooser_la_SOURCES = gnomebt-chooser-py.c gnomebt-chooser-pymodule.c
+-chooser_la_LIBADD = libgnomebt.la
+-chooser_la_LDFLAGS = $(GNOME_BLUETOOTH_PYTHON_LIBS) \
+- $(GNOME_BLUETOOTH_LIBS) \
+- -module -avoid-version
++chooser_la_LIBADD = libgnomebt.la \
++ $(GNOME_BLUETOOTH_PYTHON_LIBS) \
++ $(GNOME_BLUETOOTH_LIBS)
++chooser_la_LDFLAGS = -module -avoid-version