summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDean Bailey <alron@gentoo.org>2003-02-19 00:13:27 +0000
committerDean Bailey <alron@gentoo.org>2003-02-19 00:13:27 +0000
commitab7d8ae7b48e483a10cb735622c499bcdaac0816 (patch)
tree6b086f37a837cb08e6334a1143ee05db0a50f40d /net-www/horde-imp
parentAdded i18n dependencies. Tells the user where to find the i18n folder (diff)
downloadhistorical-ab7d8ae7b48e483a10cb735622c499bcdaac0816.tar.gz
historical-ab7d8ae7b48e483a10cb735622c499bcdaac0816.tar.bz2
historical-ab7d8ae7b48e483a10cb735622c499bcdaac0816.zip
version bump cuz of new RC
Diffstat (limited to 'net-www/horde-imp')
-rw-r--r--net-www/horde-imp/ChangeLog9
-rw-r--r--net-www/horde-imp/files/digest-horde-imp-3.2_rc31
-rw-r--r--net-www/horde-imp/horde-imp-3.2_rc3.ebuild91
3 files changed, 99 insertions, 2 deletions
diff --git a/net-www/horde-imp/ChangeLog b/net-www/horde-imp/ChangeLog
index cf33ff2c9c2a..14744af0f1ed 100644
--- a/net-www/horde-imp/ChangeLog
+++ b/net-www/horde-imp/ChangeLog
@@ -1,8 +1,13 @@
# ChangeLog for net-www/horde-imp
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/horde-imp/ChangeLog,v 1.7 2003/02/12 08:48:04 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/horde-imp/ChangeLog,v 1.8 2003/02/19 00:13:27 alron Exp $
-*horde-imp-3.2_rc1 (10 Feb 2003)
+*horde-imp-3.2_rc3 (18 Feb 2003)
+ 18 Feb 2003; Dean Bailey <alron@gentoo.org> horde-imp-3.2_rc3 :
+ Added 3.2-RC3 of IMP. Masked as -x86 so on. This is just a minor version bump.
+ Same as previous RC.
+
+*horde-imp-3.2_rc2 (10 Feb 2003)
10 Feb 2003; Dean Bailey <alron@gentoo.org> horde-imp-3.2_rc2 :
Added 3.2-RC2 of IMP. Masked as -x86 so on. This is just a minor version bump. Same reasons as previous
RC.
diff --git a/net-www/horde-imp/files/digest-horde-imp-3.2_rc3 b/net-www/horde-imp/files/digest-horde-imp-3.2_rc3
new file mode 100644
index 000000000000..7a6f9baf0bfd
--- /dev/null
+++ b/net-www/horde-imp/files/digest-horde-imp-3.2_rc3
@@ -0,0 +1 @@
+MD5 4f85853fb02f08fdc1873307569a3997 imp-3.2-RC3.tar.gz 1259181
diff --git a/net-www/horde-imp/horde-imp-3.2_rc3.ebuild b/net-www/horde-imp/horde-imp-3.2_rc3.ebuild
new file mode 100644
index 000000000000..1f614572449f
--- /dev/null
+++ b/net-www/horde-imp/horde-imp-3.2_rc3.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/horde-imp/horde-imp-3.2_rc3.ebuild,v 1.1 2003/02/19 00:13:27 alron Exp $
+
+DESCRIPTION="IMP ${PV} provides webmail access"
+HOMEPAGE="http://www.horde.org"
+P=imp-3.2
+SRC_URI="ftp://ftp.horde.org/pub/imp/tarballs/imp-3.2-RC3.tar.gz"
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="-x86 -ppc -sparc -alpha"
+DEPEND=""
+RDEPEND=">=net-www/horde-2.1"
+
+find_http_root() {
+ export HTTPD_ROOT=`grep apache /etc/passwd | cut -d: -f6`/htdocs
+
+ if [ -z "${HTTPD_ROOT}" ]; then
+ eerror "HTTPD_ROOT is null! Using defaults."
+ eerror "You probably want to check /etc/passwd"
+ HTTPD_ROOT="/home/httpd/htdocs"
+ fi
+
+ export REGISTRY=${HTTPD_ROOT}/horde/config/registry.php
+ [ -f ${REGISTRY} ] || REGISTRY=${HTTPD_ROOT}/horde/config/registry.php.dist
+}
+
+pkg_setup() {
+ # FIXME: Is this really how we want to do this ?
+ GREP=`grep imap /var/db/pkg/dev-php/mod_php*/USE`
+ if [ "${GREP}" != "" ]; then
+ return 0
+ else
+ eerror "Missing IMAP support in mod_php !"
+ die "aborting..."
+ fi
+ find_http_root
+ [ -f ${REGISTRY} ] || die "${REGISTRY} not found"
+}
+
+src_compile() {
+ echo "Nothing to compile"
+}
+
+src_install () {
+
+ # detecting apache usergroup
+ # FIXME: With time, apache's GID should be static
+ GID=`grep apache /etc/group |cut -d: -f3`
+ if [ -z "${GID}" ]; then
+ einfo "Using default GID of 81 for Apache"
+ GID=81
+ fi
+
+ find_http_root
+
+ dodir ${HTTPD_ROOT}/horde/imp
+ cp -r . ${D}/${HTTPD_ROOT}/horde/imp
+
+ # protecting files
+ chown -R root.${GID} ${D}/${HTTPD_ROOT}/horde/imp
+ find ${D}/${HTTPD_ROOT}/horde/imp/ -type f -exec chmod 0640 {} \;
+ find ${D}/${HTTPD_ROOT}/horde/imp/ -type d -exec chmod 0750 {} \;
+}
+
+pkg_postinst() {
+
+ find_http_root
+
+ # add module in horde
+ sed -e "/^\/\/.*\(\$this->applications\['imp'\].*\)/ \
+ { : next ; N ; /\;/ { s/\/\///g ; b } ; b next }" \
+ < ${REGISTRY} > ${REGISTRY}.temp
+ cp ${REGISTRY}.temp ${REGISTRY}
+ rm ${REGISTRY}.temp
+
+ # end
+ einfo "Please read ${HTTPD_ROOT}/horde/imp/docs/INSTALL !"
+}
+
+pkg_prerm() {
+ find_http_root
+
+ # rm module from horde
+ sed -e "/\(\$this->applications\['imp'\].*\)/ \
+ { s/\(.*\)/\/\/\1/g; : suite ; N ; /\;/ { s/\n/\n\/\//g ; b } ; \
+ b suite }" \
+ < ${REGISTRY} > ${REGISTRY}.temp
+ cp ${REGISTRY}.temp ${REGISTRY}
+ rm ${REGISTRY}.temp
+}