summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWout Mertens <wmertens@gentoo.org>2002-06-02 21:40:57 +0000
committerWout Mertens <wmertens@gentoo.org>2002-06-02 21:40:57 +0000
commitfec6683cc26a50e5ae3a59a7ae02d3f98c5e9bd2 (patch)
tree74d921c774e2dc87867393b6fc29ede4bde42617 /net-www/wwwoffle
parentGCC3.1 support fix -- thanks to lostlogix and carpaski (diff)
downloadhistorical-fec6683cc26a50e5ae3a59a7ae02d3f98c5e9bd2.tar.gz
historical-fec6683cc26a50e5ae3a59a7ae02d3f98c5e9bd2.tar.bz2
historical-fec6683cc26a50e5ae3a59a7ae02d3f98c5e9bd2.zip
New version to fix length info bug
Diffstat (limited to 'net-www/wwwoffle')
-rw-r--r--net-www/wwwoffle/ChangeLog20
-rw-r--r--net-www/wwwoffle/files/digest-wwwoffle-2.7b1
-rw-r--r--net-www/wwwoffle/wwwoffle-2.7b.ebuild93
3 files changed, 103 insertions, 11 deletions
diff --git a/net-www/wwwoffle/ChangeLog b/net-www/wwwoffle/ChangeLog
index 38b9d33ba656..fe8135906eef 100644
--- a/net-www/wwwoffle/ChangeLog
+++ b/net-www/wwwoffle/ChangeLog
@@ -1,12 +1,18 @@
# ChangeLog for net-www/wwwoffle
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/wwwoffle/ChangeLog,v 1.4 2002/03/26 12:48:38 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/wwwoffle/ChangeLog,v 1.5 2002/06/02 21:40:57 wmertens Exp $
- 26 Mar 2002; Dan Armak <danarmak@gentoo.org>: general cleanup
- of the ebuild. Fix bug that made the default spooldir /var/tmp/portage/...
+*wwwoffle-2.7b (02 Jun 2002)
+
+ 02 Jun 2002; Wout Mertens <wmertens@gentoo.org>:
+ New mainstream version. This one fixes the problem where it wouldn't pass
+ on length information.
*wwwoffle-2.7-r1 (16 Mar 2002)
+ 26 Mar 2002; Dan Armak <danarmak@gentoo.org>: general cleanup
+ of the ebuild. Fix bug that made the default spooldir /var/tmp/portage/...
+
16 Mar 2002; Dan Armak <danarmak@gentoo.org> Changelog:
Now, if the wwwoffle init script is running, it is stopped before merging,
@@ -20,11 +26,3 @@
ebuild in various small ways.
*wwwoffle-2.6d-r6 (1 Feb 2002)
-
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
diff --git a/net-www/wwwoffle/files/digest-wwwoffle-2.7b b/net-www/wwwoffle/files/digest-wwwoffle-2.7b
new file mode 100644
index 000000000000..25ab061bb4cb
--- /dev/null
+++ b/net-www/wwwoffle/files/digest-wwwoffle-2.7b
@@ -0,0 +1 @@
+MD5 7fac446e5b74a173e76a2d729b09a93a wwwoffle-2.7b.tgz 857511
diff --git a/net-www/wwwoffle/wwwoffle-2.7b.ebuild b/net-www/wwwoffle/wwwoffle-2.7b.ebuild
new file mode 100644
index 000000000000..ece359723f76
--- /dev/null
+++ b/net-www/wwwoffle/wwwoffle-2.7b.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-www/wwwoffle/wwwoffle-2.7b.ebuild,v 1.1 2002/06/02 21:40:57 wmertens Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="wwwoffle = WWW Offline Explorer, an adv. caching proxy especially suitable for nonpermanent (e.g. dialup) Internet connections"
+
+SRC_URI="ftp://ftp.demon.co.uk/pub/unix/httpd/${P}.tgz
+ ftp://metalab.unc.edu/pub/Linux/apps/www/servers/${P}.tgz"
+
+HOMEPAGE="http://www.gedanken.demon.co.uk/"
+
+DEPEND="sys-devel/flex
+ sys-libs/zlib
+ sys-devel/gcc
+ virtual/glibc"
+
+
+src_compile() {
+
+ local myconf
+ use ipv6 && myconf="$myconf --with-ipv6" || myconf="$myconf --without-ipv6"
+ ./configure $myconf --prefix=/usr --with-confdir=/etc || die
+
+ emake || die
+
+}
+
+src_install () {
+
+ # Install the files
+ make prefix=${D}/usr SPOOLDIR=${D}/var/spool/wwwoffle CONFDIR=${D}/etc install || die
+
+ cd ${D}/etc
+ mv wwwoffle.conf 1
+ sed -e "s:${D}::" 1 > wwwoffle.conf
+ rm 1
+
+ # Install the wwwoffled init script
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/{wwwoffled-online,wwwoffled}
+
+ # someday i'll make it use the file in /etc. for now we at least get
+ # config file protection this way.
+ dosym /etc/wwwoffle.conf /var/spool/wwwoffle/wwwoffle.conf
+
+}
+
+pkg_preinst() {
+
+ source /etc/init.d/functions.sh
+ if [ -L ${svcdir}/started/wwwoffled ]; then
+ einfo "The wwwoffled init script is running. I'll stop it, merge the new files and
+restart the script."
+ /etc/init.d/wwwoffled stop
+ touch ${T}/restart
+ fi
+
+}
+
+pkg_postinst() {
+
+ if [ -f "${T}/restart" ]; then
+ einfo "Starting the wwwoffled initscript again..."
+ /etc/init.d/wwwoffled start
+ rm ${T}/restart
+ fi
+
+ # This simply prints out some useful instructions.
+ einfo "
+
+ -----------
+ What's Next
+ -----------
+
+ You have successfully installed wwwoffle.
+
+ To configure it, read and edit /etc/wwwoffle.conf.
+ It's well commented and very powerful. Alternatively, browse to
+ http://localhost:8080 and you'll be presented with a webform-based
+ configuration interface.
+
+ To start using wwwoffle:
+ 1. rc-update add wwwoffled to boot.
+ 2. rc-update add wwwoffled-online to your 'online' runlevels.
+ 3. Configure any programs to use localhost:8080 as a proxy server
+ for HTTP, HTTPS, FTP and finger.
+"
+
+}
+