summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-08-14 15:37:59 +0000
committerJustin Lecher <jlec@gentoo.org>2012-08-14 15:37:59 +0000
commit9d1c00b58902452d29e27c9621eba818405770fc (patch)
tree9b7a4caab70aba9b09876bfe854af24c228630e7 /sci-biology/mothur/mothur-1.13.0-r2.ebuild
parentsci-biology/uchime: New addition (diff)
downloadhistorical-9d1c00b58902452d29e27c9621eba818405770fc.tar.gz
historical-9d1c00b58902452d29e27c9621eba818405770fc.tar.bz2
historical-9d1c00b58902452d29e27c9621eba818405770fc.zip
sci-biology/mothur: Version BUmp; fix for buffer overflows, #431258
Package-Manager: portage-2.2.0_alpha121/cvs/Linux x86_64
Diffstat (limited to 'sci-biology/mothur/mothur-1.13.0-r2.ebuild')
-rw-r--r--sci-biology/mothur/mothur-1.13.0-r2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sci-biology/mothur/mothur-1.13.0-r2.ebuild b/sci-biology/mothur/mothur-1.13.0-r2.ebuild
new file mode 100644
index 000000000000..3dad5095a7ca
--- /dev/null
+++ b/sci-biology/mothur/mothur-1.13.0-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/mothur/mothur-1.13.0-r2.ebuild,v 1.1 2012/08/14 15:37:59 jlec Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A suite of algorithms for ecological bioinformatics"
+HOMEPAGE="http://www.mothur.org/"
+SRC_URI="mirror://gentoo/${P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="mpi +readline"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+RDEPEND="mpi? ( virtual/mpi )"
+
+S=${WORKDIR}/Mothur.source
+
+pkg_setup() {
+ use mpi && CXX=mpicxx || CXX=$(tc-getCXX)
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-makefile.patch \
+ "${FILESDIR}"/${P}-overflows.patch \
+ "${FILESDIR}"/${P}-overflows2.patch
+}
+
+use_yn() {
+ use $1 && echo "yes" || echo "no"
+}
+
+src_compile() {
+ emake USEMPI=$(use_yn mpi) USEREADLINE=$(use_yn readline) || die
+}
+
+src_install() {
+ dobin ${PN}
+}