summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2009-03-07 04:37:27 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2009-03-07 04:37:27 +0000
commitcc0f294be15509b84cb4652c173de102e39690a6 (patch)
treeb30ee7ce07867274434b04f31d2c9158cc38b2b2 /sci-biology/plink
parentamd64 stable, bug 259678 (diff)
downloadhistorical-cc0f294be15509b84cb4652c173de102e39690a6.tar.gz
historical-cc0f294be15509b84cb4652c173de102e39690a6.tar.bz2
historical-cc0f294be15509b84cb4652c173de102e39690a6.zip
New package sci-biology/plink, bug 224017
Package-Manager: portage-2.2_rc20/cvs/Linux 2.6.26-gentoo-r4 x86_64
Diffstat (limited to 'sci-biology/plink')
-rw-r--r--sci-biology/plink/ChangeLog7
-rw-r--r--sci-biology/plink/Manifest5
-rw-r--r--sci-biology/plink/files/plink-1.05-gcc43.patch49
-rw-r--r--sci-biology/plink/metadata.xml14
-rw-r--r--sci-biology/plink/plink-1.05.ebuild36
5 files changed, 111 insertions, 0 deletions
diff --git a/sci-biology/plink/ChangeLog b/sci-biology/plink/ChangeLog
new file mode 100644
index 000000000000..308221f90b68
--- /dev/null
+++ b/sci-biology/plink/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for sci-biology/plink
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/plink/ChangeLog,v 1.1 2009/03/07 04:37:27 weaver Exp $
+
+ 06 Mar 2009; Andrey Kislyuk <weaver@gentoo.org> ChangeLog:
+ New package, ebuild written by Neil Shephard <nshephard@gmail.com> and me
+
diff --git a/sci-biology/plink/Manifest b/sci-biology/plink/Manifest
new file mode 100644
index 000000000000..521eef71f882
--- /dev/null
+++ b/sci-biology/plink/Manifest
@@ -0,0 +1,5 @@
+AUX plink-1.05-gcc43.patch 1135 RMD160 64045e347eea27d5942e588471b9fec267cf98f1 SHA1 d60b24be74ea8aea8ab9984652191f5f261d1363 SHA256 4e0c2abfd70af32f91ae2ae80c276b7a83cda1b7ed06d4db8306055a835ad56c
+DIST plink-1.05-src.zip 2156559 RMD160 1ef44f9377d9de8ff849908209e0a6c9826c819b SHA1 2ab5488f99de9b666a92a9ff8be084cce8446d41 SHA256 597cdf6510f16d3f29b5a47dae7e6848ec9a18ada7044374dd2ce2c397734689
+EBUILD plink-1.05.ebuild 987 RMD160 cf7211cc06f10e3a3af6d74600cdf61e229f5839 SHA1 35c305f9bc252619a10226394bb4def30e018e9a SHA256 0e54a44da6fbecc21bdd69239f9536fdccf7150327faff1a0f2d0a513ce3f1f1
+MISC ChangeLog 345 RMD160 7791280db4374038d73f94f95a66499afea308c7 SHA1 061bff2de7d0b844491cc29e5fd54b517ac48143 SHA256 ce3ef64c6986b3f6694b8535a256c49879e886c0a17260d5b185f0a8f924308d
+MISC metadata.xml 381 RMD160 e48ef6a333ebf961070f902eb0aa29920cbc071e SHA1 14150562fbe14a321272afa502ac029cd1391405 SHA256 44fc0f6729e24f097dfac2b2e0f21de8e2bbc744241806260c62dd9a8376f544
diff --git a/sci-biology/plink/files/plink-1.05-gcc43.patch b/sci-biology/plink/files/plink-1.05-gcc43.patch
new file mode 100644
index 000000000000..84f813cc88e4
--- /dev/null
+++ b/sci-biology/plink/files/plink-1.05-gcc43.patch
@@ -0,0 +1,49 @@
+diff -durr plink-1.05-src-orig/helper.cpp plink-1.05-src/helper.cpp
+--- plink-1.05-src-orig/helper.cpp 2008-12-11 20:52:22.000000000 +0000
++++ plink-1.05-src/helper.cpp 2009-03-06 23:22:06.199103558 +0000
+@@ -36,7 +36,7 @@
+
+ extern ofstream LOG;
+ extern Plink * PP;
+-
++/*
+ template <class T>
+ bool from_string(T& t,
+ const std::string& s,
+@@ -45,7 +45,7 @@
+ std::istringstream iss(s);
+ return !(iss >> f >> t).fail();
+ }
+-
++*/
+ vector<bool> nvec_bool()
+ {
+ vector<bool> t(0);
+diff -durr plink-1.05-src-orig/helper.h plink-1.05-src/helper.h
+--- plink-1.05-src-orig/helper.h 2008-12-11 20:52:24.000000000 +0000
++++ plink-1.05-src/helper.h 2009-03-06 23:22:06.218353426 +0000
+@@ -18,6 +18,9 @@
+ #include <vector>
+ #include <cstdio>
+
++#include <iostream>
++#include <sstream>
++
+ #include "plink.h"
+
+ template<class T>
+@@ -89,7 +92,13 @@
+ template <class T>
+ bool from_string(T& t,
+ const std::string& s,
+- std::ios_base& (*f)(std::ios_base&));
++ std::ios_base& (*f)(std::ios_base&))
++{
++ std::istringstream iss(s);
++ return !(iss >> f >> t).fail();
++ }
++
++
+
+ void error(string);
+ void shutdown();
diff --git a/sci-biology/plink/metadata.xml b/sci-biology/plink/metadata.xml
new file mode 100644
index 000000000000..68fb68e6ac6e
--- /dev/null
+++ b/sci-biology/plink/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>weaver@gentoo.org</email>
+ <name>Andrey Kislyuk</name>
+ </maintainer>
+ <herd>sci-biology</herd>
+ <use>
+ <flag name='webcheck'>
+ add support for online update checking every time the program starts
+ </flag>
+ </use>
+</pkgmetadata>
diff --git a/sci-biology/plink/plink-1.05.ebuild b/sci-biology/plink/plink-1.05.ebuild
new file mode 100644
index 000000000000..17d8a31f5237
--- /dev/null
+++ b/sci-biology/plink/plink-1.05.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/plink/plink-1.05.ebuild,v 1.1 2009/03/07 04:37:27 weaver Exp $
+
+EAPI="1"
+
+inherit eutils
+
+DESCRIPTION="Whole genome association analysis toolset"
+HOMEPAGE="http://pngu.mgh.harvard.edu/~purcell/plink/"
+SRC_URI="http://pngu.mgh.harvard.edu/~purcell/plink/dist/${P}-src.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="-webcheck"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S="${WORKDIR}/${P}-src"
+
+# Package collides with net-misc/putty. Renamed to snplink following Debian.
+# Package contains bytecode-only jar gPLINK.jar. Ignored, notified upstream.
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${P}-*.patch
+ sed -i -e '/CXXFLAGS =/ s/^/#/' -e 's/-static//' "${S}/Makefile" || die
+ use webcheck || sed -i '/WITH_WEBCHECK =/ s/^/#/' "${S}/Makefile" || die
+}
+
+src_install() {
+ newbin plink snplink || die
+ dodoc README.txt
+}