summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2005-12-02 19:44:14 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2005-12-02 19:44:14 +0000
commita13ff1b3c616b08b120341d3f6c033ceece1cd43 (patch)
tree96bfaa9b66dba3164c86557c556d3955355de82d /sci-chemistry
parentBumps for fixing wrong rotation and handling filenames with spaces in epstopd... (diff)
downloadhistorical-a13ff1b3c616b08b120341d3f6c033ceece1cd43.tar.gz
historical-a13ff1b3c616b08b120341d3f6c033ceece1cd43.tar.bz2
historical-a13ff1b3c616b08b120341d3f6c033ceece1cd43.zip
New GUI front-end for computational chemistry.
Package-Manager: portage-2.0.53
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/viewmol/ChangeLog14
-rw-r--r--sci-chemistry/viewmol/Manifest8
-rw-r--r--sci-chemistry/viewmol/files/2.4.1-change-default-path-to-usr.patch11
-rw-r--r--sci-chemistry/viewmol/files/2.4.1-look-for-python-in-right-place.patch20
-rw-r--r--sci-chemistry/viewmol/files/2.4.1-remove-icc-check.patch23
-rw-r--r--sci-chemistry/viewmol/files/2.4.1-use-root-for-app-defaults.patch20
-rw-r--r--sci-chemistry/viewmol/files/digest-viewmol-2.4.11
-rw-r--r--sci-chemistry/viewmol/metadata.xml9
-rw-r--r--sci-chemistry/viewmol/viewmol-2.4.1.ebuild55
9 files changed, 161 insertions, 0 deletions
diff --git a/sci-chemistry/viewmol/ChangeLog b/sci-chemistry/viewmol/ChangeLog
new file mode 100644
index 000000000000..6856ed34c092
--- /dev/null
+++ b/sci-chemistry/viewmol/ChangeLog
@@ -0,0 +1,14 @@
+# ChangeLog for sci-chemistry/viewmol
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/viewmol/ChangeLog,v 1.1 2005/12/02 19:44:14 spyderous Exp $
+
+*viewmol-2.4.1 (02 Dec 2005)
+
+ 02 Dec 2005; Donnie Berkholz <spyderous@gentoo.org>;
+ +files/2.4.1-change-default-path-to-usr.patch,
+ +files/2.4.1-look-for-python-in-right-place.patch,
+ +files/2.4.1-remove-icc-check.patch,
+ +files/2.4.1-use-root-for-app-defaults.patch, +metadata.xml,
+ +viewmol-2.4.1.ebuild:
+ New GUI front-end for computational chemistry.
+
diff --git a/sci-chemistry/viewmol/Manifest b/sci-chemistry/viewmol/Manifest
new file mode 100644
index 000000000000..746c2c1cc3e4
--- /dev/null
+++ b/sci-chemistry/viewmol/Manifest
@@ -0,0 +1,8 @@
+MD5 bfb30e172262c2f0bf998bb0f0acfe51 ChangeLog 582
+MD5 7ec6e03425898d903cc0863bbea68381 files/2.4.1-change-default-path-to-usr.patch 311
+MD5 3fd613552407a159c1036b316cfd095d files/2.4.1-look-for-python-in-right-place.patch 866
+MD5 d4487f098914969de572d1163f7c3d57 files/2.4.1-remove-icc-check.patch 1214
+MD5 3f798d6a2471f94411c4235bf8a337f5 files/2.4.1-use-root-for-app-defaults.patch 827
+MD5 4732f6262cbd7d8ae4c3049992833024 files/digest-viewmol-2.4.1 67
+MD5 af1bfbb0777267a03e889b08173f2757 metadata.xml 248
+MD5 5b336577187fe0da4b9e21b9377280f2 viewmol-2.4.1.ebuild 1237
diff --git a/sci-chemistry/viewmol/files/2.4.1-change-default-path-to-usr.patch b/sci-chemistry/viewmol/files/2.4.1-change-default-path-to-usr.patch
new file mode 100644
index 000000000000..e5e22ffee893
--- /dev/null
+++ b/sci-chemistry/viewmol/files/2.4.1-change-default-path-to-usr.patch
@@ -0,0 +1,11 @@
+--- viewmol-2.4.1.orig/source/getrc.c 2004-10-20 05:54:35.000000000 -0700
++++ viewmol-2.4.1/source/getrc.c 2005-12-02 11:38:32.000000000 -0800
+@@ -87,7 +87,7 @@
+
+ static char viewmolpath[MAXLENLINE];
+
+-#define DEFAULTPATH "/usr/local/lib/viewmol"
++#define DEFAULTPATH "/usr/lib/viewmol"
+
+ int getrc(void)
+ {
diff --git a/sci-chemistry/viewmol/files/2.4.1-look-for-python-in-right-place.patch b/sci-chemistry/viewmol/files/2.4.1-look-for-python-in-right-place.patch
new file mode 100644
index 000000000000..4f981a0fd1cb
--- /dev/null
+++ b/sci-chemistry/viewmol/files/2.4.1-look-for-python-in-right-place.patch
@@ -0,0 +1,20 @@
+--- viewmol-2.4.1.orig/source/getmachine 2004-08-29 08:04:09.000000000 -0700
++++ viewmol-2.4.1/source/getmachine 2005-12-02 11:19:36.000000000 -0800
+@@ -156,7 +158,7 @@
+ echo "PNGINCLUDE = $pnginclude" >> .config.$os
+
+ # Python
+- list=`find /usr -name Python.h -print 2> /dev/null`
++ list=`find /usr/include -name Python.h -print 2> /dev/null`
+ version=`(for i in $list
+ do
+ dir=\`dirname $i\`
+@@ -179,7 +181,7 @@
+ echo "PYTHONINCLUDE = $pythoninclude" >> .config.$os
+ if [ "$version" != "" ]
+ then
+- pythonlib=`dirname \`find /usr -name "lib${version}*.a" -print 2> /dev/null | grep "$version/"\``
++ pythonlib=`dirname \`find /usr/lib -name "lib${version}*.a" -print 2> /dev/null | grep "$version/"\``
+ else
+ givehint
+ echo -n "Please enter the name of the directory where the Python library can be found: "
diff --git a/sci-chemistry/viewmol/files/2.4.1-remove-icc-check.patch b/sci-chemistry/viewmol/files/2.4.1-remove-icc-check.patch
new file mode 100644
index 000000000000..c328e9cc79ab
--- /dev/null
+++ b/sci-chemistry/viewmol/files/2.4.1-remove-icc-check.patch
@@ -0,0 +1,23 @@
+diff -urN viewmol-2.4.1.orig/source/getmachine viewmol-2.4.1/source/getmachine
+--- viewmol-2.4.1.orig/source/getmachine 2004-08-29 08:04:09.000000000 -0700
++++ viewmol-2.4.1/source/getmachine 2005-12-02 09:30:49.000000000 -0800
+@@ -269,19 +269,11 @@
+ makedir
+ cat ../.config.$os > makefile
+ use_icc=`type icc 2> /dev/null`
+- if [ "$use_icc" = "" ]
+- then
+ findProcessor
+ echo 'COMPILER=gcc' >> makefile
+ echo "OPT=-O6 -mcpu=$processor -fomit-frame-pointer -ffast-math -malign-double" >> makefile
+ echo 'CFLAGS=-Wall -I/usr/X11R6/include -DLINUX -Wno-strict-aliasing' >> makefile
+ echo "LDFLAGS=$LINKFORSHARED" >> makefile
+- else
+- echo 'COMPILER=icc' >> makefile
+- echo 'OPT=-O2 -ipo' >> makefile
+- echo 'CFLAGS=-I/opt/intel/compiler50/ia32/include -I/usr/X11R6/include -DLINUX' >> makefile
+- echo "LDFLAGS=$LINKFORSHARED -ipo" >> makefile
+- fi
+ echo 'SCANDIR=' >> makefile
+ echo 'INCLUDE=$(TIFFINCLUDE) -I$(PNGINCLUDE) -I$(PYTHONINCLUDE)' >> makefile
+ echo 'LIBRARY=$(LIBTIFF) $(LIBPNG) -L$(LIBPYTHON)' >> makefile
diff --git a/sci-chemistry/viewmol/files/2.4.1-use-root-for-app-defaults.patch b/sci-chemistry/viewmol/files/2.4.1-use-root-for-app-defaults.patch
new file mode 100644
index 000000000000..c04da305c144
--- /dev/null
+++ b/sci-chemistry/viewmol/files/2.4.1-use-root-for-app-defaults.patch
@@ -0,0 +1,20 @@
+--- viewmol-2.4.1.orig/source/install 2004-10-09 08:38:31.000000000 -0700
++++ viewmol-2.4.1/source/install 2005-12-02 11:34:35.000000000 -0800
+@@ -71,7 +71,7 @@
+ find $ROOT/lib/viewmol -type d -exec chmod a+rx {} \;
+ sed 's/\/source//g' viewmolrc > $ROOT/lib/viewmol/viewmolrc
+ chmod -R 644 $ROOT/lib/viewmol/viewmolrc
+-if [ -d /usr/X11R6/lib/X11/app-defaults ]
++if [ -d $ROOT/X11R6/lib/X11/app-defaults ]
+ then
+ locale=`echo $LANG | cut -c1-2`
+ if [ "$locale" = "en" ]
+@@ -82,6 +82,6 @@
+ # The C locale is defined by default for rpm builds, overwrite it
+ locale="en_US"
+ fi
+- cp locale/${locale}/Viewmol /usr/X11R6/lib/X11/app-defaults
+- chmod a+r /usr/X11R6/lib/X11/app-defaults/Viewmol
++ cp locale/${locale}/Viewmol $ROOT/X11R6/lib/X11/app-defaults
++ chmod a+r $ROOT/X11R6/lib/X11/app-defaults/Viewmol
+ fi
diff --git a/sci-chemistry/viewmol/files/digest-viewmol-2.4.1 b/sci-chemistry/viewmol/files/digest-viewmol-2.4.1
new file mode 100644
index 000000000000..9f267f02855f
--- /dev/null
+++ b/sci-chemistry/viewmol/files/digest-viewmol-2.4.1
@@ -0,0 +1 @@
+MD5 c88cc5641bffc14d749e9759a1c813ac viewmol-2.4.1.src.tgz 2229379
diff --git a/sci-chemistry/viewmol/metadata.xml b/sci-chemistry/viewmol/metadata.xml
new file mode 100644
index 000000000000..211b8bd0f0a4
--- /dev/null
+++ b/sci-chemistry/viewmol/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+<email>spyderous@gentoo.org</email>
+<name>Donnie Berkholz</name>
+</maintainer>
+</pkgmetadata>
diff --git a/sci-chemistry/viewmol/viewmol-2.4.1.ebuild b/sci-chemistry/viewmol/viewmol-2.4.1.ebuild
new file mode 100644
index 000000000000..1435448430e6
--- /dev/null
+++ b/sci-chemistry/viewmol/viewmol-2.4.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/viewmol/viewmol-2.4.1.ebuild,v 1.1 2005/12/02 19:44:14 spyderous Exp $
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Open-source graphical front end for computational chemistry programs"
+HOMEPAGE="http://viewmol.sourceforge.net/"
+SRC_URI="mirror://sourceforge/viewmol/${P}.src.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RDEPEND="media-libs/tiff
+ virtual/opengl
+ virtual/motif
+ media-libs/libpng
+ >=dev-lang/python-2.2
+ || ( (
+ x11-libs/libXmu
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXaw
+ )
+ virtual/x11
+ )"
+DEPEND="${RDEPEND}
+ || ( (
+ x11-proto/inputproto
+ x11-proto/xproto
+ )
+ virtual/x11
+ )"
+
+S="${WORKDIR}/${P}/source"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-remove-icc-check.patch
+ epatch ${FILESDIR}/${PV}-look-for-python-in-right-place.patch
+ epatch ${FILESDIR}/${PV}-use-root-for-app-defaults.patch
+ epatch ${FILESDIR}/${PV}-change-default-path-to-usr.patch
+}
+
+src_compile() {
+ ./getmachine
+ emake -j1 \
+ COMPILER=$(tc-getCC) \
+ OPT="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ ./install ${D}/usr || die
+}