summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Medinas <metalgod@gentoo.org>2006-07-02 23:17:07 +0000
committerLuis Medinas <metalgod@gentoo.org>2006-07-02 23:17:07 +0000
commit602217882b1944f02c476dd754a6b13acb7ccbf5 (patch)
tree2e2ba3f5fa81558a7c024c5519ebed20b4b55e6c /sci-physics
parentMoved sci-misc/lightspeed to sci-physics/lightspeed (diff)
downloadhistorical-602217882b1944f02c476dd754a6b13acb7ccbf5.tar.gz
historical-602217882b1944f02c476dd754a6b13acb7ccbf5.tar.bz2
historical-602217882b1944f02c476dd754a6b13acb7ccbf5.zip
Moved from sci-misc/mpb to sci-physics/mpb.
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/mpb/ChangeLog13
-rw-r--r--sci-physics/mpb/Manifest4
-rw-r--r--sci-physics/mpb/files/digest-mpb-1.4.21
-rw-r--r--sci-physics/mpb/metadata.xml6
-rw-r--r--sci-physics/mpb/mpb-1.4.2.ebuild68
5 files changed, 92 insertions, 0 deletions
diff --git a/sci-physics/mpb/ChangeLog b/sci-physics/mpb/ChangeLog
new file mode 100644
index 000000000000..adb4fe01bf80
--- /dev/null
+++ b/sci-physics/mpb/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for sci-misc/mpb
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/mpb/ChangeLog,v 1.1 2006/07/02 23:17:07 metalgod Exp $
+
+ 02 Jul 2006; Luis Medinas <metalgod@gentoo.org> +metadata.xml,
+ +mpb-1.4.2.ebuild:
+ Moved from sci-misc/mpb to sci-physics/mpb.
+
+*mpb-1.4.2 (04 Jan 2006)
+
+ 04 Jan 2006; Peter Bienstman <pbienst@gentoo.org> +mpb-1.4.2.ebuild:
+ New ebuild (closes #36581).
+
diff --git a/sci-physics/mpb/Manifest b/sci-physics/mpb/Manifest
new file mode 100644
index 000000000000..84d3cfc6c15f
--- /dev/null
+++ b/sci-physics/mpb/Manifest
@@ -0,0 +1,4 @@
+MD5 fb3b501f1ab8f7069200dff043c9f886 ChangeLog 326
+MD5 2e7f5ed5cdc4b9b1f359611041c5d30a files/digest-mpb-1.4.2 61
+MD5 19d4f5e8734023708b8b8081270e9d4e metadata.xml 157
+MD5 219910bca80eb39ba8968b424b924053 mpb-1.4.2.ebuild 1676
diff --git a/sci-physics/mpb/files/digest-mpb-1.4.2 b/sci-physics/mpb/files/digest-mpb-1.4.2
new file mode 100644
index 000000000000..b4fef82d9dd1
--- /dev/null
+++ b/sci-physics/mpb/files/digest-mpb-1.4.2
@@ -0,0 +1 @@
+MD5 e1e618b0db343a7a3fc38eabd69d008b mpb-1.4.2.tar.gz 686488
diff --git a/sci-physics/mpb/metadata.xml b/sci-physics/mpb/metadata.xml
new file mode 100644
index 000000000000..f3c63d4e560a
--- /dev/null
+++ b/sci-physics/mpb/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+</pkgmetadata>
+
diff --git a/sci-physics/mpb/mpb-1.4.2.ebuild b/sci-physics/mpb/mpb-1.4.2.ebuild
new file mode 100644
index 000000000000..034831656018
--- /dev/null
+++ b/sci-physics/mpb/mpb-1.4.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/mpb/mpb-1.4.2.ebuild,v 1.1 2006/07/02 23:17:07 metalgod Exp $
+
+DESCRIPTION="Program for computing the band structures and electromagnetic modes of periodic dielectric structures"
+SRC_URI="http://ab-initio.mit.edu/mpb/${P}.tar.gz"
+HOMEPAGE="http://ab-initio.mit.edu/mpb/"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+SLOT="0"
+
+DEPEND="virtual/lapack
+ sci-libs/libctl
+ sci-libs/hdf5
+ =sci-libs/fftw-2.1.5-r1
+ sys-libs/readline"
+RDEPEND="=sci-libs/fftw-2.1.5-r1"
+
+src_unpack() {
+ unpack ${A}
+
+ # Create directories to compile the versions with inversion symmetry
+ # and with hermitian eps.
+
+ cp -r ${S} ${S}_inv
+ cp -r ${S} ${S}_herm
+}
+
+src_compile() {
+ # Create the normal version (mpb).
+ cd ${S}
+ econf || die
+ MAKEOPTS="-j1" emake || die # Parallel 'make' gives syntax errors.
+
+ # Create the version with inversion symmetry (mpbi).
+ cd ${S}_inv
+ econf --with-inv-symmetry || die
+ MAKEOPTS="-j1" emake || die
+
+ # Create the version with hermitian eps (mpbh).
+ cd ${S}_herm
+ econf --with-hermitian-eps || die
+ MAKEOPTS="-j1" emake || die
+}
+
+src_install() {
+
+ cd ${S}
+ einstall || die
+
+ dodoc README COPYING NEWS AUTHORS COPYRIGHT ChangeLog TODO
+ dohtml doc/*
+
+ # Install mpbi and mpbh as well.
+
+ mv ${S}_inv/mpb-ctl/.mpb ${S}_inv/mpb-ctl/mpbi
+ dobin ${S}_inv/mpb-ctl/mpbi
+
+ mv ${S}_herm/mpb-ctl/.mpb ${S}_herm/mpb-ctl/mpbh
+ dobin ${S}_herm/mpb-ctl/mpbh
+
+ einfo "Three versions of mpb have been installed:"
+ einfo "mpb : regular version"
+ einfo "mpbi : configured for inversion symmetry"
+ einfo "mpbh : configured for hermitian epsilon"
+}