summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-01-13 20:07:52 +0000
committerAchim Gottinger <achim@gentoo.org>2001-01-13 20:07:52 +0000
commite0bcb4d5442b6e1e855122a9a485add0031c45aa (patch)
treeda81203634c946255e2198f397d5fd7284f67e77 /sys-apps/gluelog
parent*** empty log message *** (diff)
downloadhistorical-e0bcb4d5442b6e1e855122a9a485add0031c45aa.tar.gz
historical-e0bcb4d5442b6e1e855122a9a485add0031c45aa.tar.bz2
historical-e0bcb4d5442b6e1e855122a9a485add0031c45aa.zip
*** empty log message ***
Diffstat (limited to 'sys-apps/gluelog')
-rwxr-xr-xsys-apps/gluelog/files/svc-klog6
-rwxr-xr-xsys-apps/gluelog/files/svc-syslog8
-rw-r--r--sys-apps/gluelog/gluelog-1.0-r1.ebuild8
3 files changed, 11 insertions, 11 deletions
diff --git a/sys-apps/gluelog/files/svc-klog b/sys-apps/gluelog/files/svc-klog
index a366f6411215..129ed7c0af4a 100755
--- a/sys-apps/gluelog/files/svc-klog
+++ b/sys-apps/gluelog/files/svc-klog
@@ -3,17 +3,17 @@
. /etc/rc.d/config/functions
-SERVICE=svc-klog
+SERVICE=klog
opts="start stop"
start() {
- ebegin "Starting ${SERVICE}"
+ ebegin "Starting supervised ${SERVICE}"
ln -sf ../services/${SERVICE} ${SVCDIR}/control/${SERVICE}
eend $?
}
stop() {
- ebegin "Stopping ${SERVICE}"
+ ebegin "Stopping supervised ${SERVICE}"
if [ -e ${SVCDIR}/control/${SERVICE} ]
then
/usr/bin/svc -dx ${SVCDIR}/control/${SERVICE}
diff --git a/sys-apps/gluelog/files/svc-syslog b/sys-apps/gluelog/files/svc-syslog
index b3f3791c8b02..3329fcbdfdc7 100755
--- a/sys-apps/gluelog/files/svc-syslog
+++ b/sys-apps/gluelog/files/svc-syslog
@@ -3,17 +3,17 @@
. /etc/rc.d/config/functions
-SERVICE=svc-syslog
+SERVICE=syslog
opts="start stop"
start() {
- ebegin "Starting ${SERVICE}"
+ ebegin "Starting supervised ${SERVICE}"
ln -sf ../services/${SERVICE} ${SVCDIR}/control/${SERVICE}
- eend $retval
+ eend $?
}
stop() {
- ebegin "Stopping ${SERVICE}"
+ ebegin "Stopping supervised ${SERVICE}"
if [ -e ${SVCDIR}/control/${SERVICE} ]
then
/usr/bin/svc -dx ${SVCDIR}/control/${SERVICE}
diff --git a/sys-apps/gluelog/gluelog-1.0-r1.ebuild b/sys-apps/gluelog/gluelog-1.0-r1.ebuild
index c78fc96594f3..04c1b5d91052 100644
--- a/sys-apps/gluelog/gluelog-1.0-r1.ebuild
+++ b/sys-apps/gluelog/gluelog-1.0-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gluelog/gluelog-1.0-r1.ebuild,v 1.2 2000/12/24 05:26:23 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gluelog/gluelog-1.0-r1.ebuild,v 1.3 2001/01/13 20:07:52 achim Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Pipe and socket fittings for the system and kernel logs"
@@ -22,15 +22,15 @@ src_install() {
dodir /usr/sbin
dosbin ${S}/gluelog ${S}/glueklog
exeopts -m0750 -g wheel
- install -d -m0750 -o root -g wheel ${D}/etc/supervise
dodir /var/log
local x
for x in syslog klog
do
- exeinto /var/supervise/${x}
+ exeinto /var/lib/supervise/services/${x}
newexe ${FILESDIR}/${x}-run run
- ln -s /var/supervise/${x} ${D}/etc/supervise/${x}
install -d -m0750 -o daemon -g wheel ${D}/var/log/${x}.d
+ exeinto /etc/rc.d/init.d
+ doexe ${FILESDIR}/svc-${x}
done
}