summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-03-31 07:34:19 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-03-31 07:34:19 +0000
commit2780871d74bc2ae68f4a8f720b12520aa6425fd4 (patch)
treee3ab6a858f4950e93aabe91d463c0009def853dc /sys-apps/modutils
parentVersion bump (diff)
downloadhistorical-2780871d74bc2ae68f4a8f720b12520aa6425fd4.tar.gz
historical-2780871d74bc2ae68f4a8f720b12520aa6425fd4.tar.bz2
historical-2780871d74bc2ae68f4a8f720b12520aa6425fd4.zip
bump commit 1
Diffstat (limited to 'sys-apps/modutils')
-rw-r--r--sys-apps/modutils/modutils-2.4.25.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/sys-apps/modutils/modutils-2.4.25.ebuild b/sys-apps/modutils/modutils-2.4.25.ebuild
new file mode 100644
index 000000000000..a4e6d6cfc5b9
--- /dev/null
+++ b/sys-apps/modutils/modutils-2.4.25.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/modutils/modutils-2.4.25.ebuild,v 1.1 2003/03/31 07:34:19 lostlogic Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Standard kernel module utilities"
+SRC_URI="http://www.kernel.org/pub/linux/utils/kernel/${PN}/v2.4/${P}.tar.bz2"
+HOMEPAGE="http://www.kernel.org/pub/linux/utils/kernel/modutils/"
+KEYWORDS="x86 ~ppc sparc ~alpha ~hppa ~arm"
+SLOT="0"
+LICENSE="GPL-2"
+DEPEND="virtual/glibc"
+PROVIDE="virtual/module-tools"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/util
+ cat ${FILESDIR}/alias.h.diff | patch -p0 || die
+}
+
+src_compile() {
+ filter-flags -fPIC
+ myconf=""
+ # see bug #3897 ... we need insmod static, as libz.so is in /usr/lib
+ #
+ # Final resolution ... dont make it link against zlib, as the static
+ # version do not want to autoload modules :(
+ myconf="${myconf} --disable-zlib"
+
+ econf \
+ --prefix=/ \
+ --disable-strip \
+ --enable-insmod-static \
+ ${myconf} || die "./configure failed"
+ if [ ${ARCH} = "hppa" ]
+ then
+ mymake="ARCH=hppa"
+ fi
+
+ emake ${mymake} || die "emake failed"
+}
+
+src_install() {
+ if [ ${ARCH} = "hppa" ]
+ then
+ mymake="ARCH=hppa"
+ fi
+ einstall prefix="${D}" ${mymake} || die "make install failed"
+
+ dodoc COPYING CREDITS ChangeLog NEWS README TODO
+}
+