summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-01-06 16:16:51 +0000
committerAron Griffis <agriffis@gentoo.org>2004-01-06 16:16:51 +0000
commit4c6900227764b387c1945c19e2366d68732b8847 (patch)
treefa31803c9209a45f29f3ad5d2199b39bac0bda27 /sys-apps/slocate
parentbump rev to carry in config change (diff)
downloadhistorical-4c6900227764b387c1945c19e2366d68732b8847.tar.gz
historical-4c6900227764b387c1945c19e2366d68732b8847.tar.bz2
historical-4c6900227764b387c1945c19e2366d68732b8847.zip
bump rev to carry in config change
Diffstat (limited to 'sys-apps/slocate')
-rw-r--r--sys-apps/slocate/Manifest4
-rw-r--r--sys-apps/slocate/files/digest-slocate-2.7-r41
-rw-r--r--sys-apps/slocate/slocate-2.7-r4.ebuild76
3 files changed, 79 insertions, 2 deletions
diff --git a/sys-apps/slocate/Manifest b/sys-apps/slocate/Manifest
index 662ba19637e0..4983cc29cf62 100644
--- a/sys-apps/slocate/Manifest
+++ b/sys-apps/slocate/Manifest
@@ -1,8 +1,8 @@
-MD5 3b68730ff5596988d2de524307d264d4 ChangeLog 3808
+MD5 d8765cd880df34806082de715e3f574d ChangeLog 3995
MD5 9a0d03adcb00d7a3a7adc6cf8e6b1781 slocate-2.7-r2.ebuild 2204
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 89178d2acbcd5d37b4e413a7a3b82745 slocate-2.7-r3.ebuild 2325
-MD5 89178d2acbcd5d37b4e413a7a3b82745 slocate-2.7-r4.ebuild 2325
+MD5 4a748eec6cfcca8325a00cede7cf988a slocate-2.7-r4.ebuild 2324
MD5 174498f3041f595529585601c5379c5b files/updatedb.conf 602
MD5 f03ed3063ac796dbf26187038a928db8 files/digest-slocate-2.7-r2 62
MD5 f03ed3063ac796dbf26187038a928db8 files/digest-slocate-2.7-r4 62
diff --git a/sys-apps/slocate/files/digest-slocate-2.7-r4 b/sys-apps/slocate/files/digest-slocate-2.7-r4
new file mode 100644
index 000000000000..f312912325b1
--- /dev/null
+++ b/sys-apps/slocate/files/digest-slocate-2.7-r4
@@ -0,0 +1 @@
+MD5 4872830642ea2ed5f9aff932720583c9 slocate-2.7.tar.gz 87240
diff --git a/sys-apps/slocate/slocate-2.7-r4.ebuild b/sys-apps/slocate/slocate-2.7-r4.ebuild
new file mode 100644
index 000000000000..4f98aafd22e0
--- /dev/null
+++ b/sys-apps/slocate/slocate-2.7-r4.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/slocate/slocate-2.7-r4.ebuild,v 1.1 2004/01/06 16:16:43 agriffis Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="secure way to index and quickly search for files on your system (drop-in replacement for 'locate')"
+HOMEPAGE="http://www.geekreview.org/slocate/"
+SRC_URI="ftp://ftp.geekreview.org/slocate/src/slocate-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~alpha ~hppa ~mips ~ia64 ppc64"
+
+DEPEND="sys-apps/shadow
+ >=sys-apps/sed-4"
+
+src_compile() {
+ filter-flags -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
+ econf || die
+ emake || die
+}
+
+src_install() {
+ dodir /usr/share/man/man1
+
+ sed -i -e "/groupadd/s/^/#/;/chown.*slocate/s/^/#/" Makefile || die
+ make DESTDIR=${D} install || die
+
+ # make install for this package is blocked by sandbox
+ dosym slocate /usr/bin/locate
+ dosym slocate /usr/bin/updatedb
+ fperms 0755 /etc/cron.daily/slocate
+ keepdir /var/lib/slocate
+
+ # If this file doesn't exist, the first run of updatedb will create
+ # it anyway. But doing this shuts it up.
+ if [ ! -f ${ROOT}/var/lib/slocate/slocate.db ] ; then
+ touch ${D}/var/lib/slocate/slocate.db
+ fi
+
+ dodoc INSTALL LICENSE COPYING AUTHORS NEWS README ChangeLog
+
+ # man page fixing
+ rm -rf ${D}/usr/share/man/man1/locate.1.gz
+ dosym slocate.1.gz /usr/share/man/man1/locate.1.gz
+
+
+ insinto /etc
+ doins ${FILESDIR}/updatedb.conf
+ fperms 0644 /etc/updatedb.conf
+}
+
+pkg_postinst() {
+ touch /var/lib/slocate/slocate.db
+
+ # /var/lib/slocate is owned by group slocate and so is the executable
+ if ! groupmod slocate; then
+ groupadd slocate 2> /dev/null || die "Failed to create slocate group"
+ fi
+
+ chown root:slocate /usr/bin/slocate
+
+ # If nobody else minds I'd like to see 2711 become the system wide default. -solar
+ has sfperms ${FEATURES} && chmod 2711 /usr/bin/slocate || chmod 2755 /usr/bin/slocate
+
+ chown -R root:slocate /var/lib/slocate
+ chmod 0750 /var/lib/slocate
+
+ ewarn "If you merged slocate-2.7.ebuild, please remove"
+ ewarn "/etc/cron.daily/slocate.cron the .cron is no longer"
+ ewarn "in the filename"
+ echo
+ einfo "Note that the /etc/updatedb.conf file is generic"
+ einfo "Please customize it to your system requirements"
+}