summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2005-12-17 20:20:29 +0000
committerBryan Østergaard <kloeri@gentoo.org>2005-12-17 20:20:29 +0000
commita0dffe13b8605eab2b585a889c0ea3b994569ae4 (patch)
tree999b61295f934bc3f75a816ec78ee55bc629b132 /sys-boot
parentAdded ~ppc64; bug #97355 (diff)
downloadhistorical-a0dffe13b8605eab2b585a889c0ea3b994569ae4.tar.gz
historical-a0dffe13b8605eab2b585a889c0ea3b994569ae4.tar.bz2
historical-a0dffe13b8605eab2b585a889c0ea3b994569ae4.zip
Fix gcc-3.4 compilation, bug 115337.
Package-Manager: portage-2.0.51.22-r3
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/aboot/ChangeLog6
-rw-r--r--sys-boot/aboot/Manifest15
-rw-r--r--sys-boot/aboot/aboot-1.0_pre20040408.ebuild5
-rw-r--r--sys-boot/aboot/files/aboot-gcc-3.4.patch31
4 files changed, 48 insertions, 9 deletions
diff --git a/sys-boot/aboot/ChangeLog b/sys-boot/aboot/ChangeLog
index 332dde64a475..6e82c73075e3 100644
--- a/sys-boot/aboot/ChangeLog
+++ b/sys-boot/aboot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-boot/aboot
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/aboot/ChangeLog,v 1.7 2005/03/01 23:06:36 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/aboot/ChangeLog,v 1.8 2005/12/17 20:20:29 kloeri Exp $
+
+ 17 Dec 2005; Bryan Østergaard <kloeri@gentoo.org
+ +files/aboot-gcc-3.4.patch, aboot-1.0_pre20040408.ebuild:
+ Fix gcc-3.4 compilation, bug 115337.
02 Mar 2005; Bryan Østergaard <kloeri@gentoo.org>
aboot-1.0_pre20040408.ebuild:
diff --git a/sys-boot/aboot/Manifest b/sys-boot/aboot/Manifest
index 7cafcc7ed594..f5b49d3b0a29 100644
--- a/sys-boot/aboot/Manifest
+++ b/sys-boot/aboot/Manifest
@@ -1,17 +1,18 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 6d6f18940be87b343f837f949927ca54 ChangeLog 1228
+MD5 014fb4b10ddaa4acf182d9489ce1a605 ChangeLog 1380
+MD5 18b761437ec9eae073e7fa508f742fe1 aboot-1.0_pre20040408.ebuild 1930
MD5 0ed40e134501a252bb21c5c5808d8028 metadata.xml 158
-MD5 1835efe83027d5d274ef01db37faa1a0 aboot-1.0_pre20040408.ebuild 1872
MD5 9cf70ec6a8a046d2fd23021c21de3dd8 aboot-0.9-r1.ebuild 1900
MD5 254f0c6b0c0862df2ecd486daab0bbf9 files/aboot.conf 295
-MD5 963ee6f184a7fecbcbec48b5b8af534d files/digest-aboot-0.9-r1 66
MD5 746d744469877288661af19f5f0f5d12 files/digest-aboot-1.0_pre20040408 74
+MD5 963ee6f184a7fecbcbec48b5b8af534d files/digest-aboot-0.9-r1 66
+MD5 fdda13c08b553b8296ab0f41c3bbee46 files/aboot-gcc-3.4.patch 830
-----BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.0 (GNU/Linux)
+Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFCJPWHugEuf3OQ0akRAoabAKCHfLEyqT64TgZOGrOKb8sxqpuiNwCeL5zB
-7hum5xW8LHocG7MU8h3lq+I=
-=qaF3
+iD8DBQFDpIGPugEuf3OQ0akRArIbAJ0WXwZ398EtUNrvE+tFl35UnekH0wCeObYb
+pPu0eVttCQeac3VOaQPgQ2g=
+=X7o7
-----END PGP SIGNATURE-----
diff --git a/sys-boot/aboot/aboot-1.0_pre20040408.ebuild b/sys-boot/aboot/aboot-1.0_pre20040408.ebuild
index 3f2f08d1a735..ceeeafadbf8d 100644
--- a/sys-boot/aboot/aboot-1.0_pre20040408.ebuild
+++ b/sys-boot/aboot/aboot-1.0_pre20040408.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/aboot/aboot-1.0_pre20040408.ebuild,v 1.5 2005/03/01 23:06:36 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/aboot/aboot-1.0_pre20040408.ebuild,v 1.6 2005/12/17 20:20:29 kloeri Exp $
+
+inherit eutils
DESCRIPTION="Alpha Linux boot loader for SRM"
HOMEPAGE="http://aboot.sourceforge.net/"
@@ -18,6 +20,7 @@ src_unpack() {
unpack ${A}
cd ${S}
sed -i "s:/usr/man:/usr/share/man:" Makefile || die
+ epatch "${FILESDIR}/aboot-gcc-3.4.patch"
}
src_compile() {
diff --git a/sys-boot/aboot/files/aboot-gcc-3.4.patch b/sys-boot/aboot/files/aboot-gcc-3.4.patch
new file mode 100644
index 000000000000..24da18ce8190
--- /dev/null
+++ b/sys-boot/aboot/files/aboot-gcc-3.4.patch
@@ -0,0 +1,31 @@
+--- aboot-1.0_pre20040408/cons.c
++++ aboot-1.0_pre20040408/cons.c
+@@ -20,7 +20,6 @@
+ #endif
+
+ long cons_dev; /* console device */
+-extern long int dispatch(); /* Need the full 64 bit return here...*/
+
+ long
+ cons_puts(const char *str, long len)
+--- aboot-1.0_pre20040408/fs/ext2.c
++++ aboot-1.0_pre20040408/fs/ext2.c
+@@ -6,6 +6,7 @@
+ * This file has been ported from the DEC 32-bit Linux version
+ * by David Mosberger (davidm@cs.arizona.edu).
+ */
++#include <string.h>
+ #include <linux/stat.h>
+ #include <linux/types.h>
+ #include <linux/version.h>
+--- aboot-1.0_pre20040408/include/cons.h
++++ aboot-1.0_pre20040408/include/cons.h
+@@ -3,7 +3,7 @@
+
+ extern long cons_dev; /* console device */
+
+-extern long dispatch(long proc, ...);
++extern long int dispatch(long proc, ...);
+
+ #ifdef TESTING
+ #define STRINGIFY(sym) #sym