summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Wever <weeve@gentoo.org>2004-01-07 15:29:59 +0000
committerJason Wever <weeve@gentoo.org>2004-01-07 15:29:59 +0000
commit6d5bd151f4bd7abbec8c6629b64be204d16d2437 (patch)
tree413a7ba9bc297b1fea0f904cb394c4458d45668e /sys-cluster/lam-mpi
parentAdded 6.5.6-r1 back into the repository as it was the last stable version for... (diff)
downloadhistorical-6d5bd151f4bd7abbec8c6629b64be204d16d2437.tar.gz
historical-6d5bd151f4bd7abbec8c6629b64be204d16d2437.tar.bz2
historical-6d5bd151f4bd7abbec8c6629b64be204d16d2437.zip
Added 6.5.6-r1 back into the repository as it was the last stable version for sparc and broke dependencies by being removed.
Diffstat (limited to 'sys-cluster/lam-mpi')
-rw-r--r--sys-cluster/lam-mpi/Manifest4
-rw-r--r--sys-cluster/lam-mpi/files/digest-lam-mpi-6.5.6-r11
-rw-r--r--sys-cluster/lam-mpi/lam-mpi-6.5.6-r1.ebuild57
3 files changed, 60 insertions, 2 deletions
diff --git a/sys-cluster/lam-mpi/Manifest b/sys-cluster/lam-mpi/Manifest
index 344807c47111..7f1cb159903a 100644
--- a/sys-cluster/lam-mpi/Manifest
+++ b/sys-cluster/lam-mpi/Manifest
@@ -1,9 +1,9 @@
-MD5 258003ffdf3afa57faf3adca815ffb0e ChangeLog 2658
+MD5 5a3a51d676ad78e3fb14f9f9ead62755 ChangeLog 2891
MD5 24f54487f4cda94bd10c7fb200ed976e lam-mpi-7.0.3.ebuild 1427
MD5 218d80be782fd68f7f8001b2b6ace932 lam-mpi-6.5.9-r1.ebuild 1543
MD5 e01195aefff35e7a7362accba521b71a lam-mpi-7.0.2.ebuild 1425
MD5 cde8b4e93c9339eb99fe3ad45941c99b metadata.xml 160
-MD5 f16300389f1b3562c7b2aabb38ba4db4 lam-mpi-6.5.6-r1.ebuild 1474
+MD5 48931169ab030c051710ed5e9d363e43 lam-mpi-6.5.6-r1.ebuild 1460
MD5 f99c2a4c1cbbfd97415b800afca5d343 files/digest-lam-mpi-7.0.3 63
MD5 b2a92a68d13d42103750c61268d9ef19 files/digest-lam-mpi-6.5.6-r1 63
MD5 e897a667e2ca42d134950b2c85a4b4e3 files/digest-lam-mpi-6.5.9-r1 63
diff --git a/sys-cluster/lam-mpi/files/digest-lam-mpi-6.5.6-r1 b/sys-cluster/lam-mpi/files/digest-lam-mpi-6.5.6-r1
new file mode 100644
index 000000000000..4d564991aa7a
--- /dev/null
+++ b/sys-cluster/lam-mpi/files/digest-lam-mpi-6.5.6-r1
@@ -0,0 +1 @@
+MD5 97884838b7b0299f3a095d0b2a9f9ef1 lam-6.5.6.tar.bz2 1303693
diff --git a/sys-cluster/lam-mpi/lam-mpi-6.5.6-r1.ebuild b/sys-cluster/lam-mpi/lam-mpi-6.5.6-r1.ebuild
new file mode 100644
index 000000000000..9d26f01d0b6c
--- /dev/null
+++ b/sys-cluster/lam-mpi/lam-mpi-6.5.6-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/lam-mpi/lam-mpi-6.5.6-r1.ebuild,v 1.4 2004/01/07 15:29:51 weeve Exp $
+
+Name="lam"
+S=${WORKDIR}/${Name}-${PV}
+
+DESCRIPTION="the LAM MPI parallel computing environment"
+SRC_URI="http://www.lam-mpi.org/download/files/${Name}-${PV}.tar.bz2"
+HOMEPAGE="http://www.lam-mpi.org"
+
+DEPEND="virtual/glibc"
+# we need ssh if we want to use it instead of rsh
+RDEPEND="net-misc/openssh"
+
+SLOT="6"
+KEYWORDS="x86 sparc "
+LICENSE="as-is"
+
+PROVIDE="dev-libs/lam-mpi"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/romio/util/
+ mv romioinstall.in romioinstall.in-orig
+ sed -e "s|docdir=\"\$datadir/lam/doc\"|docdir=\"${D}/usr/share/doc/${PF}\"|" romioinstall.in-orig >romioinstall.in
+
+}
+
+src_compile() {
+ ./configure \
+ --infodir=/usr/share/info --mandir=/usr/share/man --prefix=/usr \
+ --host="${CHOST}" --with-cflags="${CFLAGS}" \
+ --sysconfdir=/etc/lam-mpi \
+ --with-cxxflags="${CXXFLAGS}" --with-rsh="ssh -x" || die
+
+ # sometimes emake doesn't finish since it gets ahead of itself :)
+
+ make || die
+
+}
+
+src_install () {
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man infodir=${D}/usr/share/info \
+ sysconfdir=${D}/etc/lam-mpi install || die
+
+ #need to correct the produced absolute symlink
+ cd ${D}/usr/include
+ rm mpi++.h
+ ln -sf mpi2c++/mpi++.h mpi++.h
+
+ dodoc README HISTORY LICENSE RELEASE_NOTES VERSION
+}
+