summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoel Martin <kanaka@gentoo.org>2006-01-11 14:51:09 +0000
committerJoel Martin <kanaka@gentoo.org>2006-01-11 14:51:09 +0000
commitb4c5e3f29c44e5e001e922158040ca204034b7a5 (patch)
treee7bd4646a11903312e42bd91c62f4fd91c1efc4c /sys-cluster
parentAdd mpich2 USE flags: fast, cxx, and mpe (diff)
downloadhistorical-b4c5e3f29c44e5e001e922158040ca204034b7a5.tar.gz
historical-b4c5e3f29c44e5e001e922158040ca204034b7a5.tar.bz2
historical-b4c5e3f29c44e5e001e922158040ca204034b7a5.zip
Create mpich2 ebuild for version 1.0.2-p1
Package-Manager: portage-2.0.53
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/mpich2/ChangeLog10
-rw-r--r--sys-cluster/mpich2/Manifest14
-rw-r--r--sys-cluster/mpich2/files/digest-mpich2-1.0.2_p11
-rw-r--r--sys-cluster/mpich2/metadata.xml9
-rw-r--r--sys-cluster/mpich2/mpich2-1.0.2_p1.ebuild86
5 files changed, 120 insertions, 0 deletions
diff --git a/sys-cluster/mpich2/ChangeLog b/sys-cluster/mpich2/ChangeLog
new file mode 100644
index 000000000000..c8f971366fd8
--- /dev/null
+++ b/sys-cluster/mpich2/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-cluster/mpich2
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/ChangeLog,v 1.1 2006/01/11 14:51:09 kanaka Exp $
+
+*mpich2-1.0.2_p1 (27 Dec 2005)
+
+ 27 Dec 2005; Joel Martin <kanaka@gentoo.org> +metadata.xml,
+ +mpich2-1.0.2_p1.ebuild:
+ Create mpich2 ebuild for version 1.0.2-p1
+
diff --git a/sys-cluster/mpich2/Manifest b/sys-cluster/mpich2/Manifest
new file mode 100644
index 000000000000..d2c1b70b239e
--- /dev/null
+++ b/sys-cluster/mpich2/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 45362bf755dc5da0beaaf4857b80f56c ChangeLog 375
+MD5 71c1e71efad6c6deaef7a04cb6c7e9db files/digest-mpich2-1.0.2_p1 68
+MD5 8030c8b7656ad8112a5f870431e95932 metadata.xml 249
+MD5 bce4f67882911bc523c6c9afcf030cbf mpich2-1.0.2_p1.ebuild 2262
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDxRxEbaW+3NC9cLgRAn/yAJwIJaAIbrPGoeVbRNar7bINBAe2XQCfZM/f
+2NeuQIx7EMrf7IZ1obe6JGw=
+=909K
+-----END PGP SIGNATURE-----
diff --git a/sys-cluster/mpich2/files/digest-mpich2-1.0.2_p1 b/sys-cluster/mpich2/files/digest-mpich2-1.0.2_p1
new file mode 100644
index 000000000000..7e5a35b1d224
--- /dev/null
+++ b/sys-cluster/mpich2/files/digest-mpich2-1.0.2_p1
@@ -0,0 +1 @@
+MD5 04d38fce64900d5216da067de44fb780 mpich2-1.0.2p1.tar.gz 12172068
diff --git a/sys-cluster/mpich2/metadata.xml b/sys-cluster/mpich2/metadata.xml
new file mode 100644
index 000000000000..e65ae05eb91d
--- /dev/null
+++ b/sys-cluster/mpich2/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>cluster</herd>
+<maintainer>
+ <email>kanaka@gentoo.org</email>
+ <name>Joel Martin</name>
+</maintainer>
+</pkgmetadata>
diff --git a/sys-cluster/mpich2/mpich2-1.0.2_p1.ebuild b/sys-cluster/mpich2/mpich2-1.0.2_p1.ebuild
new file mode 100644
index 000000000000..094766fd3738
--- /dev/null
+++ b/sys-cluster/mpich2/mpich2-1.0.2_p1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.0.2_p1.ebuild,v 1.1 2006/01/11 14:51:09 kanaka Exp $
+
+inherit eutils
+
+# Set the MPICH_CONFIGURE_OPTS environment variable to change the signal
+# mpich listens on or any other custom options (#38207).
+# The default USR1 conflicts with pthreads. Options include SIGUSR2 and SIGBUS.
+# For example: MPICH_CONFIGURE_OPTS="--with-device=ch_p4:-listener_sig=SIGBUS"
+
+DESCRIPTION="MPICH2 - A portable MPI implementation"
+HOMEPAGE="http://www-unix.mcs.anl.gov/mpi/mpich2"
+MY_P=${P/_/}
+SRC_URI="ftp://ftp.mcs.anl.gov/pub/mpi/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc fast cxx mpe"
+
+PROVIDE="virtual/mpi"
+DEPEND="virtual/libc
+ sys-devel/libtool"
+RDEPEND="${DEPEND}
+ !virtual/mpi"
+
+pkg_setup() {
+ if [ -n "${MPICH_CONFIGURE_OPTS}" ]; then
+ einfo "Custom configure options are ${MPICH_CONFIGURE_OPTS}."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ mv ${WORKDIR}/${MY_P} ${S}
+ cd ${S}
+}
+
+src_compile() {
+ local myconf="${myconf} ${MPICH_CONFIGURE_OPTS}"
+
+ ./configure \
+ ${myconf} \
+ $(use_enable fast) \
+ $(use_enable cxx) \
+ $(use_enable mpe) \
+ --mandir=/usr/share/man \
+ --with-docdir=/usr/share/doc/${PF} \
+ --with-htmldir=/usr/share/doc/${PF}/html \
+ --sysconfdir=/etc/mpich2 \
+ --prefix=/usr \
+ --datadir=/usr/share/mpich2 || die
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} \
+ mandir=${D}/usr/share/man \
+ docdir=${D}/usr/share/doc/${PF} \
+ htmldir=${D}/usr/share/doc/${PF}/html \
+ sysconfdir=${D}/etc/mpich2 \
+ prefix=${D}/usr \
+ install || die
+
+ # Dont let users deinstall without portage
+ rm ${D}/usr/sbin/mpeuninstall
+
+ # Fix broken install scripts
+ mv ${D}/usr/doc/jumpshot-4 ${D}/usr/share/doc/${PF}
+ mv ${D}/usr/examples/cpi ${D}/usr/share/${PN}/cpi
+
+ # Decide whether to install documentation
+ if use doc; then
+ dodoc COPYRIGHT README README.romio README.testing CHANGES
+ else
+ rm -rf ${D}/usr/share/doc/
+ rm -rf ${D}/usr/share/man/
+ fi
+
+ # Fix up the example code Makefiles
+ for DIR in examples_graphics examples_logging; do
+ sed -i -e "s:^srcdir *=.*$:srcdir=/usr/share/mpich2/${DIR}:" \
+ ${D}/usr/share/mpich2/${DIR}/Makefile
+ done
+}