summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-02-06 23:24:03 +0000
committerMike Frysinger <vapier@gentoo.org>2005-02-06 23:24:03 +0000
commitf626c46522ce24bf1154173d2c83c6883e466c50 (patch)
tree579c03f470538c9e8f5f474aedf09a1a455d407b /sys-fs/devfsd
parentMarked stable on mips. (diff)
downloadhistorical-f626c46522ce24bf1154173d2c83c6883e466c50.tar.gz
historical-f626c46522ce24bf1154173d2c83c6883e466c50.tar.bz2
historical-f626c46522ce24bf1154173d2c83c6883e466c50.zip
touchup permissions #80360
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'sys-fs/devfsd')
-rw-r--r--sys-fs/devfsd/Manifest9
-rw-r--r--sys-fs/devfsd/devfsd-1.3.25-r8.ebuild18
-rw-r--r--sys-fs/devfsd/files/devfsd13
-rw-r--r--sys-fs/devfsd/files/devfsd.conf26
4 files changed, 32 insertions, 34 deletions
diff --git a/sys-fs/devfsd/Manifest b/sys-fs/devfsd/Manifest
index ba7afde25c0a..5a5580202be6 100644
--- a/sys-fs/devfsd/Manifest
+++ b/sys-fs/devfsd/Manifest
@@ -1,9 +1,8 @@
-MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
-MD5 20697f6dbb6506514b167a9d73945464 devfsd-1.3.25-r8.ebuild 1534
MD5 531eae5bc781cee0bfee30256ef1b2b3 ChangeLog 5472
-MD5 72d324e2b484a8ba4087e16c46e6e2bf files/devfsd.conf 5139
-MD5 d580e9efc3658a0e71a165b3b531d415 files/devfsd 245
-MD5 9483221bc19786c3f7cb5df05a664477 files/devfsd-1.3.25-pic.patch 529
+MD5 e646b3b1d395a11010bf32d82c1fa749 devfsd-1.3.25-r8.ebuild 1547
+MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
+MD5 5198e02931ee0ceb9bb88a74da341fba files/devfsd.conf 5644
MD5 41a6be534a78f5a0ad994b10e4134e6e files/devfsd-1.3.25-kernel-2.5.patch 3929
MD5 b8ec7858c1ac54c47302ca839a52188f files/digest-devfsd-1.3.25-r8 65
+MD5 9483221bc19786c3f7cb5df05a664477 files/devfsd-1.3.25-pic.patch 529
MD5 3df00d60f0ad517c5489f558c1a95056 files/devfsd-1.3.25-no-nis.patch 2142
diff --git a/sys-fs/devfsd/devfsd-1.3.25-r8.ebuild b/sys-fs/devfsd/devfsd-1.3.25-r8.ebuild
index d87b8c66437a..e8261cbff6a0 100644
--- a/sys-fs/devfsd/devfsd-1.3.25-r8.ebuild
+++ b/sys-fs/devfsd/devfsd-1.3.25-r8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/devfsd/devfsd-1.3.25-r8.ebuild,v 1.16 2005/02/01 10:43:53 greg_g Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/devfsd/devfsd-1.3.25-r8.ebuild,v 1.17 2005/02/06 23:24:03 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -21,26 +21,27 @@ S=${WORKDIR}/${PN}
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-kernel-2.5.patch
- epatch ${FILESDIR}/${P}-pic.patch
- epatch ${FILESDIR}/${P}-no-nis.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-kernel-2.5.patch
+ epatch "${FILESDIR}"/${P}-pic.patch
+ epatch "${FILESDIR}"/${P}-no-nis.patch
use uclibc || append-flags -DHAVE_NIS
- sed -e "s:-O2:${CFLAGS}:g" \
+ sed -i \
+ -e "s:-O2:${CFLAGS}:g" \
-e 's:/usr/man:/usr/share/man:' \
-e 's:/usr/src/linux:.:' \
-e '32,34d;11,16d' -e '6c\' \
-e 'DEFINES := -DLIBNSL="\\"/lib/libnsl.so.1\\""' \
-e 's:install -s:install:' \
- -i GNUmakefile
+ GNUmakefile
use uclibc && sed -e 's|libnsl.so.1|libnsl.so.0|' -i GNUmakefile
tc-export CC
}
src_install() {
dodir /sbin /usr/share/man /etc
- make PREFIX=${D} install || die
+ make PREFIX="${D}" install || die
dodoc devfsd.conf INSTALL
keepdir /etc/devfs.d
@@ -55,4 +56,3 @@ pkg_postinst() {
einfo " http://www.gentoo.org/doc/en/devfs-guide.xml"
echo
}
-
diff --git a/sys-fs/devfsd/files/devfsd b/sys-fs/devfsd/files/devfsd
deleted file mode 100644
index b01a3b879d43..000000000000
--- a/sys-fs/devfsd/files/devfsd
+++ /dev/null
@@ -1,13 +0,0 @@
-#!/bin/sh
-#RCUPDATE:boot:04:This line is required for script management
-
-
-. /etc/rc.d/config/basic
-. /etc/rc.d/config/functions
-
-# Test if we use devfs and start devfsd
-mount --bind /dev /dev-state
-mount -t devfs none /dev
-/sbin/devfsd /dev
-
-
diff --git a/sys-fs/devfsd/files/devfsd.conf b/sys-fs/devfsd/files/devfsd.conf
index 1431d7eda350..5aa9c2c146a7 100644
--- a/sys-fs/devfsd/files/devfsd.conf
+++ b/sys-fs/devfsd/files/devfsd.conf
@@ -4,7 +4,7 @@
# The Gentoo Linux Team - http://www.gentoo.org/
# - Many fixes, etc
#
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/devfsd/files/devfsd.conf,v 1.3 2004/10/16 17:09:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/devfsd/files/devfsd.conf,v 1.4 2005/02/06 23:24:03 vapier Exp $
# Enable full compatibility mode for old device names. You may comment these
# out if you don't use the old device names. Make sure you know what you're
@@ -56,9 +56,6 @@ RESTORE /lib/dev-state
# You can force default like this :
# PERMISSIONS owner_and_group access_mode
-# Video4Linux devices
-REGISTER v4l/.* PERMISSIONS root.video 660
-
# ALSA/OSS stuff
# Comment/change these if you want to change the permissions on
# the audio devices
@@ -75,9 +72,24 @@ REGISTER snd/.* PERMISSIONS root.audio 660
# Autoload the sg module if generic scsi driver compiled as module.
#LOOKUP ^sg$ MODLOAD ACTION sg
-# Give the cdrw group write permissions to /dev/sg0
-# This is done to have non root user use the burner (scan the scsi bus)
-#REGISTER ^scsi/host.*/bus.*/target.*/lun.*/generic PERMISSIONS root.cdrw 660
+# Give the cdrom group access to /dev/sg0
+REGISTER ^scsi/host.*/bus.*/target.*/lun.*/generic PERMISSIONS root.cdrom 660
+
+# Give the cdrom group access to the cdrom devices
+REGISTER ^scsi/host.*/bus.*/target.*/lun.*/cd PERMISSIONS root.cdrom 660
+REGISTER ^ide/host.*/bus.*/target.*/lun.*/cd PERMISSIONS root.cdrom 660
+
+# Give the floppy group access to the floppy devices
+REGISTER ^floppy/.* PERMISSIONS root.floppy 660
+
+# Give the usb group access to the usb devices
+REGISTER ^usb/.* PERMISSIONS root.usb 660
+REGISTER ^tts/USB.* PERMISSIONS root.usb 660
+
+# Video devices
+REGISTER ^v4l/.* PERMISSIONS root.video 660
+REGISTER ^dri/.* PERMISSIONS root.video 660
+REGISTER ^nvidia.* PERMISSIONS root.video 660
# General note for the following auto creation of symlinks:
#