summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-03-13 15:37:51 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-03-13 15:37:51 +0000
commitbb156bf047c28c7ed85c0be1505fb1c2b6438eac (patch)
tree37ab1d2f0f46d57010d75eb5f5e4ae574b6232dd /sys-libs/readline
parentCloses #17415 (diff)
downloadhistorical-bb156bf047c28c7ed85c0be1505fb1c2b6438eac.tar.gz
historical-bb156bf047c28c7ed85c0be1505fb1c2b6438eac.tar.bz2
historical-bb156bf047c28c7ed85c0be1505fb1c2b6438eac.zip
force upgrade
Diffstat (limited to 'sys-libs/readline')
-rw-r--r--sys-libs/readline/ChangeLog7
-rw-r--r--sys-libs/readline/files/digest-readline-4.2a-r21
-rw-r--r--sys-libs/readline/readline-4.2a-r2.ebuild71
3 files changed, 78 insertions, 1 deletions
diff --git a/sys-libs/readline/ChangeLog b/sys-libs/readline/ChangeLog
index 13a190e75149..dc023190d1e2 100644
--- a/sys-libs/readline/ChangeLog
+++ b/sys-libs/readline/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/readline
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.19 2003/03/05 11:34:03 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.20 2003/03/13 15:37:51 seemant Exp $
+
+*readline-4.2a-r2 (13 Mar 2003)
+
+ 13 Mar 2003; Seemant Kulleen <seemant@gentoo.org> readline-4.2a-r2.ebuild:
+ force upgrade to install the proper header
20 Feb 2003; Zach Welch <zwelch@gentoo.org> readline-4.3-r4.ebuild :
Added arm to keywords.
diff --git a/sys-libs/readline/files/digest-readline-4.2a-r2 b/sys-libs/readline/files/digest-readline-4.2a-r2
new file mode 100644
index 000000000000..449580104606
--- /dev/null
+++ b/sys-libs/readline/files/digest-readline-4.2a-r2
@@ -0,0 +1 @@
+MD5 7c5b1d2909821d5c1a7fe8904f1bb714 readline-4.2a.tar.gz 919625
diff --git a/sys-libs/readline/readline-4.2a-r2.ebuild b/sys-libs/readline/readline-4.2a-r2.ebuild
new file mode 100644
index 000000000000..e250acf4e6ff
--- /dev/null
+++ b/sys-libs/readline/readline-4.2a-r2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-4.2a-r2.ebuild,v 1.1 2003/03/13 15:37:51 seemant Exp $
+
+inherit eutils gnuconfig
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Another cute console display library"
+SRC_URI="ftp://ftp.gnu.org/gnu/readline/${P}.tar.gz
+ ftp://gatekeeper.dec.com/pub/GNU/readline/${P}.tar.gz"
+HOMEPAGE="http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html"
+
+KEYWORDS="x86 ppc sparc alpha mips"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2-r2
+ >=app-shells/bash-2.05a-r3"
+
+src_unpack() {
+ unpack ${A}
+
+ # config.sub doesn't recognize alphaev67+, update it
+ use alpha && gnuconfig_update
+}
+
+src_compile() {
+
+ econf --with-curses || die
+
+ emake || die
+ cd shlib
+ emake || die
+}
+
+
+src_install() {
+
+ make prefix=${D}/usr mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info install || die
+ cd shlib
+ make prefix=${D}/usr mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info install || die
+
+ cd ..
+
+ sed -i "s/# include <config.h>//" tilde.h
+ insinto /usr/include/readline
+ doins tilde.h
+
+ dodir /lib
+ mv ${D}/usr/lib/*.so* ${D}/lib
+ # bug #4411
+ gen_usr_ldscript libreadline.so
+ gen_usr_ldscript libhistory.so
+ # end bug #4411
+ dosym libhistory.so.${PV/a/} /lib/libhistory.so
+ dosym libreadline.so.${PV/a/} /lib/libreadline.so
+ # Needed because make install uses ${D} for the link
+ dosym libhistory.so.${PV/a/} /lib/libhistory.so.4
+ dosym libreadline.so.${PV/a/} /lib/libreadline.so.4
+ chmod 755 ${D}/lib/*.${PV/a/}
+
+ dodoc CHANGELOG CHANGES COPYING MANIFEST README USAGE
+ docinto ps
+ dodoc doc/*.ps
+ docinto html
+ dodoc doc/*.html
+}
+