summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2006-10-20 19:47:34 +0000
committerChristian Heim <phreak@gentoo.org>2006-10-20 19:47:34 +0000
commit17cae192af5fc9b0584367bc27679de15d78529b (patch)
tree33387abe0d394c75c3acd810c2b3ba5de37c1070 /sys-power
parentx86 (diff)
downloadhistorical-17cae192af5fc9b0584367bc27679de15d78529b.tar.gz
historical-17cae192af5fc9b0584367bc27679de15d78529b.tar.bz2
historical-17cae192af5fc9b0584367bc27679de15d78529b.zip
Revision bump, fixing #152096 (by installing cpufreqd into /etc/conf.d); Adding an extra comment to the init-script, why it could fail (#152057). Thanks to Daniel Franke for both.
Package-Manager: portage-2.1.2_pre3-r5
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/cpufreqd/ChangeLog11
-rw-r--r--sys-power/cpufreqd/cpufreqd-2.2.0-r1.ebuild70
-rw-r--r--sys-power/cpufreqd/files/cpufreqd-2.2.0-Makefile.am.patch17
-rw-r--r--sys-power/cpufreqd/files/cpufreqd-2.2.0-init.d5
-rw-r--r--sys-power/cpufreqd/files/digest-cpufreqd-2.2.0-r16
5 files changed, 106 insertions, 3 deletions
diff --git a/sys-power/cpufreqd/ChangeLog b/sys-power/cpufreqd/ChangeLog
index 54a349051a75..5ad803ded240 100644
--- a/sys-power/cpufreqd/ChangeLog
+++ b/sys-power/cpufreqd/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-power/cpufreqd
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufreqd/ChangeLog,v 1.38 2006/10/16 18:12:29 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufreqd/ChangeLog,v 1.39 2006/10/20 19:47:34 phreak Exp $
+
+*cpufreqd-2.2.0-r1 (20 Oct 2006)
+
+ 20 Oct 2006; Christian Heim <phreak@gentoo.org>
+ +files/cpufreqd-2.2.0-Makefile.am.patch, files/cpufreqd-2.2.0-init.d,
+ -cpufreqd-2.2.0.ebuild, +cpufreqd-2.2.0-r1.ebuild:
+ Revision bump, fixing #152096 (by installing cpufreqd into /etc/conf.d);
+ Adding an extra comment to the init-script, why it could fail (#152057).
+ Thanks to Daniel Franke for both.
16 Oct 2006; Christian Heim <phreak@gentoo.org>
+files/cpufreqd-2.2.0-init.d:
diff --git a/sys-power/cpufreqd/cpufreqd-2.2.0-r1.ebuild b/sys-power/cpufreqd/cpufreqd-2.2.0-r1.ebuild
new file mode 100644
index 000000000000..6b7e421a4071
--- /dev/null
+++ b/sys-power/cpufreqd/cpufreqd-2.2.0-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufreqd/cpufreqd-2.2.0-r1.ebuild,v 1.1 2006/10/20 19:47:34 phreak Exp $
+
+inherit eutils autotools
+
+NVCLOCK_VERSION="0.8b"
+
+DESCRIPTION="CPU Frequency Daemon"
+HOMEPAGE="http://cpufreqd.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
+ nvidia? ( http://www.linuxhardware.org/nvclock/nvclock${NVCLOCK_VERSION}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+IUSE="acpi apm lm_sensors nforce2 nvidia pmu"
+RDEPEND=">=sys-power/cpufrequtils-002
+ lm_sensors? ( sys-apps/lm_sensors )"
+DEPEND="sys-apps/sed
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-Makefile.am.patch
+ eautomake
+
+ sed -i -e "s:acpi_event:acpi:" "${S}"/cpufreqd.conf
+
+ if use nvidia; then
+ cd "${WORKDIR}"/nvclock${NVCLOCK_VERSION}
+ epatch "${FILESDIR}"/nvclock${NVCLOCK_VERSION}-fpic.patch
+ fi
+}
+
+src_compile() {
+ local config
+
+ if use nvidia; then
+ cd "${WORKDIR}"/nvclock${NVCLOCK_VERSION}
+ econf \
+ --disable-gtk \
+ --disable-qt \
+ --disable-nvcontrol \
+ || die "econf nvclock failed"
+ emake -j1 || die "emake nvclock failed"
+ config="--enable-nvclock=${WORKDIR}/nvclock${NVCLOCK_VERSION}"
+ fi
+
+ cd "${S}"
+ econf \
+ $(use_enable acpi) \
+ $(use_enable apm) \
+ $(use_enable lm_sensors sensors) \
+ $(use_enable nforce2) \
+ $(use_enable pmu) \
+ ${config} \
+ || die "econf failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ newinitd "${FILESDIR}"/${P}-init.d ${PN}
+}
diff --git a/sys-power/cpufreqd/files/cpufreqd-2.2.0-Makefile.am.patch b/sys-power/cpufreqd/files/cpufreqd-2.2.0-Makefile.am.patch
new file mode 100644
index 000000000000..4033bac3ab35
--- /dev/null
+++ b/sys-power/cpufreqd/files/cpufreqd-2.2.0-Makefile.am.patch
@@ -0,0 +1,17 @@
+Index: cpufreqd-2.2.0/Makefile.am
+===================================================================
+--- cpufreqd-2.2.0.orig/Makefile.am
++++ cpufreqd-2.2.0/Makefile.am
+@@ -22,11 +22,7 @@ SUBDIRS = src utils manpages
+ #man5_MANS = manpages/cpufreqd.conf.5
+
+ install-data-local:
+- if [ -f $(DESTDIR)/$(sysconfdir)/cpufreqd.conf ]; then \
+- echo "** preserving old configuration file **"; \
+- else \
+- install -Dm 0644 $(top_srcdir)/cpufreqd.conf $(DESTDIR)/$(sysconfdir)/cpufreqd.conf; \
+- fi;
++ install -Dm 0644 $(top_srcdir)/cpufreqd.conf $(DESTDIR)/$(sysconfdir)/conf.d/cpufreqd
+
+ tags:
+ if [ -f ./tags ]; then \
diff --git a/sys-power/cpufreqd/files/cpufreqd-2.2.0-init.d b/sys-power/cpufreqd/files/cpufreqd-2.2.0-init.d
index 21fa262761eb..e3a5d83fdc96 100644
--- a/sys-power/cpufreqd/files/cpufreqd-2.2.0-init.d
+++ b/sys-power/cpufreqd/files/cpufreqd-2.2.0-init.d
@@ -1,9 +1,9 @@
#!/sbin/runscript
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufreqd/files/cpufreqd-2.2.0-init.d,v 1.1 2006/10/16 18:12:29 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufreqd/files/cpufreqd-2.2.0-init.d,v 1.2 2006/10/20 19:47:34 phreak Exp $
-CONFIGFILE=/etc/cpufreqd.conf
+CONFIGFILE=/etc/conf.d/cpufreqd
depend() {
need localmount
@@ -18,6 +18,7 @@ checkconfig() {
if [[ ! -e /proc/cpufreq ]] && [[ ! -e /sys/devices/system/cpu/cpu0/cpufreq ]]; then
eerror "cpufreqd requires the kernel to be configured with CONFIG_CPU_FREQ"
+ eerror "Make sure that the appropiate drivers for your CPU are available."
return 1
fi
}
diff --git a/sys-power/cpufreqd/files/digest-cpufreqd-2.2.0-r1 b/sys-power/cpufreqd/files/digest-cpufreqd-2.2.0-r1
new file mode 100644
index 000000000000..928d8acc56d6
--- /dev/null
+++ b/sys-power/cpufreqd/files/digest-cpufreqd-2.2.0-r1
@@ -0,0 +1,6 @@
+MD5 a8916004d3fb75ed43822eb978c08fc5 cpufreqd-2.2.0.tar.bz2 292219
+RMD160 2e61db9bac593ae564e5103c80b4c49b9a85011c cpufreqd-2.2.0.tar.bz2 292219
+SHA256 13b857d23dff773965eb03a1531e6265627c328d5cc448ec4d446a7c54348d3b cpufreqd-2.2.0.tar.bz2 292219
+MD5 df36711124e08b3349692a8788755d14 nvclock0.8b.tar.gz 353127
+RMD160 66cac5993dc141d00efaa95d8f5ec38ed53854f6 nvclock0.8b.tar.gz 353127
+SHA256 a1fbdb82837c33869c0ebfcb95b6e11fc53b86919e8d1d17265d1af71eb04393 nvclock0.8b.tar.gz 353127