summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2009-12-01 15:03:59 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2009-12-01 15:03:59 +0000
commit4aa78a0319391f6ddd3b99440b24fc2bdaa19322 (patch)
tree46dccc5b41eb57738b4b09d1dc70ecc655db3bd3 /x11-libs/qt-webkit
parentmask temporarily qt-4.6 until I finish committing it (diff)
downloadhistorical-4aa78a0319391f6ddd3b99440b24fc2bdaa19322.tar.gz
historical-4aa78a0319391f6ddd3b99440b24fc2bdaa19322.tar.bz2
historical-4aa78a0319391f6ddd3b99440b24fc2bdaa19322.zip
Version bump to 4.6.0
Package-Manager: portage-2.2_rc54/cvs/Linux x86_64
Diffstat (limited to 'x11-libs/qt-webkit')
-rw-r--r--x11-libs/qt-webkit/ChangeLog8
-rw-r--r--x11-libs/qt-webkit/qt-webkit-4.6.0.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/x11-libs/qt-webkit/ChangeLog b/x11-libs/qt-webkit/ChangeLog
index da867ea26941..54b570f969a6 100644
--- a/x11-libs/qt-webkit/ChangeLog
+++ b/x11-libs/qt-webkit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-webkit
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/ChangeLog,v 1.69 2009/11/18 20:49:54 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/ChangeLog,v 1.70 2009/12/01 15:02:53 tampakrap Exp $
+
+*qt-webkit-4.6.0 (01 Dec 2009)
+
+ 01 Dec 2009; Theo Chatzimichos <tampakrap@gentoo.org>
+ +qt-webkit-4.6.0.ebuild:
+ Version Bump to 4.6.0
*qt-webkit-4.6.0_rc1 (18 Nov 2009)
diff --git a/x11-libs/qt-webkit/qt-webkit-4.6.0.ebuild b/x11-libs/qt-webkit/qt-webkit-4.6.0.ebuild
new file mode 100644
index 000000000000..3d3a04f9c83b
--- /dev/null
+++ b/x11-libs/qt-webkit/qt-webkit-4.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/qt-webkit-4.6.0.ebuild,v 1.1 2009/12/01 15:02:53 tampakrap Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The Webkit module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd"
+IUSE="kde"
+
+DEPEND="~x11-libs/qt-core-${PV}[debug=,ssl]
+ ~x11-libs/qt-dbus-${PV}[debug=]
+ ~x11-libs/qt-gui-${PV}[dbus,debug=]
+ !kde? ( || ( ~x11-libs/qt-phonon-${PV}:${SLOT}[dbus,debug=]
+ media-sound/phonon ) )
+ kde? ( media-sound/phonon )"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="src/3rdparty/webkit/WebCore tools/designer/src/plugins/qwebview"
+QT4_EXTRACT_DIRECTORIES="
+include/
+src/
+tools/"
+QCONFIG_ADD="webkit"
+QCONFIG_DEFINE="QT_WEBKIT"
+
+src_prepare() {
+ [[ $(tc-arch) == "ppc64" ]] && append-flags -mminimal-toc #241900
+ if use sparc; then
+ epatch "${FILESDIR}"/sparc-qt-webkit-sigbus.patch
+ fi
+ qt4-build_src_prepare
+}
+
+src_configure() {
+ myconf="${myconf} -webkit"
+ qt4-build_src_configure
+}