summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-06-08 12:24:25 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-06-08 12:24:25 +0000
commit7b4707dcae03ce99fd2b5c59597b4f61b4897b14 (patch)
treece38f4ce519e28e4232c08492f7ec43794a844cd /x11-libs/qt-webkit
parentDon't define _XOPEN_SOURCE on Solaris either, such that we can compile there ... (diff)
downloadhistorical-7b4707dcae03ce99fd2b5c59597b4f61b4897b14.tar.gz
historical-7b4707dcae03ce99fd2b5c59597b4f61b4897b14.tar.bz2
historical-7b4707dcae03ce99fd2b5c59597b4f61b4897b14.zip
Qt release version bump
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'x11-libs/qt-webkit')
-rw-r--r--x11-libs/qt-webkit/ChangeLog8
-rw-r--r--x11-libs/qt-webkit/qt-webkit-4.6.3.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/x11-libs/qt-webkit/ChangeLog b/x11-libs/qt-webkit/ChangeLog
index fe789f701ae4..02b03a2e477e 100644
--- a/x11-libs/qt-webkit/ChangeLog
+++ b/x11-libs/qt-webkit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-webkit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/ChangeLog,v 1.89 2010/04/18 13:00:24 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/ChangeLog,v 1.90 2010/06/08 12:23:40 hwoarang Exp $
+
+*qt-webkit-4.6.3 (08 Jun 2010)
+
+ 08 Jun 2010; Markos Chandras <hwoarang@gentoo.org>
+ +qt-webkit-4.6.3.ebuild:
+ Version bump
18 Apr 2010; <nixnut@gentoo.org> qt-webkit-4.6.2.ebuild:
ppc stable #297299
diff --git a/x11-libs/qt-webkit/qt-webkit-4.6.3.ebuild b/x11-libs/qt-webkit/qt-webkit-4.6.3.ebuild
new file mode 100644
index 000000000000..77d8c9133c61
--- /dev/null
+++ b/x11-libs/qt-webkit/qt-webkit-4.6.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/qt-webkit-4.6.3.ebuild,v 1.1 2010/06/08 12:23:40 hwoarang Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The Webkit module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="dbus kde"
+
+DEPEND="~x11-libs/qt-core-${PV}[aqua=,debug=,ssl]
+ ~x11-libs/qt-gui-${PV}[aqua=,dbus?,debug=]
+ ~x11-libs/qt-xmlpatterns-${PV}[aqua=,debug=]
+ dbus? ( ~x11-libs/qt-dbus-${PV}[aqua=,debug=] )
+ !kde? ( || ( ~x11-libs/qt-phonon-${PV}:${SLOT}[aqua=,dbus=,debug=]
+ media-sound/phonon[aqua=] ) )
+ kde? ( || ( media-sound/phonon[aqua=] ~x11-libs/qt-phonon-${PV}:${SLOT}[aqua=,dbus=,debug] ) )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.6.0-solaris-strnstr.patch
+)
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="
+ src/3rdparty/webkit/WebCore
+ tools/designer/src/plugins/qwebview"
+ QT4_EXTRACT_DIRECTORIES="
+ include/
+ src/
+ tools/"
+ QCONFIG_ADD="webkit"
+ QCONFIG_DEFINE="QT_WEBKIT"
+
+ qt4-build_pkg_setup
+}
+
+src_prepare() {
+ [[ $(tc-arch) == "ppc64" ]] && append-flags -mminimal-toc #241900
+ qt4-build_src_prepare
+}
+
+src_configure() {
+ myconf="${myconf} -webkit $(qt_use dbus qdbus)"
+ qt4-build_src_configure
+}