summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-10-24 18:16:47 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-10-24 18:16:47 +0000
commit01e3aa149c85e0af19d824e7e47b360ffae88757 (patch)
tree0087fd7f9ff401474454d25374c3e1baf1dcd29d /x11-misc/root-portal
parentinitial import (diff)
downloadhistorical-01e3aa149c85e0af19d824e7e47b360ffae88757.tar.gz
historical-01e3aa149c85e0af19d824e7e47b360ffae88757.tar.bz2
historical-01e3aa149c85e0af19d824e7e47b360ffae88757.zip
the new build of root-portal, a desktop interaction tool
Diffstat (limited to 'x11-misc/root-portal')
-rw-r--r--x11-misc/root-portal/ChangeLog9
-rw-r--r--x11-misc/root-portal/files/digest-root-portal-0.4.111
-rw-r--r--x11-misc/root-portal/root-portal-0.4.11.ebuild58
3 files changed, 68 insertions, 0 deletions
diff --git a/x11-misc/root-portal/ChangeLog b/x11-misc/root-portal/ChangeLog
new file mode 100644
index 000000000000..f1c51d07c8ef
--- /dev/null
+++ b/x11-misc/root-portal/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for x11-misc/root-portal
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/root-portal/ChangeLog,v 1.1 2002/10/24 18:16:47 spider Exp $
+
+*root-portal-0.4.11 (16 Oct 2002)
+
+ 16 Oct 2002; Spider <spider@gentoo.org> ChangeLog root-portal-0.4.11.ebuild :
+ first ebuild by myself, its a handly little util to draw text/graphs on the
+ desktop.
diff --git a/x11-misc/root-portal/files/digest-root-portal-0.4.11 b/x11-misc/root-portal/files/digest-root-portal-0.4.11
new file mode 100644
index 000000000000..3002ff6014d4
--- /dev/null
+++ b/x11-misc/root-portal/files/digest-root-portal-0.4.11
@@ -0,0 +1 @@
+MD5 4f5784ad9315ca06aa8bc64726184879 root-portal-0.4.11.tar.gz 316278
diff --git a/x11-misc/root-portal/root-portal-0.4.11.ebuild b/x11-misc/root-portal/root-portal-0.4.11.ebuild
new file mode 100644
index 000000000000..d849e1c4af35
--- /dev/null
+++ b/x11-misc/root-portal/root-portal-0.4.11.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/root-portal/root-portal-0.4.11.ebuild,v 1.1 2002/10/24 18:16:47 spider Exp $
+
+inherit debug
+
+IUSE="gnome"
+
+DESCRIPTION="A program to draw text and graphs in the root window"
+HOMEPAGE="http://root-portal.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~x86"
+
+# Build-time dependencies, such as
+# ssl? ( >=openssl-0.9.6b )
+# >=perl-5.6.1-r1
+DEPEND="
+ virtual/x11
+ =x11-libs/gtk+-1.2*
+ >=gnome-base/ORBit-0.5.7
+ >=gnome-base/gnome-libs-1.4.0
+ <gnome-base/gnome-panel-2
+ >=dev-libs/libxml-1.8.16 "
+
+
+# the tabulated section is only needed if Gnome is in USE, but their disable-gnome doesn't work for now.
+
+#RDEPEND=""
+
+S="${WORKDIR}/${P}"
+
+src_compile() {
+ local myconf="--enable-debug --enable-test --enable-crash-debug"
+ ## Theres an upstream bug (filed) that disables this. when the next version is out, uncomment theese lines and it should work
+
+
+# use gnome && myconf="${myconf} --enable-gnometext-builtin --enable-shell-builtin"
+# use gnome || myconf="${myconf} --without-gnome --without-gnome-libs --disable-gnometext-builtin --disable-shell-builtin"
+
+ myconf="${myconf} --enable-gnometext --enable-shell"
+ myconf="${myconf} --enable-console --enable-fifo --enable-filetail"
+ myconf="${myconf} --enable-graph --enable-process-builtin --enable-modifier"
+ myconf="${myconf} --enable-networkload --enable-remote --enable-roottext"
+ myconf="${myconf} --enable-systemload --enable-consoledump"
+ econf ${myconf} || die "configure failure. please file a bugreport"
+
+ emake || die "compile failure. please file a bugreport"
+}
+
+src_install() {
+ einstall
+ dodoc PACKAGING README NEWS ChangeLog BUGS AUTHORS COPYING INSTALL README.help UNINSTALL TODO
+}