summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2005-01-21 21:49:10 +0000
committerTavis Ormandy <taviso@gentoo.org>2005-01-21 21:49:10 +0000
commita4f738a14c646e6b28d5f41e9e4b7f680bf1ff43 (patch)
tree40e35b5a319ad439d68cf06157c2ad20b9d609e6 /x11-misc
parentRemoving deprecation notices from all 2005.0 profiles. (diff)
downloadhistorical-a4f738a14c646e6b28d5f41e9e4b7f680bf1ff43.tar.gz
historical-a4f738a14c646e6b28d5f41e9e4b7f680bf1ff43.tar.bz2
historical-a4f738a14c646e6b28d5f41e9e4b7f680bf1ff43.zip
initial import
Package-Manager: portage-2.0.51-r13
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xse/ChangeLog9
-rw-r--r--x11-misc/xse/Manifest4
-rw-r--r--x11-misc/xse/files/digest-xse-2.01
-rw-r--r--x11-misc/xse/metadata.xml20
-rw-r--r--x11-misc/xse/xse-2.0.ebuild66
5 files changed, 100 insertions, 0 deletions
diff --git a/x11-misc/xse/ChangeLog b/x11-misc/xse/ChangeLog
new file mode 100644
index 000000000000..27e81c4fc899
--- /dev/null
+++ b/x11-misc/xse/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for x11-misc/xse
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xse/ChangeLog,v 1.1 2005/01/21 21:49:10 taviso Exp $
+
+*xse-2.0 (21 Jan 2005)
+
+ 21 Jan 2005; Tavis Ormandy <taviso@gentoo.org> +xse-2.0.ebuild:
+ Initial import
+
diff --git a/x11-misc/xse/Manifest b/x11-misc/xse/Manifest
new file mode 100644
index 000000000000..b29a14849708
--- /dev/null
+++ b/x11-misc/xse/Manifest
@@ -0,0 +1,4 @@
+MD5 3e2c2f9aff6ef92e3f4c567c99cc7497 xse-2.0.ebuild 1501
+MD5 9db31a2db7b8127edc6583e75fdc3372 ChangeLog 305
+MD5 c318a263cc1ca8f9785f08985f34c469 metadata.xml 729
+MD5 58bc865d9dd6348beee0b46fc948339a files/digest-xse-2.0 58
diff --git a/x11-misc/xse/files/digest-xse-2.0 b/x11-misc/xse/files/digest-xse-2.0
new file mode 100644
index 000000000000..eb5bec801620
--- /dev/null
+++ b/x11-misc/xse/files/digest-xse-2.0
@@ -0,0 +1 @@
+MD5 9923127482d2dc50fc3fadf1cb64538d xse-2.0.tar.gz 34300
diff --git a/x11-misc/xse/metadata.xml b/x11-misc/xse/metadata.xml
new file mode 100644
index 000000000000..18d8477de682
--- /dev/null
+++ b/x11-misc/xse/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>taviso@gentoo.org</email>
+ <description>
+ package likely has no upstream maintainer, taviso will accept all
+ reported bugs.
+ </description>
+</maintainer>
+ <longdescription>
+ xse is basically a command line wrapper around the Xlib XSendEvent()
+ function, allowing you to send any kind of event to X11 applications,
+ such as input events, motion or configure notification, or any other.
+
+ This can be useful for scripting interaction, debugging applications
+ and experimenting with events while developing X11 applications.
+ </longdescription>
+</pkgmetadata>
diff --git a/x11-misc/xse/xse-2.0.ebuild b/x11-misc/xse/xse-2.0.ebuild
new file mode 100644
index 000000000000..a33318e48007
--- /dev/null
+++ b/x11-misc/xse/xse-2.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xse/xse-2.0.ebuild,v 1.1 2005/01/21 21:49:10 taviso Exp $
+
+inherit eutils
+
+DESCRIPTION="Command Line Interface to XSendEvent() (useful for scripting interaction, debugging applications, experimenting with X11 events, etc.)"
+HOMEPAGE="news://alt.sources/"
+
+# The following posts to alt.sources make up this package:
+#
+# <1992Jan31.182036.26249@cs.rochester.edu>
+# <1992Jan31.182224.26407@cs.rochester.edu>
+# <1992Jan31.182450.26610@cs.rochester.edu>
+
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="X11"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+DEPEND="virtual/x11"
+
+src_unpack() {
+ local i
+
+ unpack ${A}
+ cd ${S}
+
+ einfo "Unpacking shar archives..."
+ # this saves a dependency on sharutils
+ for i in 1992Jan31.{182036.26249,182224.26407,182450.26610}
+ do
+ ebegin " ${i}"
+ set -o pipefail
+ sed '1,/^#!/d' ${i} | /bin/sh -s -- -c &> /dev/null || {
+ eend $?
+ die "failed to unpack shar archive"
+ } && {
+ eend $?
+ }
+ set +o pipefail
+ done
+ einfo "done."
+ ebegin "Creating Makefiles"
+ xmkmf -a &> /dev/null || {
+ eend $?
+ die "Building Makefiles failed"
+ } && {
+ eend $?
+ }
+}
+
+src_compile() { emake CDEBUGFLAGS="${CFLAGS}" LOCAL_LDFLAGS=${LDFLAGS}; }
+
+src_install() {
+ dobin xse
+
+ newman xse.man xse.1
+ dodoc README test-events
+
+ dodir /usr/X11R6/lib/X11/app-defaults
+ insinto /usr/X11R6/lib/X11/app-defaults
+ newins Xse.ad Xse
+}