summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-09-10 22:40:29 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-09-10 22:40:29 +0000
commite5911a03cbda6442555da4deb3f67d5cc9712cf6 (patch)
treeb3e6a78b96da99e979aee19ceaf8fb320eb10838 /x11-misc
parentSecurity bump to address CAN-2005-2700. Fixes bug 104807 (diff)
downloadhistorical-e5911a03cbda6442555da4deb3f67d5cc9712cf6.tar.gz
historical-e5911a03cbda6442555da4deb3f67d5cc9712cf6.tar.bz2
historical-e5911a03cbda6442555da4deb3f67d5cc9712cf6.zip
PIC patch bug #34739. CFLAGS fixed not to do -O3 by default
Package-Manager: portage-2.0.52-r1
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/electricsheep/ChangeLog7
-rw-r--r--x11-misc/electricsheep/Manifest11
-rw-r--r--x11-misc/electricsheep/electricsheep-2.6.3-r1.ebuild10
-rw-r--r--x11-misc/electricsheep/files/electricsheep-2.6.3-cflagsfix.patch591
4 files changed, 612 insertions, 7 deletions
diff --git a/x11-misc/electricsheep/ChangeLog b/x11-misc/electricsheep/ChangeLog
index ff992bd8ce0d..ab38012ad3b5 100644
--- a/x11-misc/electricsheep/ChangeLog
+++ b/x11-misc/electricsheep/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/electricsheep
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/electricsheep/ChangeLog,v 1.28 2005/09/09 00:00:47 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/electricsheep/ChangeLog,v 1.29 2005/09/10 22:40:29 dragonheart Exp $
+
+ 10 Sep 2005; Daniel Black <dragonheart@gentoo.org>
+ +files/electricsheep-2.6.3-cflagsfix.patch, electricsheep-2.6.3-r1.ebuild:
+ PIC patch thanks to Kevin Quinn bug #34739. CFLAGS fixed not to do -O3 by
+ default
*electricsheep-2.6.3-r1 (08 Sep 2005)
diff --git a/x11-misc/electricsheep/Manifest b/x11-misc/electricsheep/Manifest
index de34c63a89f1..a12730b5449a 100644
--- a/x11-misc/electricsheep/Manifest
+++ b/x11-misc/electricsheep/Manifest
@@ -1,15 +1,16 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 79e9daa5b253b06a37c7d1076f8fb03e ChangeLog 4237
+MD5 b806ee7746d15f0675d36cc1e592b702 ChangeLog 4454
+MD5 ff208fd77969755ebfe343c32ab034d9 electricsheep-2.6.3-r1.ebuild 2097
MD5 f84d0865990260d30b1b5180364dd6a8 metadata.xml 319
-MD5 84c9ae70b4377e95ed22c4d3985dd576 electricsheep-2.6.3-r1.ebuild 1882
+MD5 8573de509811af15cb08905c91a05864 files/electricsheep-2.6.3-cflagsfix.patch 16890
MD5 cf3d6d65b467f83063fea471d22e2f37 files/electricsheep.desktop 3973
MD5 d74dadadc142bec28238e9e3994fc179 files/digest-electricsheep-2.6.3-r1 72
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDINC/mdTrptrqvGERAhwXAJ9EEf4RKoSVmBFYp2GNCavobssbDwCbBRzu
-n5eISW3RMBFBcAYMzikvTi4=
-=9OIY
+iD8DBQFDI2DwmdTrptrqvGERAjMSAJwOkMnUO9N9dCyuLbkjy2tryxK2IQCeMRQM
+H2eyV02+vGAa7303icuaeBM=
+=Bgc+
-----END PGP SIGNATURE-----
diff --git a/x11-misc/electricsheep/electricsheep-2.6.3-r1.ebuild b/x11-misc/electricsheep/electricsheep-2.6.3-r1.ebuild
index 40a54c212fd2..29a47af9f578 100644
--- a/x11-misc/electricsheep/electricsheep-2.6.3-r1.ebuild
+++ b/x11-misc/electricsheep/electricsheep-2.6.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/electricsheep/electricsheep-2.6.3-r1.ebuild,v 1.1 2005/09/08 23:58:12 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/electricsheep/electricsheep-2.6.3-r1.ebuild,v 1.2 2005/09/10 22:40:29 dragonheart Exp $
inherit eutils flag-o-matic kde-functions
@@ -37,6 +37,14 @@ RDEPEND="virtual/x11
virtual/libc
sys-libs/zlib"
+src_unpack() {
+ unpack ${A}
+ # Detect PIC requirement from direct from compiler instead of
+ # macro PIC.
+ sed -i -e 's/def PIC/def __PIC__/' ${S}/mpeg2dec/src/cpu_accel.c
+ epatch ${FILESDIR}/${P}-cflagsfix.patch
+}
+
# Also detects and ties in sys-libs/slang, media-libs/aalib media-libs/svgalib and nas
# if they exist on the user machine although these aren't deps.
diff --git a/x11-misc/electricsheep/files/electricsheep-2.6.3-cflagsfix.patch b/x11-misc/electricsheep/files/electricsheep-2.6.3-cflagsfix.patch
new file mode 100644
index 000000000000..673783987dbb
--- /dev/null
+++ b/x11-misc/electricsheep/files/electricsheep-2.6.3-cflagsfix.patch
@@ -0,0 +1,591 @@
+--- electricsheep-2.6.3/mpeg2dec/configure.in.orig 2005-09-11 08:25:16.000000000 +1000
++++ electricsheep-2.6.3/mpeg2dec/configure.in 2005-09-11 08:26:33.000000000 +1000
+@@ -15,70 +15,6 @@
+ AC_PROG_CC
+ AC_PROG_GCC_TRADITIONAL
+
+-dnl CC-specific flags
+-if test x"$CC" = x"checkergcc"; then
+- enable_sdl=no
+-elif test x"$GCC" = x"yes"; then
+-
+- dnl GCC-specific flags
+- dnl -Wall -Werror moved to the end to not disturb the configure script
+-
+- dnl -O3
+- changequote(<<,>>)
+- OPT_CFLAGS=`echo "$CFLAGS"|sed "s/-O[0-9]*//g;"`
+- changequote([,])
+- OPT_CFLAGS="$OPT_CFLAGS -O3"
+- AC_TRY_CFLAGS([$OPT_CFLAGS],[CFLAGS=$OPT_CFLAGS])
+-
+- dnl -fomit-frame-pointer
+- OPT_CFLAGS="$CFLAGS -fomit-frame-pointer"
+- AC_TRY_CFLAGS([$OPT_CFLAGS],[CFLAGS=$OPT_CFLAGS])
+-
+- dnl arch-specific flags
+- case "$host_alias" in
+- i?86-* | k?-*)
+- AC_DEFINE([ARCH_X86],,[x86 architecture])
+- case "$host_alias" in
+- i386-*) OPT_CFLAGS="$CFLAGS -march=i386";;
+- i486-*) OPT_CFLAGS="$CFLAGS -march=i486";;
+- i586-*) OPT_CFLAGS="$CFLAGS -march=pentium";;
+- i686-*) OPT_CFLAGS="$CFLAGS -march=pentiumpro";;
+- k6-*) OPT_CFLAGS="$CFLAGS -march=k6";;
+- esac
+- AC_TRY_CFLAGS([$OPT_CFLAGS],[CFLAGS=$OPT_CFLAGS]);;
+- ppc-* | powerpc-*)
+- OPT_CFLAGS="$CFLAGS -Wa,-m7400"
+- AC_TRY_CFLAGS([$OPT_CFLAGS],
+- [CFLAGS=$OPT_CFLAGS; AC_DEFINE([ARCH_PPC],,[ppc architecture])]);;
+- sparc-* | sparc64-*)
+- OPT_CFLAGS="$CFLAGS -march=ultrasparc -mvis -Wa,-Av9"
+- AC_TRY_CFLAGS([$OPT_CFLAGS],[CFLAGS=$OPT_CFLAGS]);;
+- mips-sgi-irix6.*) dnl do we need to be that specific ?
+- OPT_CFLAGS="$CFLAGS -mabi=64"
+- AC_TRY_CFLAGS([$OPT_CFLAGS],[CFLAGS=$OPT_CFLAGS]);;
+- esac
+-elif test x"$CC" = x"tcc" -a x"`$CC -version 2>&1 | grep TenDRA`" != x""; then
+- dnl TenDRA portability checking compiler
+- TENDRA=yes
+- CFLAGS="-Xp -Yansi -f`pwd`/include/tendra.h -DELIDE_CODE"
+- enable_mlib=no
+- no_x=yes
+- enable_sdl=no
+-elif test x"$CC" = x"icc" -a x"`$CC -V 2>&1 | grep Intel`" != x""; then
+- dnl Intel C++ compiler
+- CFLAGS="-g -O3 -unroll -ip"
+-else
+- dnl non-gcc flags - we probably need exact configuration triplets here.
+- case "$host_alias" in
+- mips-sgi-irix6.*)
+- OPT_CFLAGS="$CFLAGS -64"
+- AC_TRY_CFLAGS([$OPT_CFLAGS],[CFLAGS=$OPT_CFLAGS]);;
+- sparc-sun-solaris*)
+- OPT_CFLAGS="$CFLAGS -xCC -fast -xO5"
+- AC_TRY_CFLAGS([$OPT_CFLAGS],[CFLAGS=$OPT_CFLAGS]);;
+- esac
+-fi
+-
+ dnl Checks for libtool - this must be done after we set cflags
+ AC_DISABLE_SHARED
+ AC_LIBTOOL_WIN32_DLL
+--- electricsheep-2.6.3/mpeg2dec/configure.orig 2005-09-11 08:25:25.000000000 +1000
++++ electricsheep-2.6.3/mpeg2dec/configure 2005-09-11 08:28:03.000000000 +1000
+@@ -3245,515 +3245,6 @@
+ fi
+
+
+-if test x"$CC" = x"checkergcc"; then
+- enable_sdl=no
+-elif test x"$GCC" = x"yes"; then
+-
+-
+-
+- OPT_CFLAGS=`echo "$CFLAGS"|sed "s/-O[0-9]*//g;"`
+-
+- OPT_CFLAGS="$OPT_CFLAGS -O3"
+- echo "$as_me:$LINENO: checking if $CC supports $OPT_CFLAGS flags" >&5
+-echo $ECHO_N "checking if $CC supports $OPT_CFLAGS flags... $ECHO_C" >&6
+- SAVE_CFLAGS="$CFLAGS"
+- CFLAGS="$OPT_CFLAGS"
+- cat >conftest.$ac_ext <<_ACEOF
+-/* confdefs.h. */
+-_ACEOF
+-cat confdefs.h >>conftest.$ac_ext
+-cat >>conftest.$ac_ext <<_ACEOF
+-/* end confdefs.h. */
+-
+-int
+-main ()
+-{
+-
+- ;
+- return 0;
+-}
+-_ACEOF
+-rm -f conftest.$ac_objext
+-if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
+- (eval $ac_compile) 2>conftest.er1
+- ac_status=$?
+- grep -v '^ *+' conftest.er1 >conftest.err
+- rm -f conftest.er1
+- cat conftest.err >&5
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag"
+- || test ! -s conftest.err'
+- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+- (eval $ac_try) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; } &&
+- { ac_try='test -s conftest.$ac_objext'
+- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+- (eval $ac_try) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; }; then
+- ac_cv_try_cflags_ok=yes
+-else
+- echo "$as_me: failed program was:" >&5
+-sed 's/^/| /' conftest.$ac_ext >&5
+-
+-ac_cv_try_cflags_ok=no
+-fi
+-rm -f conftest.err conftest.$ac_objext conftest.$ac_ext
+- CFLAGS="$SAVE_CFLAGS"
+- echo "$as_me:$LINENO: result: $ac_cv_try_cflags_ok" >&5
+-echo "${ECHO_T}$ac_cv_try_cflags_ok" >&6
+- if test x"$ac_cv_try_cflags_ok" = x"yes"; then
+- CFLAGS=$OPT_CFLAGS
+- else
+- :
+- fi
+-
+- OPT_CFLAGS="$CFLAGS -fomit-frame-pointer"
+- echo "$as_me:$LINENO: checking if $CC supports $OPT_CFLAGS flags" >&5
+-echo $ECHO_N "checking if $CC supports $OPT_CFLAGS flags... $ECHO_C" >&6
+- SAVE_CFLAGS="$CFLAGS"
+- CFLAGS="$OPT_CFLAGS"
+- cat >conftest.$ac_ext <<_ACEOF
+-/* confdefs.h. */
+-_ACEOF
+-cat confdefs.h >>conftest.$ac_ext
+-cat >>conftest.$ac_ext <<_ACEOF
+-/* end confdefs.h. */
+-
+-int
+-main ()
+-{
+-
+- ;
+- return 0;
+-}
+-_ACEOF
+-rm -f conftest.$ac_objext
+-if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
+- (eval $ac_compile) 2>conftest.er1
+- ac_status=$?
+- grep -v '^ *+' conftest.er1 >conftest.err
+- rm -f conftest.er1
+- cat conftest.err >&5
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag"
+- || test ! -s conftest.err'
+- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+- (eval $ac_try) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; } &&
+- { ac_try='test -s conftest.$ac_objext'
+- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+- (eval $ac_try) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; }; then
+- ac_cv_try_cflags_ok=yes
+-else
+- echo "$as_me: failed program was:" >&5
+-sed 's/^/| /' conftest.$ac_ext >&5
+-
+-ac_cv_try_cflags_ok=no
+-fi
+-rm -f conftest.err conftest.$ac_objext conftest.$ac_ext
+- CFLAGS="$SAVE_CFLAGS"
+- echo "$as_me:$LINENO: result: $ac_cv_try_cflags_ok" >&5
+-echo "${ECHO_T}$ac_cv_try_cflags_ok" >&6
+- if test x"$ac_cv_try_cflags_ok" = x"yes"; then
+- CFLAGS=$OPT_CFLAGS
+- else
+- :
+- fi
+-
+- case "$host_alias" in
+- i?86-* | k?-*)
+-
+-cat >>confdefs.h <<\_ACEOF
+-#define ARCH_X86
+-_ACEOF
+-
+- case "$host_alias" in
+- i386-*) OPT_CFLAGS="$CFLAGS -march=i386";;
+- i486-*) OPT_CFLAGS="$CFLAGS -march=i486";;
+- i586-*) OPT_CFLAGS="$CFLAGS -march=pentium";;
+- i686-*) OPT_CFLAGS="$CFLAGS -march=pentiumpro";;
+- k6-*) OPT_CFLAGS="$CFLAGS -march=k6";;
+- esac
+- echo "$as_me:$LINENO: checking if $CC supports $OPT_CFLAGS flags" >&5
+-echo $ECHO_N "checking if $CC supports $OPT_CFLAGS flags... $ECHO_C" >&6
+- SAVE_CFLAGS="$CFLAGS"
+- CFLAGS="$OPT_CFLAGS"
+- cat >conftest.$ac_ext <<_ACEOF
+-/* confdefs.h. */
+-_ACEOF
+-cat confdefs.h >>conftest.$ac_ext
+-cat >>conftest.$ac_ext <<_ACEOF
+-/* end confdefs.h. */
+-
+-int
+-main ()
+-{
+-
+- ;
+- return 0;
+-}
+-_ACEOF
+-rm -f conftest.$ac_objext
+-if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
+- (eval $ac_compile) 2>conftest.er1
+- ac_status=$?
+- grep -v '^ *+' conftest.er1 >conftest.err
+- rm -f conftest.er1
+- cat conftest.err >&5
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag"
+- || test ! -s conftest.err'
+- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+- (eval $ac_try) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; } &&
+- { ac_try='test -s conftest.$ac_objext'
+- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+- (eval $ac_try) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; }; then
+- ac_cv_try_cflags_ok=yes
+-else
+- echo "$as_me: failed program was:" >&5
+-sed 's/^/| /' conftest.$ac_ext >&5
+-
+-ac_cv_try_cflags_ok=no
+-fi
+-rm -f conftest.err conftest.$ac_objext conftest.$ac_ext
+- CFLAGS="$SAVE_CFLAGS"
+- echo "$as_me:$LINENO: result: $ac_cv_try_cflags_ok" >&5
+-echo "${ECHO_T}$ac_cv_try_cflags_ok" >&6
+- if test x"$ac_cv_try_cflags_ok" = x"yes"; then
+- CFLAGS=$OPT_CFLAGS
+- else
+- :
+- fi;;
+- ppc-* | powerpc-*)
+- OPT_CFLAGS="$CFLAGS -Wa,-m7400"
+- echo "$as_me:$LINENO: checking if $CC supports $OPT_CFLAGS flags" >&5
+-echo $ECHO_N "checking if $CC supports $OPT_CFLAGS flags... $ECHO_C" >&6
+- SAVE_CFLAGS="$CFLAGS"
+- CFLAGS="$OPT_CFLAGS"
+- cat >conftest.$ac_ext <<_ACEOF
+-/* confdefs.h. */
+-_ACEOF
+-cat confdefs.h >>conftest.$ac_ext
+-cat >>conftest.$ac_ext <<_ACEOF
+-/* end confdefs.h. */
+-
+-int
+-main ()
+-{
+-
+- ;
+- return 0;
+-}
+-_ACEOF
+-rm -f conftest.$ac_objext
+-if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
+- (eval $ac_compile) 2>conftest.er1
+- ac_status=$?
+- grep -v '^ *+' conftest.er1 >conftest.err
+- rm -f conftest.er1
+- cat conftest.err >&5
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag"
+- || test ! -s conftest.err'
+- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+- (eval $ac_try) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; } &&
+- { ac_try='test -s conftest.$ac_objext'
+- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+- (eval $ac_try) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; }; then
+- ac_cv_try_cflags_ok=yes
+-else
+- echo "$as_me: failed program was:" >&5
+-sed 's/^/| /' conftest.$ac_ext >&5
+-
+-ac_cv_try_cflags_ok=no
+-fi
+-rm -f conftest.err conftest.$ac_objext conftest.$ac_ext
+- CFLAGS="$SAVE_CFLAGS"
+- echo "$as_me:$LINENO: result: $ac_cv_try_cflags_ok" >&5
+-echo "${ECHO_T}$ac_cv_try_cflags_ok" >&6
+- if test x"$ac_cv_try_cflags_ok" = x"yes"; then
+- CFLAGS=$OPT_CFLAGS;
+-cat >>confdefs.h <<\_ACEOF
+-#define ARCH_PPC
+-_ACEOF
+-
+- else
+- :
+- fi;;
+- sparc-* | sparc64-*)
+- OPT_CFLAGS="$CFLAGS -march=ultrasparc -mvis -Wa,-Av9"
+- echo "$as_me:$LINENO: checking if $CC supports $OPT_CFLAGS flags" >&5
+-echo $ECHO_N "checking if $CC supports $OPT_CFLAGS flags... $ECHO_C" >&6
+- SAVE_CFLAGS="$CFLAGS"
+- CFLAGS="$OPT_CFLAGS"
+- cat >conftest.$ac_ext <<_ACEOF
+-/* confdefs.h. */
+-_ACEOF
+-cat confdefs.h >>conftest.$ac_ext
+-cat >>conftest.$ac_ext <<_ACEOF
+-/* end confdefs.h. */
+-
+-int
+-main ()
+-{
+-
+- ;
+- return 0;
+-}
+-_ACEOF
+-rm -f conftest.$ac_objext
+-if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
+- (eval $ac_compile) 2>conftest.er1
+- ac_status=$?
+- grep -v '^ *+' conftest.er1 >conftest.err
+- rm -f conftest.er1
+- cat conftest.err >&5
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag"
+- || test ! -s conftest.err'
+- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+- (eval $ac_try) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; } &&
+- { ac_try='test -s conftest.$ac_objext'
+- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+- (eval $ac_try) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; }; then
+- ac_cv_try_cflags_ok=yes
+-else
+- echo "$as_me: failed program was:" >&5
+-sed 's/^/| /' conftest.$ac_ext >&5
+-
+-ac_cv_try_cflags_ok=no
+-fi
+-rm -f conftest.err conftest.$ac_objext conftest.$ac_ext
+- CFLAGS="$SAVE_CFLAGS"
+- echo "$as_me:$LINENO: result: $ac_cv_try_cflags_ok" >&5
+-echo "${ECHO_T}$ac_cv_try_cflags_ok" >&6
+- if test x"$ac_cv_try_cflags_ok" = x"yes"; then
+- CFLAGS=$OPT_CFLAGS
+- else
+- :
+- fi;;
+- mips-sgi-irix6.*) OPT_CFLAGS="$CFLAGS -mabi=64"
+- echo "$as_me:$LINENO: checking if $CC supports $OPT_CFLAGS flags" >&5
+-echo $ECHO_N "checking if $CC supports $OPT_CFLAGS flags... $ECHO_C" >&6
+- SAVE_CFLAGS="$CFLAGS"
+- CFLAGS="$OPT_CFLAGS"
+- cat >conftest.$ac_ext <<_ACEOF
+-/* confdefs.h. */
+-_ACEOF
+-cat confdefs.h >>conftest.$ac_ext
+-cat >>conftest.$ac_ext <<_ACEOF
+-/* end confdefs.h. */
+-
+-int
+-main ()
+-{
+-
+- ;
+- return 0;
+-}
+-_ACEOF
+-rm -f conftest.$ac_objext
+-if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
+- (eval $ac_compile) 2>conftest.er1
+- ac_status=$?
+- grep -v '^ *+' conftest.er1 >conftest.err
+- rm -f conftest.er1
+- cat conftest.err >&5
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag"
+- || test ! -s conftest.err'
+- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+- (eval $ac_try) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; } &&
+- { ac_try='test -s conftest.$ac_objext'
+- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+- (eval $ac_try) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; }; then
+- ac_cv_try_cflags_ok=yes
+-else
+- echo "$as_me: failed program was:" >&5
+-sed 's/^/| /' conftest.$ac_ext >&5
+-
+-ac_cv_try_cflags_ok=no
+-fi
+-rm -f conftest.err conftest.$ac_objext conftest.$ac_ext
+- CFLAGS="$SAVE_CFLAGS"
+- echo "$as_me:$LINENO: result: $ac_cv_try_cflags_ok" >&5
+-echo "${ECHO_T}$ac_cv_try_cflags_ok" >&6
+- if test x"$ac_cv_try_cflags_ok" = x"yes"; then
+- CFLAGS=$OPT_CFLAGS
+- else
+- :
+- fi;;
+- esac
+-elif test x"$CC" = x"tcc" -a x"`$CC -version 2>&1 | grep TenDRA`" != x""; then
+- TENDRA=yes
+- CFLAGS="-Xp -Yansi -f`pwd`/include/tendra.h -DELIDE_CODE"
+- enable_mlib=no
+- no_x=yes
+- enable_sdl=no
+-elif test x"$CC" = x"icc" -a x"`$CC -V 2>&1 | grep Intel`" != x""; then
+- CFLAGS="-g -O3 -unroll -ip"
+-else
+- case "$host_alias" in
+- mips-sgi-irix6.*)
+- OPT_CFLAGS="$CFLAGS -64"
+- echo "$as_me:$LINENO: checking if $CC supports $OPT_CFLAGS flags" >&5
+-echo $ECHO_N "checking if $CC supports $OPT_CFLAGS flags... $ECHO_C" >&6
+- SAVE_CFLAGS="$CFLAGS"
+- CFLAGS="$OPT_CFLAGS"
+- cat >conftest.$ac_ext <<_ACEOF
+-/* confdefs.h. */
+-_ACEOF
+-cat confdefs.h >>conftest.$ac_ext
+-cat >>conftest.$ac_ext <<_ACEOF
+-/* end confdefs.h. */
+-
+-int
+-main ()
+-{
+-
+- ;
+- return 0;
+-}
+-_ACEOF
+-rm -f conftest.$ac_objext
+-if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
+- (eval $ac_compile) 2>conftest.er1
+- ac_status=$?
+- grep -v '^ *+' conftest.er1 >conftest.err
+- rm -f conftest.er1
+- cat conftest.err >&5
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag"
+- || test ! -s conftest.err'
+- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+- (eval $ac_try) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; } &&
+- { ac_try='test -s conftest.$ac_objext'
+- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+- (eval $ac_try) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; }; then
+- ac_cv_try_cflags_ok=yes
+-else
+- echo "$as_me: failed program was:" >&5
+-sed 's/^/| /' conftest.$ac_ext >&5
+-
+-ac_cv_try_cflags_ok=no
+-fi
+-rm -f conftest.err conftest.$ac_objext conftest.$ac_ext
+- CFLAGS="$SAVE_CFLAGS"
+- echo "$as_me:$LINENO: result: $ac_cv_try_cflags_ok" >&5
+-echo "${ECHO_T}$ac_cv_try_cflags_ok" >&6
+- if test x"$ac_cv_try_cflags_ok" = x"yes"; then
+- CFLAGS=$OPT_CFLAGS
+- else
+- :
+- fi;;
+- sparc-sun-solaris*)
+- OPT_CFLAGS="$CFLAGS -xCC -fast -xO5"
+- echo "$as_me:$LINENO: checking if $CC supports $OPT_CFLAGS flags" >&5
+-echo $ECHO_N "checking if $CC supports $OPT_CFLAGS flags... $ECHO_C" >&6
+- SAVE_CFLAGS="$CFLAGS"
+- CFLAGS="$OPT_CFLAGS"
+- cat >conftest.$ac_ext <<_ACEOF
+-/* confdefs.h. */
+-_ACEOF
+-cat confdefs.h >>conftest.$ac_ext
+-cat >>conftest.$ac_ext <<_ACEOF
+-/* end confdefs.h. */
+-
+-int
+-main ()
+-{
+-
+- ;
+- return 0;
+-}
+-_ACEOF
+-rm -f conftest.$ac_objext
+-if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
+- (eval $ac_compile) 2>conftest.er1
+- ac_status=$?
+- grep -v '^ *+' conftest.er1 >conftest.err
+- rm -f conftest.er1
+- cat conftest.err >&5
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag"
+- || test ! -s conftest.err'
+- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+- (eval $ac_try) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; } &&
+- { ac_try='test -s conftest.$ac_objext'
+- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+- (eval $ac_try) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; }; then
+- ac_cv_try_cflags_ok=yes
+-else
+- echo "$as_me: failed program was:" >&5
+-sed 's/^/| /' conftest.$ac_ext >&5
+-
+-ac_cv_try_cflags_ok=no
+-fi
+-rm -f conftest.err conftest.$ac_objext conftest.$ac_ext
+- CFLAGS="$SAVE_CFLAGS"
+- echo "$as_me:$LINENO: result: $ac_cv_try_cflags_ok" >&5
+-echo "${ECHO_T}$ac_cv_try_cflags_ok" >&6
+- if test x"$ac_cv_try_cflags_ok" = x"yes"; then
+- CFLAGS=$OPT_CFLAGS
+- else
+- :
+- fi;;
+- esac
+-fi
+-
+ # Check whether --enable-shared or --disable-shared was given.
+ if test "${enable_shared+set}" = set; then
+ enableval="$enable_shared"