summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-10-04 18:42:58 +0000
committerNick Hadaway <raker@gentoo.org>2002-10-04 18:42:58 +0000
commitf01dbdfbbc64f76fbf00fdc9e75fe6881f026f7a (patch)
tree0715c8a54b9267082229d7abc693f1d61355791e /x11-plugins/wmtop
parentInitial add of ebuild to portage. (diff)
downloadhistorical-f01dbdfbbc64f76fbf00fdc9e75fe6881f026f7a.tar.gz
historical-f01dbdfbbc64f76fbf00fdc9e75fe6881f026f7a.tar.bz2
historical-f01dbdfbbc64f76fbf00fdc9e75fe6881f026f7a.zip
Initial add of ebuild to portage
Diffstat (limited to 'x11-plugins/wmtop')
-rw-r--r--x11-plugins/wmtop/ChangeLog9
-rw-r--r--x11-plugins/wmtop/files/digest-wmtop-0.841
-rw-r--r--x11-plugins/wmtop/wmtop-0.84.ebuild35
3 files changed, 45 insertions, 0 deletions
diff --git a/x11-plugins/wmtop/ChangeLog b/x11-plugins/wmtop/ChangeLog
new file mode 100644
index 000000000000..9ce6fb7a3ded
--- /dev/null
+++ b/x11-plugins/wmtop/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for x11-plugins/wmtop
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtop/ChangeLog,v 1.1 2002/10/04 18:42:58 raker Exp $
+
+*wmtop-0.84 (04 Oct 2002)
+
+ 04 Oct 2002; Nick Hadaway <raker@gentoo.org> wmtop-0.84.ebuild,
+ files/digest-wmtop-0.84 :
+ Initial add of ebuild to portage.
diff --git a/x11-plugins/wmtop/files/digest-wmtop-0.84 b/x11-plugins/wmtop/files/digest-wmtop-0.84
new file mode 100644
index 000000000000..0293d3e23f8b
--- /dev/null
+++ b/x11-plugins/wmtop/files/digest-wmtop-0.84
@@ -0,0 +1 @@
+MD5 2bab22c5bc3a5b887e7c03d6dbfe59d7 wmtop-0.84.tar.bz2 24401
diff --git a/x11-plugins/wmtop/wmtop-0.84.ebuild b/x11-plugins/wmtop/wmtop-0.84.ebuild
new file mode 100644
index 000000000000..20d5de7f7aaf
--- /dev/null
+++ b/x11-plugins/wmtop/wmtop-0.84.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtop/wmtop-0.84.ebuild,v 1.1 2002/10/04 18:42:58 raker Exp $
+
+S="${WORKDIR}/${P}"
+
+DESCRIPTION="top in a dockapp"
+HOMEPAGE="http://wmtop.sourceforge.net"
+SRC_URI="mirror://sourceforge/wmtop/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/glibc
+ virtual/x11"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+
+ cd ${S}
+ cp Makefile Makefile.orig
+ sed -e "s:-O3 -g -Wall:${CFLAGS}:" \
+ -e "s:/local::" Makefile.orig > Makefile
+
+ make linux
+
+}
+
+src_install() {
+
+ dodir /usr/bin /usr/man/man1
+ make PREFIX=${D}/usr install || die "make install failed"
+
+}