summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/alsamixergui/ChangeLog10
-rw-r--r--media-sound/alsamixergui/alsamixergui-0.9.0.1.2-r2.ebuild48
-rw-r--r--media-sound/alsamixergui/files/digest-alsamixergui-0.9.0.1.2-r21
-rw-r--r--media-sound/alsamixergui/files/gentoo.diff67
4 files changed, 125 insertions, 1 deletions
diff --git a/media-sound/alsamixergui/ChangeLog b/media-sound/alsamixergui/ChangeLog
index b3b041f790d6..47b257bf78b3 100644
--- a/media-sound/alsamixergui/ChangeLog
+++ b/media-sound/alsamixergui/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/alsamixergui
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsamixergui/ChangeLog,v 1.4 2002/09/21 18:20:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsamixergui/ChangeLog,v 1.5 2003/01/03 01:39:46 raker Exp $
+
+*alsamixergui-0.9.0.1.2-r2 (02 Jan 2002)
+
+ 02 Jan 2002; Nick Hadaway <raker@gentoo.org>
+ alsamixergui-0.9.0.1.2-r2.ebuild,
+ files/digest-alsamixergui-0.9.0.1.2-r2,
+ files/gentoo.diff :
+ New ebuild. Another attempt at getting configure right.
*alsamixergui-0.9.0.1.2-r1 (21 Sep 2002)
diff --git a/media-sound/alsamixergui/alsamixergui-0.9.0.1.2-r2.ebuild b/media-sound/alsamixergui/alsamixergui-0.9.0.1.2-r2.ebuild
new file mode 100644
index 000000000000..c75a12101694
--- /dev/null
+++ b/media-sound/alsamixergui/alsamixergui-0.9.0.1.2-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsamixergui/alsamixergui-0.9.0.1.2-r2.ebuild,v 1.1 2003/01/03 01:39:46 raker Exp $
+
+NATIVE_VER=0.9.0rc1-2
+S=${WORKDIR}/${PN}-${NATIVE_VER}
+
+DESCRIPTION="AlsaMixerGui - a FLTK based amixer Frontend"
+HOMEPAGE="http://www.iua.upf.es/~mdeboer/projects/alsamixergui/"
+SRC_URI="ftp://www.iua.upf.es/pub/mdeboer/projects/alsamixergui/${PN}-${NATIVE_VER}.tar.gz"
+
+DEPEND=">=media-sound/alsa-driver-0.9.0_rc1
+ >=media-libs/alsa-lib-0.9.0_rc1
+ >=media-sound/alsa-utils-0.9.0_rc1
+ >=x11-libs/fltk-1.1.0_rc6"
+
+SLOT="0"
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+
+inherit eutils
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/gentoo.diff
+
+}
+
+src_compile() {
+
+ export LDFLAGS="-L/usr/lib/fltk-1.1"
+ export CPPFLAGS="-I/usr/include/fltk-1.1"
+
+ econf || die "configure failed"
+
+ emake || die "make failed"
+
+}
+
+src_install () {
+
+ einstall || die
+
+ dodoc COPYING README AUTHORS ChangeLog
+
+}
diff --git a/media-sound/alsamixergui/files/digest-alsamixergui-0.9.0.1.2-r2 b/media-sound/alsamixergui/files/digest-alsamixergui-0.9.0.1.2-r2
new file mode 100644
index 000000000000..a47468b6e908
--- /dev/null
+++ b/media-sound/alsamixergui/files/digest-alsamixergui-0.9.0.1.2-r2
@@ -0,0 +1 @@
+MD5 24b74dda2cf77c313c6cba9b062c8feb alsamixergui-0.9.0rc1-2.tar.gz 70255
diff --git a/media-sound/alsamixergui/files/gentoo.diff b/media-sound/alsamixergui/files/gentoo.diff
new file mode 100644
index 000000000000..3dc5239600d9
--- /dev/null
+++ b/media-sound/alsamixergui/files/gentoo.diff
@@ -0,0 +1,67 @@
+diff -urN alsamixergui-0.9.0rc1-2/configure alsamixergui-0.9.0rc1-2-modified/configure
+--- alsamixergui-0.9.0rc1-2/configure 2002-05-03 04:40:38.000000000 -0500
++++ alsamixergui-0.9.0rc1-2-modified/configure 2003-01-02 19:35:55.000000000 -0600
+@@ -1468,10 +1468,10 @@
+ echo "$ac_t""no" 1>&6
+ fi
+
+-
+-echo $ac_n "checking for numericsort in -lfltk""... $ac_c" 1>&6
+-echo "configure:1474: checking for numericsort in -lfltk" >&5
+-ac_lib_var=`echo fltk'_'numericsort | sed 'y%./+-%__p_%'`
++ac_link='${CXX-g++} -o conftest${ac_exeext} $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5'
++echo $ac_n "checking for main in -lfltk""... $ac_c" 1>&6
++echo "configure:1474: checking for main in -lfltk" >&5
++ac_lib_var=`echo fltk'_'main | sed 'y%./+-%__p_%'`
+ if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+@@ -1481,12 +1481,12 @@
+ #line 1482 "configure"
+ #include "confdefs.h"
+ /* Override any gcc2 internal prototype to avoid an error. */
+-/* We use char because int might match the return type of a gcc2
+- builtin and then its argument prototype would still apply. */
+-char numericsort();
++/* We use char because int might match the return type of a gcc2 */
++/* builtin and then its argument prototype would still apply. */
++/* char main(); */
+
+ int main() {
+-numericsort()
++main()
+ ; return 0; }
+ EOF
+ if { (eval echo configure:1493: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+@@ -1656,10 +1656,10 @@
+ ac_link='${CC-cc} -o conftest${ac_exeext} $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5'
+ cross_compiling=$ac_cv_prog_cc_cross
+
+-
+-echo $ac_n "checking for snd_seq_create_event in -lasound""... $ac_c" 1>&6
+-echo "configure:1662: checking for snd_seq_create_event in -lasound" >&5
+-ac_lib_var=`echo asound'_'snd_seq_create_event | sed 'y%./+-%__p_%'`
++ac_link='${CXX-g++} -o conftest${ac_exeext} $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5'
++echo $ac_n "checking for main in -lasound""... $ac_c" 1>&6
++echo "configure:1662: checking for main in -lasound" >&5
++ac_lib_var=`echo asound'_'main | sed 'y%./+-%__p_%'`
+ if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+@@ -1669,12 +1669,12 @@
+ #line 1670 "configure"
+ #include "confdefs.h"
+ /* Override any gcc2 internal prototype to avoid an error. */
+-/* We use char because int might match the return type of a gcc2
+- builtin and then its argument prototype would still apply. */
+-char snd_seq_create_event();
++/* We use char because int might match the return type of a gcc2 */
++/* builtin and then its argument prototype would still apply. */
++/* char main(); */
+
+ int main() {
+-snd_seq_create_event()
++main()
+ ; return 0; }
+ EOF
+ if { (eval echo configure:1681: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then