summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/pasm/ChangeLog10
-rw-r--r--dev-lang/pasm/Manifest5
-rw-r--r--dev-lang/pasm/files/digest-pasm-1.6c1
-rw-r--r--dev-lang/pasm/files/pasm-1.6c-ppc.patch29
-rw-r--r--dev-lang/pasm/metadata.xml9
-rw-r--r--dev-lang/pasm/pasm-1.6c.ebuild30
6 files changed, 84 insertions, 0 deletions
diff --git a/dev-lang/pasm/ChangeLog b/dev-lang/pasm/ChangeLog
new file mode 100644
index 000000000000..62e3ec46a25a
--- /dev/null
+++ b/dev-lang/pasm/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-lang/pasm
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/pasm/ChangeLog,v 1.1 2004/02/28 15:37:38 dholm Exp $
+
+*pasm-1.6c (28 Feb 2004)
+
+ 28 Feb 2004; David Holm <dholm@gentoo.org> pasm-1.6c.ebuild,
+ files/pasm-1.6c-ppc.patch:
+ Initial import.
+
diff --git a/dev-lang/pasm/Manifest b/dev-lang/pasm/Manifest
new file mode 100644
index 000000000000..8e00f15da25d
--- /dev/null
+++ b/dev-lang/pasm/Manifest
@@ -0,0 +1,5 @@
+MD5 6934aa977c0e01ac337118d675c04bc1 pasm-1.6c.ebuild 671
+MD5 e050f2f350eaa384342f37dfa459df6b metadata.xml 657
+MD5 6fd147a37c51f1cad57d10c315af0a5c ChangeLog 344
+MD5 6fa5986827c4c0b83925c4177abbde2b files/pasm-1.6c-ppc.patch 901
+MD5 2e9757ce0482d8efbd257c0b6044e4ef files/digest-pasm-1.6c 55
diff --git a/dev-lang/pasm/files/digest-pasm-1.6c b/dev-lang/pasm/files/digest-pasm-1.6c
new file mode 100644
index 000000000000..d90c9b621cbf
--- /dev/null
+++ b/dev-lang/pasm/files/digest-pasm-1.6c
@@ -0,0 +1 @@
+MD5 5bb10c13d1bae878e129cdf02ba3a9cd pasm.tar.gz 82136
diff --git a/dev-lang/pasm/files/pasm-1.6c-ppc.patch b/dev-lang/pasm/files/pasm-1.6c-ppc.patch
new file mode 100644
index 000000000000..24ff8056b937
--- /dev/null
+++ b/dev-lang/pasm/files/pasm-1.6c-ppc.patch
@@ -0,0 +1,29 @@
+diff -Naur pasm-1.6c.orig/Makefile pasm-1.6c/Makefile
+--- pasm-1.6c.orig/Makefile 2001-05-14 18:06:01.000000000 +0200
++++ pasm-1.6c/Makefile 2004-02-28 16:19:21.000000000 +0100
+@@ -14,9 +14,9 @@
+
+ # Unix
+ CC = gcc
+-COPTS = -O2 -fomit-frame-pointer -DIrix53 -DOFMT_DEFAULT=OFMT_ELF
++COPTS = $(CFLAGS) -DLinuxPPC -DOFMT_DEFAULT=OFMT_ELF
+ CLIBS = -lm
+-DIR = Irix5.3
++DIR = LinuxPPC
+
+
+ PPCobj = $(DIR)/main.o $(DIR)/support.o $(DIR)/pass.o $(DIR)/eval.o \
+diff -Naur pasm-1.6c.orig/ppcasm.h pasm-1.6c/ppcasm.h
+--- pasm-1.6c.orig/ppcasm.h 2003-11-01 13:49:29.000000000 +0100
++++ pasm-1.6c/ppcasm.h 2004-02-28 16:16:38.000000000 +0100
+@@ -162,6 +162,10 @@
+ #define MACHINE "Linux/Alpha"
+ #define LITTLEENDIAN
+ #define TYPES64BIT
++#elif defined (LinuxPPC)
++#define MACHINE "Linux/PPC"
++#define BIGENDIAN
++#define STDTYPES
+ #elif defined (Wintel) /* jab */
+ #define MACHINE "Wintel"
+ #define LITTLEENDIAN
diff --git a/dev-lang/pasm/metadata.xml b/dev-lang/pasm/metadata.xml
new file mode 100644
index 000000000000..c49f8448da7c
--- /dev/null
+++ b/dev-lang/pasm/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>dholm@gentoo.org</email>
+ <name>David Holm</name>
+</maintainer>
+<longdescription>pasm is a portable assembler for processors of the PowerPC family, written completely in ANSI-C. All PPC standard instructions, AltiVec instructions, all 32-bit extended mnemonics and most of the 64-bit extended mnemonics are supported. pasm knows about nearly 50 directives. Among them are directives for macros, conditional assembly, include files, base-relative addressing (small data), etc..</longdescription>
+</pkgmetadata>
diff --git a/dev-lang/pasm/pasm-1.6c.ebuild b/dev-lang/pasm/pasm-1.6c.ebuild
new file mode 100644
index 000000000000..55e4609ed1a6
--- /dev/null
+++ b/dev-lang/pasm/pasm-1.6c.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/pasm/pasm-1.6c.ebuild,v 1.1 2004/02/28 15:37:38 dholm Exp $
+
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="pasm is a portable assembler for processors of the PowerPC family."
+SRC_URI="http://devnull.owl.de/~frank/${PN}.tar.gz"
+HOMEPAGE="http://devnull.owl.de/~frank/pasm_e.html"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~ppc"
+
+src_unpack() {
+ mkdir -p ${S}
+ mkdir -p ${S}/LinuxPPC
+ cd ${S}
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-ppc.patch
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install () {
+ dobin pasm
+ dodoc pasm.doc
+}