summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/mpmath/ChangeLog6
-rw-r--r--dev-python/mpmath/Manifest4
-rw-r--r--dev-python/mpmath/mpmath-0.14.ebuild33
3 files changed, 25 insertions, 18 deletions
diff --git a/dev-python/mpmath/ChangeLog b/dev-python/mpmath/ChangeLog
index c81d05b5a90a..74fd96edd88e 100644
--- a/dev-python/mpmath/ChangeLog
+++ b/dev-python/mpmath/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/mpmath
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mpmath/ChangeLog,v 1.9 2010/02/06 08:21:44 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mpmath/ChangeLog,v 1.10 2010/02/06 11:19:52 arfrever Exp $
+
+ 06 Feb 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ mpmath-0.14.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
*mpmath-0.14 (06 Feb 2010)
diff --git a/dev-python/mpmath/Manifest b/dev-python/mpmath/Manifest
index 1bb90fc45a64..769c99fe29a3 100644
--- a/dev-python/mpmath/Manifest
+++ b/dev-python/mpmath/Manifest
@@ -1,6 +1,6 @@
DIST mpmath-0.13.tar.gz 324959 RMD160 b379d88a494be862f57b01526745ae24f0e9b3f0 SHA1 2ae72cb66b4d22e9db9dd8c4a0f3ac9512671131 SHA256 abf336b083562848456796209f67aa9742af295e7fc82d9f44ef1ab7aeab39c7
DIST mpmath-0.14.tar.gz 468606 RMD160 54b07c811cd1d9b7c4a9d1da91050dd921aa75f3 SHA1 94069d827d08f9547301e0faf04f0e2574a7dae5 SHA256 039c8649c926584c93e88b917908bfb512ceb4d124ba787f2aa14ecaf58f007b
EBUILD mpmath-0.13.ebuild 984 RMD160 c94cf3d1d2b0ae99e1f32fd9d5209cd78d17dcff SHA1 8343f5fe2739c182ead74f5f7edb35d14e93d1c8 SHA256 a061d1f8be45ad46ce047f08ef4da83ee9f50020656a8738eecaddccdd9b71b0
-EBUILD mpmath-0.14.ebuild 984 RMD160 8d591448f2e61f6f29bffdc7c2c94de14bc1a726 SHA1 91496ce8e2526dae27d5e62c8ad94792134e03fa SHA256 9a21257fccf76e93b895804c210c3d431378d74a819b56e510023b90a03445e8
-MISC ChangeLog 1522 RMD160 9a1f45ba83f71235b04b41be5593b7209d8dfc2c SHA1 5d180380c2d694ef373df2d871d30ee5cd22e423 SHA256 e6cdda12e6fc02635c34dd7e69db54511d63f2f7e4905cddc7f443b243fdff7f
+EBUILD mpmath-0.14.ebuild 1061 RMD160 a40c25b7ad67c0cf41f311e131f17780f052e513 SHA1 5926acb4e1d773a6162850e8e5ffcda426b55385 SHA256 3ff008a6851c612f34d208f857d57aa5c63decbd4b08d43cf4dca7ad0c24a1e3
+MISC ChangeLog 1648 RMD160 b8f1439a06d38241baf90930931975488c78735f SHA1 135c5477d60937dd0fb56cc3fb6e3d5178294c36 SHA256 6504ff6901e9baceb0d42d9af4914dfcc0202a554676957bb12fb9bbdbc1b461
MISC metadata.xml 365 RMD160 ece7c524ccedeb12b39753fba601dd830c25f8ab SHA1 afc79096300fa102014e4e794fdc20814b25f363 SHA256 d6bb09b59c81f6643741decbdce8d164005673b406d703ce5c2448891b2db2a8
diff --git a/dev-python/mpmath/mpmath-0.14.ebuild b/dev-python/mpmath/mpmath-0.14.ebuild
index 90e2c7edf938..f4066d24b3c5 100644
--- a/dev-python/mpmath/mpmath-0.14.ebuild
+++ b/dev-python/mpmath/mpmath-0.14.ebuild
@@ -1,35 +1,43 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mpmath/mpmath-0.14.ebuild,v 1.1 2010/02/06 08:21:44 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mpmath/mpmath-0.14.ebuild,v 1.2 2010/02/06 11:19:52 arfrever Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="py.test"
-EAPI=2
-NEED_PYTHON=2.4
inherit distutils
DESCRIPTION="A python library for arbitrary-precision floating-point arithmetic"
-HOMEPAGE="http://code.google.com/p/${PN}/"
+HOMEPAGE="http://code.google.com/p/mpmath/ http://pypi.python.org/pypi/mpmath"
SRC_URI="http://mpmath.googlecode.com/files/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc examples gmp test"
+IUSE="doc examples gmp"
RDEPEND="gmp? ( dev-python/gmpy )"
-DEPEND="doc? ( dev-python/sphinx )
- test? ( dev-python/py )"
+DEPEND="doc? ( dev-python/sphinx )"
+RESTRICT_PYTHON_ABIS="3.*"
+
+DOCS="CHANGES"
src_compile() {
distutils_src_compile
if use doc; then
cd doc
- "${python}" build.py
- cd ..
+ "$(PYTHON -f)" build.py
fi
}
+src_test() {
+ cd mpmath/tests
+ distutils_src_test
+}
+
src_install() {
- DOCS="CHANGES"
distutils_src_install
if use doc; then
@@ -43,8 +51,3 @@ src_install() {
doins demo/*
fi
}
-
-src_test() {
- cd mpmath/tests
- py.test || die "tests failed"
-}