summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-strategy/wesnoth/ChangeLog8
-rw-r--r--games-strategy/wesnoth/Manifest4
-rw-r--r--games-strategy/wesnoth/files/digest-wesnoth-0.6.99.31
-rw-r--r--games-strategy/wesnoth/wesnoth-0.6.99.3.ebuild36
4 files changed, 47 insertions, 2 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index 016b92beb603..cd33abd91e33 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.10 2004/02/06 09:26:34 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.11 2004/02/16 10:56:00 mr_bones_ Exp $
+
+*wesnoth-0.6.99.3 (16 Feb 2004)
+
+ 16 Feb 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ wesnoth-0.6.99.3.ebuild:
+ version bump (bug #41619)
*wesnoth-0.6.99.2 (06 Feb 2004)
diff --git a/games-strategy/wesnoth/Manifest b/games-strategy/wesnoth/Manifest
index b66f06a765d4..928cbcfc244f 100644
--- a/games-strategy/wesnoth/Manifest
+++ b/games-strategy/wesnoth/Manifest
@@ -1,14 +1,16 @@
MD5 15da46914c18a71422e2cde7d225a9c6 wesnoth-0.4.8.ebuild 1042
MD5 a30c9d4ce8f9629d6d7323eaab258343 metadata.xml 241
-MD5 a01b41603a4cff92a8d3218fe4186956 ChangeLog 1521
+MD5 3f5bc9c4dc0ba83ebe5518debee41a17 ChangeLog 1665
MD5 523e7508fde512b80444bdf35bf999b7 wesnoth-0.5.1.ebuild 1086
MD5 8095bf0449b4c25a1f918c5bc30b3a16 wesnoth-0.5.ebuild 1191
MD5 93568e78956478a481244d3dc74cbe5e wesnoth-0.6.1.ebuild 893
MD5 f5d5b6d1503a3ba1e0b070681ad7b902 wesnoth-0.6.99.1.ebuild 918
MD5 d341487bf607c02fa430fb1650f842dd wesnoth-0.6.99.2.ebuild 918
+MD5 4c49a75ccb2f8d4606b13c6c88812d7c wesnoth-0.6.99.3.ebuild 918
MD5 12449f4d45609424ab20eb79f5f77baf files/digest-wesnoth-0.4.8 66
MD5 906d61f6bd37904556d48a72fd3d7e7f files/digest-wesnoth-0.5 65
MD5 d5ad9b90f362470f8749bf69f17eb378 files/digest-wesnoth-0.5.1 67
MD5 a4c70d154e44e8992198d637fcb4e13a files/digest-wesnoth-0.6.1 67
MD5 54b74b28b80b25f584a88dfdb4e1762d files/digest-wesnoth-0.6.99.1 70
MD5 e966635a1c1ba1490da3e026499af97f files/digest-wesnoth-0.6.99.2 70
+MD5 b1d414864c9edca563ad0d94140311f0 files/digest-wesnoth-0.6.99.3 70
diff --git a/games-strategy/wesnoth/files/digest-wesnoth-0.6.99.3 b/games-strategy/wesnoth/files/digest-wesnoth-0.6.99.3
new file mode 100644
index 000000000000..b46a7eee43a5
--- /dev/null
+++ b/games-strategy/wesnoth/files/digest-wesnoth-0.6.99.3
@@ -0,0 +1 @@
+MD5 f73bd189438c6675c5b63e7664ba584d wesnoth-0.6.99.3.tar.gz 15833979
diff --git a/games-strategy/wesnoth/wesnoth-0.6.99.3.ebuild b/games-strategy/wesnoth/wesnoth-0.6.99.3.ebuild
new file mode 100644
index 000000000000..d35ceef6910a
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-0.6.99.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-0.6.99.3.ebuild,v 1.1 2004/02/16 10:56:00 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org/"
+SRC_URI="http://www.wesnoth.org/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 amd64 ppc"
+IUSE="server editor tools"
+
+DEPEND=">=media-libs/libsdl-1.2
+ >=media-libs/sdl-image-1.2
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/sdl-ttf-2.0
+ media-libs/sdl-net
+ virtual/x11"
+
+src_compile() {
+ egamesconf \
+ `use_enable server` \
+ `use_enable editor` \
+ `use_enable tools` \
+ || die "egamesconf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc MANUAL changelog || die "dodoc failed"
+ prepgamesdirs
+}