summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-laptop/tpb/tpb-0.4.2.ebuild')
-rw-r--r--app-laptop/tpb/tpb-0.4.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-laptop/tpb/tpb-0.4.2.ebuild b/app-laptop/tpb/tpb-0.4.2.ebuild
new file mode 100644
index 000000000000..1f5fde4d71e6
--- /dev/null
+++ b/app-laptop/tpb/tpb-0.4.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/tpb/tpb-0.4.2.ebuild,v 1.1 2004/03/08 05:08:54 latexer Exp $
+
+DESCRIPTION="Thinkpad button utility"
+HOMEPAGE="http://savannah.nongnu.org/projects/tpb/"
+SRC_URI="http://savannah.nongnu.org/download/tpb/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="x11-libs/xosd"
+
+src_compile() {
+ econf
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}
+pkg_postinst() {
+ einfo "tpb requires you to have nvram support compiled into"
+ einfo "your kernel to function."
+}