summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/librep/librep-20020419.ebuild')
-rw-r--r--dev-libs/librep/librep-20020419.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-libs/librep/librep-20020419.ebuild b/dev-libs/librep/librep-20020419.ebuild
new file mode 100644
index 000000000000..93e5a7139c46
--- /dev/null
+++ b/dev-libs/librep/librep-20020419.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Spider <spider@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/dev-libs/librep/librep-0.15.2.ebuild,v 1.1 2002/01/23 18:45:25 azarah Exp
+
+# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
+DEBUG="yes"
+RESTRICT="nostrip"
+# force debug information
+CFLAGS="${CFLAGS} -g"
+CXXFLAGS="${CXXFLAGS} -g"
+
+
+S=${WORKDIR}/librep-2002-04-19
+DESCRIPTION="Shared library implementing a Lisp dialect"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/pre-gnome2/sources/librep/librep-2002-04-19.tar.bz2"
+HOMEPAGE="http://librep.sourceforge.net/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/gdbm-1.8.0
+ >=dev-libs/gmp-3.1.1
+ readline? ( >=sys-libs/readline-4.1
+ >=sys-libs/ncurses-5.2 )
+ sys-apps/texinfo"
+
+src_compile() {
+ local myconf
+
+ if [ "`use readline`" ] ; then
+ myconf="--with-readline"
+ else
+ myconf="--without-readline"
+ fi
+
+ ./configure --host=${CHOST} \
+ ${myconf} \
+ --prefix=/usr \
+ --libexecdir=/usr/lib \
+ --infodir=/usr/share/info || die
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ insinto /usr/include
+ doins src/rep_config.h
+ dodoc AUTHORS BUGS COPYING ChangeLog NEWS README THANKS TODO DOC
+ docinto doc
+ dodoc doc/*
+}