summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tcltk/itcl/itcl-3.2-r2.ebuild')
-rw-r--r--dev-tcltk/itcl/itcl-3.2-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-tcltk/itcl/itcl-3.2-r2.ebuild b/dev-tcltk/itcl/itcl-3.2-r2.ebuild
new file mode 100644
index 000000000000..2f4742e03b3d
--- /dev/null
+++ b/dev-tcltk/itcl/itcl-3.2-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/itcl/itcl-3.2-r2.ebuild,v 1.15 2004/04/05 04:17:12 zx Exp $
+
+MY_P=${PN}${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Object Oriented Enhancements for Tcl/Tk"
+SRC_URI="http://dev.scriptics.com/ftp/${PN}/${MY_P}.tar.gz"
+HOMEPAGE="http://www.tcltk.com/itcl/"
+
+SLOT="0"
+LICENSE="as-is BSD"
+KEYWORDS="x86 ppc sparc alpha amd64"
+
+DEPEND="dev-lang/tk"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PF}-gentoo.diff
+}
+
+src_compile() {
+ econf || die "Econf failed"
+ make CFLAGS_DEFAULT="${CFLAGS}" || die "Make failed"
+}
+
+src_install() {
+ einstall || die "Einstall failed"
+
+ rm ${D}/usr/lib/iwidgets
+ ln -s iwidgets3.0.1 ${D}/usr/lib/iwidgets
+ dodoc CHANGES INCOMPATIBLE README TODO license.terms
+ dodoc doc/*
+}