summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dialup/rp-pppoe/rp-pppoe-3.3.ebuild')
-rw-r--r--net-dialup/rp-pppoe/rp-pppoe-3.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-dialup/rp-pppoe/rp-pppoe-3.3.ebuild b/net-dialup/rp-pppoe/rp-pppoe-3.3.ebuild
new file mode 100644
index 000000000000..607c31457190
--- /dev/null
+++ b/net-dialup/rp-pppoe/rp-pppoe-3.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>, David Bresson <david.bresson@yale.edu>
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/rp-pppoe/rp-pppoe-3.3.ebuild,v 1.1 2001/10/24 09:14:29 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}/src
+DESCRIPTION="A user-mode PPPoE client and server suite for Linux"
+SRC_URI="http://www.roaringpenguin.com/pppoe/${A}"
+HOMEPAGE="http://www.roaringpeguin.com/"
+
+DEPEND="virtual/glibc >=net-dialup/ppp-2.4.1"
+
+src_compile() {
+
+ try ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST}
+ try make
+
+}
+
+src_install () {
+
+ try make RPM_INSTALL_ROOT=${D} install
+ dodir /usr/share/doc
+ mv ${D}/usr/doc/${P} ${D}/usr/share/doc/${PF}
+ rm -rf ${D}/usr/doc
+ prepalldocs
+
+}
+