summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/xchat-gnome/files/0.10-libnotify-libsexy-configure.patch')
-rw-r--r--net-irc/xchat-gnome/files/0.10-libnotify-libsexy-configure.patch55
1 files changed, 55 insertions, 0 deletions
diff --git a/net-irc/xchat-gnome/files/0.10-libnotify-libsexy-configure.patch b/net-irc/xchat-gnome/files/0.10-libnotify-libsexy-configure.patch
new file mode 100644
index 000000000000..b4be5330749c
--- /dev/null
+++ b/net-irc/xchat-gnome/files/0.10-libnotify-libsexy-configure.patch
@@ -0,0 +1,55 @@
+diff -Nur xchat-gnome-0.10.orig/configure.ac xchat-gnome-0.10/configure.ac
+--- xchat-gnome-0.10.orig/configure.ac 2006-03-02 21:23:29.268163000 +0000
++++ xchat-gnome-0.10/configure.ac 2006-03-02 21:31:37.000000000 +0000
+@@ -110,24 +110,39 @@
+
+ AM_CONDITIONAL([ENABLE_DBUS],[test "x$dbus" = "xyes"])
+
++AC_ARG_ENABLE([libsexy],
++ AS_HELP_STRING([--enable-libsexy],[Enable libsexy support]),
++ [enable_libsexy=$enableval libsexy=$enableval],
++ [enable_libsexy=no libsexy=no])
++
+ # libsexy soft dependency
+-PKG_CHECK_MODULES([LIBSEXY], [libsexy >= $LIBSEXY_REQUIRED], libsexy=yes, libsexy=no)
+-AC_SUBST([LIBSEXY_CFLAGS])
+-AC_SUBST([LIBSEXY_LIBS])
++if test "x$enable_libsexy" = "xyes"; then
++ PKG_CHECK_MODULES([LIBSEXY], [libsexy >= $LIBSEXY_REQUIRED], libsexy=yes, libsexy=no)
++ AC_SUBST([LIBSEXY_CFLAGS])
++ AC_SUBST([LIBSEXY_LIBS])
++fi
++
+ AM_CONDITIONAL([ENABLE_LIBSEXY],[test "x$libsexy" = "xyes"])
+-if test "x$libsexy" = xyes; then
+- AC_DEFINE(HAVE_LIBSEXY, 1, [Enable libsexy])
+-else
+- AC_MSG_WARN([Library requirements (libsexy >= $LIBSEXY_REQUIRED) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.])
++
++if test "x$enable_libsexy" = "xyes" && test "x$libsexy" != "xyes"; then
++ AC_MSG_ERROR([libsexy not found])
+ fi
+
++AC_ARG_ENABLE([libnotify],
++ AS_HELP_STRING([--enable-libnotify],[Enable libnotify support]),
++ [enable_libnotify=$enableval libnotify=$enableval],
++ [enable_libnotify=no libnotify=no])
++
+ # libnotify soft dependency
+-PKG_CHECK_MODULES([LIBNOTIFY], [libnotify >= $LIBNOTIFY_REQUIRED], libnotify=yes, libnotify=no)
+-AC_SUBST([LIBNOTIFY_CFLAGS])
+-AC_SUBST([LIBNOTIFY_LIBS])
++if test "x$enable_libnotify" = "xyes"; then
++ PKG_CHECK_MODULES([LIBNOTIFY], [libnotify >= $LIBNOTIFY_REQUIRED], libnotify=yes, libnotify=no)
++ AC_SUBST([LIBNOTIFY_CFLAGS])
++ AC_SUBST([LIBNOTIFY_LIBS])
++fi
++
+ AM_CONDITIONAL([ENABLE_LIBNOTIFY],[test "x$libnotify" = "xyes"])
+-if test "x$libnotify" = xyes; then
+- AC_MSG_WARN([Library requirements (libnotify >= $LIBNOTIFY_REQUIRED) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.])
++if test "x$enable_libnotify" = "xyes" && test "x$libnotify" != "xyes"; then
++ AC_MSG_ERROR([libnotify not found])
+ fi
+
+ # GConf