summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/bwa/bwa-0.6.1.ebuild')
-rw-r--r--sci-biology/bwa/bwa-0.6.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sci-biology/bwa/bwa-0.6.1.ebuild b/sci-biology/bwa/bwa-0.6.1.ebuild
new file mode 100644
index 000000000000..96c0be66c38a
--- /dev/null
+++ b/sci-biology/bwa/bwa-0.6.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/bwa/bwa-0.6.1.ebuild,v 1.1 2011/11/30 08:44:21 weaver Exp $
+
+EAPI=2
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Burrows-Wheeler Alignment Tool, a fast short genomic sequence aligner"
+HOMEPAGE="http://bio-bwa.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bio-bwa/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+
+src_prepare() {
+ sed -e "s/\$(CC) \$(CFLAGS)/\$(CC) \$(LDFLAGS) \$(CFLAGS)/" \
+ -i "${S}"/Makefile || die #336348
+ append-flags -pthread
+}
+
+src_compile() {
+ emake -e CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ dobin bwa || die
+ doman bwa.1 || die
+ exeinto /usr/share/${PN}
+ doexe solid2fastq.pl || die
+ doexe qualfa2fq.pl || die
+ dodoc ChangeLog NEWS || die
+}