aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <stephen.arnold42@gmail.com>2015-06-06 09:06:57 -0700
committerSteve Arnold <stephen.arnold42@gmail.com>2015-06-06 09:06:57 -0700
commit4d4097ee5104b0ecf725f672a3bf2f35931ee8d5 (patch)
treeb9e66c422d137e6f90a7d2bd6410024734132763 /media-libs
parentstripped graphite flags from vo-aacenc config (diff)
downloadarm-4d4097ee5104b0ecf725f672a3bf2f35931ee8d5.tar.gz
arm-4d4097ee5104b0ecf725f672a3bf2f35931ee8d5.tar.bz2
arm-4d4097ee5104b0ecf725f672a3bf2f35931ee8d5.zip
also stripped graphite flags from vo-vo-amrwbenc config
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/vo-amrwbenc/Manifest1
-rw-r--r--media-libs/vo-amrwbenc/vo-amrwbenc-0.1.3.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/media-libs/vo-amrwbenc/Manifest b/media-libs/vo-amrwbenc/Manifest
new file mode 100644
index 0000000..d9e4b31
--- /dev/null
+++ b/media-libs/vo-amrwbenc/Manifest
@@ -0,0 +1 @@
+DIST vo-amrwbenc-0.1.3.tar.gz 608936 SHA256 5652b391e0f0e296417b841b02987d3fd33e6c0af342c69542cbb016a71d9d4e SHA512 5f132f798f00ec2c0619700ab1ce456897792b45631af4b538c866636af9c9de5600af5f79040c41c3dc69c17cf4be7032139a9518a46a4276431e091f3dd6a9 WHIRLPOOL e4d10c0a9504ea27a515efb2d96428eea4c6a0c879c4377a37026c217a60515747e1616dff7da9222c1a8d263f6d106370d3fe7edc05d3fe547960ac4f24579d
diff --git a/media-libs/vo-amrwbenc/vo-amrwbenc-0.1.3.ebuild b/media-libs/vo-amrwbenc/vo-amrwbenc-0.1.3.ebuild
new file mode 100644
index 0000000..a497b20
--- /dev/null
+++ b/media-libs/vo-amrwbenc/vo-amrwbenc-0.1.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+
+if [[ ${PV} == *9999 ]] ; then
+ SCM="git-2"
+ EGIT_REPO_URI="git://github.com/mstorsjo/${PN}.git"
+ [[ ${PV%9999} != "" ]] && EGIT_BRANCH="release/${PV%.9999}"
+ AUTOTOOLS_AUTORECONF=1
+fi
+
+inherit autotools-multilib flag-o-matic ${SCM}
+
+DESCRIPTION="VisualOn AMR-WB encoder library"
+HOMEPAGE="http://sourceforge.net/projects/opencore-amr/"
+
+if [[ ${PV} == *9999 ]] ; then
+ SRC_URI=""
+elif [[ ${PV%_p*} != ${PV} ]] ; then # Gentoo snapshot
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+else # Official release
+ SRC_URI="mirror://sourceforge/opencore-amr/${P}.tar.gz"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+[[ ${PV} == *9999 ]] || \
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~x64-macos"
+IUSE="examples static-libs"
+
+src_configure() {
+ filter-flags -floop-interchange -floop-strip-mine -floop-block
+
+ use neon && append-flags "-mfpu=neon"
+
+ local myeconfargs=(
+ $(use_enable examples example) \
+ )
+ autotools-multilib_src_configure
+}