aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <stephen.arnold42@gmail.com>2015-07-27 12:05:55 -0700
committerSteve Arnold <stephen.arnold42@gmail.com>2015-07-27 12:05:55 -0700
commit40dc40f0aac0507f8096e1de3ac90aa84d95c31a (patch)
tree6baf72182840535cd8082f0bdeab3ac9243b89be /xfce-base
parentadded EGL patch for mesa-progs (diff)
downloadarm-40dc40f0aac0507f8096e1de3ac90aa84d95c31a.tar.gz
arm-40dc40f0aac0507f8096e1de3ac90aa84d95c31a.tar.bz2
arm-40dc40f0aac0507f8096e1de3ac90aa84d95c31a.zip
updated use flags/config for xfce4-settings
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfce4-settings/Manifest1
-rw-r--r--xfce-base/xfce4-settings/xfce4-settings-4.12.0.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/xfce-base/xfce4-settings/Manifest b/xfce-base/xfce4-settings/Manifest
new file mode 100644
index 0000000..d17954e
--- /dev/null
+++ b/xfce-base/xfce4-settings/Manifest
@@ -0,0 +1 @@
+DIST xfce4-settings-4.12.0.tar.bz2 973324 SHA256 04becef105c19d0266cfe8dbf42619e7233c3b9fa99b43dbfc9c6a5959501f81 SHA512 4a61c16f1f03de98c9968a00b50595e2934aaf28b80613c59403d33a293a7f8ef9ebb6fad98b0eeb97a6590b9100e91f73dd6363133d5d8bd06714f1126d8856 WHIRLPOOL 52a66c1b99f67b1e92ccbc223535617a6edff67857032d7c19581fe38e4b5b7e2b32a42bb5263f92ec02596035dd76f6a8f6387f17e524b035def717eda373ff
diff --git a/xfce-base/xfce4-settings/xfce4-settings-4.12.0.ebuild b/xfce-base/xfce4-settings/xfce4-settings-4.12.0.ebuild
new file mode 100644
index 0000000..a8bb873
--- /dev/null
+++ b/xfce-base/xfce4-settings/xfce4-settings-4.12.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="Configuration system for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ~ia64 ~mips ppc ppc64 ~sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug libcanberra libinput libnotify upower +xcursor +xklavier +xrandr"
+
+RDEPEND=">=dev-libs/dbus-glib-0.100
+ >=dev-libs/glib-2.24
+ media-libs/fontconfig
+ >=x11-libs/gtk+-2.20:2
+ x11-libs/libX11
+ >=x11-libs/libXi-1.3
+ >=xfce-base/garcon-0.2
+ >=xfce-base/exo-0.8
+ >=xfce-base/libxfce4ui-4.11
+ >=xfce-base/libxfce4util-4.11
+ >=xfce-base/xfconf-4.10
+ libcanberra? ( >=media-libs/libcanberra-0.25[sound] )
+ libinput? ( x11-drivers/xf86-input-libinput )
+ libnotify? ( >=x11-libs/libnotify-0.7 )
+ upower? ( || ( >=sys-power/upower-0.9.23 sys-power/upower-pm-utils ) )
+ xcursor? ( >=x11-libs/libXcursor-1.1 )
+ xklavier? ( >=x11-libs/libxklavier-5 )
+ xrandr? ( >=x11-libs/libXrandr-1.2 )"
+
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext
+ >=x11-proto/inputproto-1.4
+ x11-proto/xproto"
+
+pkg_setup() {
+ XFCONF=(
+ --enable-gio-unix
+ $(use_enable upower upower-glib)
+ $(use_enable libinput xorg-libinput)
+ $(use_enable libnotify)
+ $(use_enable xcursor)
+ $(use_enable xrandr)
+ $(use_enable xklavier libxklavier)
+ $(use_enable libcanberra sound-settings)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS TODO )
+}