aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenri Gasc <gasc@eurecom.fr>2024-07-09 16:58:13 +0200
committerHenri Gasc <gasc@eurecom.fr>2024-07-09 16:59:15 +0200
commiteab0472a57f9ecdd85eecd42cec9446e6adcb211 (patch)
treedc80ff42889e0850e02d620aaf956c930dd3bfba /app-editors
parentdev-python/PythonQwt: add 0.12.6 (diff)
downloadguru-eab0472a57f9ecdd85eecd42cec9446e6adcb211.tar.gz
guru-eab0472a57f9ecdd85eecd42cec9446e6adcb211.tar.bz2
guru-eab0472a57f9ecdd85eecd42cec9446e6adcb211.zip
app-editors/imhex: add 1.35.3, drop 1.33.2-r1
Signed-off-by: Henri Gasc <gasc@eurecom.fr>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/imhex/Manifest4
-rw-r--r--app-editors/imhex/files/remove_Werror.patch21
-rw-r--r--app-editors/imhex/files/remove_dotnet.patch26
-rw-r--r--app-editors/imhex/imhex-1.35.3.ebuild (renamed from app-editors/imhex/imhex-1.33.2-r1.ebuild)0
4 files changed, 36 insertions, 15 deletions
diff --git a/app-editors/imhex/Manifest b/app-editors/imhex/Manifest
index 39350d82f..2190fce9d 100644
--- a/app-editors/imhex/Manifest
+++ b/app-editors/imhex/Manifest
@@ -1,2 +1,2 @@
-DIST imhex-1.33.2.gh.tar.gz 32292253 BLAKE2B 97d8b0f5c7b9621bfa36dbd85f24040c7d8d7dffca154cd85ff128160428d8d590b42e348aa8dbd48b4a21f747d6a0d6c3e74fe9ee484a77f061d5ea28661e70 SHA512 393719670019d7fa11d3f67a6b5ef8d2ae75812078a8beaba6b9b3091a283fc9790161c018073933c1b4a8cbcedf8ff7534aacac20ef4d210f10632db6e487ec
-DIST imhex-patterns-1.33.2.gh.tar.gz 7603711 BLAKE2B 17eb5aaa9bec2418f3ca9fe23e9e3cb5443ce1a5624c3dbcece9bcbe2ca7a95a2498d7fd713bbed78854b136b9884d7f4cb0d8453ded262b6fb6efb377219a96 SHA512 e6b6409b5f5e64de339f5a493c33c06e6033c8f4a1fc594f8f23d3ecd9b6d8a66e712e06649f0312e55860a682e532db000d1f1534d6fdd88181b6738c9201e0
+DIST imhex-1.35.3.gh.tar.gz 33023289 BLAKE2B ebafcda5c873f87945f3d0135615932f545717988920086dd2f09e6ca1c62fda88f272f9ab6a2dae43db49083c9c0c5b6842c55d0c2d2ff667e3f49b84a01097 SHA512 711f98710b00da3ed826367a208678fa3231b02abc61b33d05034cefef3617f6641da78df88ba354a02a16c5d119ee8560fc66d95295214dcd0bdeaab9967c0c
+DIST imhex-patterns-1.35.3.gh.tar.gz 8114314 BLAKE2B 5f89d35c375d5dbe4d1e52ea5c41d86225aa6b5c76a960f430a5a32f94dd68e7ed8cc2fffdd7a3e7dec11f740ef3e226bd52ac3b1d461c0cc9af074a5b44f63d SHA512 6452bad26072dd178bdad2291e717749df361a098a5be7503c7c00e8e8486d2e465fd585d7fa82fe1927848efdcc681cf81e35255cb437231552816cf67ac568
diff --git a/app-editors/imhex/files/remove_Werror.patch b/app-editors/imhex/files/remove_Werror.patch
index 1a35f9e92..891d61a48 100644
--- a/app-editors/imhex/files/remove_Werror.patch
+++ b/app-editors/imhex/files/remove_Werror.patch
@@ -1,5 +1,21 @@
-Remove the different Werror flags we can find used
-Should fix https://bugs.gentoo.org/921663
+--- a/cmake/build_helpers.cmake
++++ b/cmake/build_helpers.cmake
+@@ -563,7 +563,7 @@ macro(setupCompilerFlags target)
+ if(CMAKE_CXX_COMPILER_ID MATCHES "GNU|Clang")
+ # Define strict compilation flags
+ if (IMHEX_STRICT_WARNINGS)
+- set(IMHEX_COMMON_FLAGS "${IMHEX_COMMON_FLAGS} -Wall -Wextra -Wpedantic -Werror")
++ set(IMHEX_COMMON_FLAGS "${IMHEX_COMMON_FLAGS} -Wall -Wextra -Wpedantic")
+ endif()
+
+ if (UNIX AND NOT APPLE AND CMAKE_CXX_COMPILER_ID MATCHES "GNU")
+@@ -871,4 +871,4 @@ function(precompileHeaders target includeFolder)
+ PUBLIC
+ "$<$<COMPILE_LANGUAGE:CXX>:${INCLUDES}>"
+ )
+-endfunction()
+\ No newline at end of file
++endfunction()
--- a/lib/external/pattern_language/cli/CMakeLists.txt
+++ b/lib/external/pattern_language/cli/CMakeLists.txt
@@ -29,7 +29,7 @@ else()
@@ -22,3 +38,4 @@ Should fix https://bugs.gentoo.org/921663
if(CMAKE_CXX_COMPILER_ID MATCHES "GNU")
target_compile_options(libpl PRIVATE -Wno-stringop-overflow)
endif()
+
diff --git a/app-editors/imhex/files/remove_dotnet.patch b/app-editors/imhex/files/remove_dotnet.patch
index 88d5c9700..5f241cf8d 100644
--- a/app-editors/imhex/files/remove_dotnet.patch
+++ b/app-editors/imhex/files/remove_dotnet.patch
@@ -1,14 +1,18 @@
-Remove the compilation step that needs dotnet
-https://bugs.gentoo.org/926761
--- a/plugins/script_loader/CMakeLists.txt
+++ b/plugins/script_loader/CMakeLists.txt
-@@ -45,8 +45,4 @@ if (CoreClrEmbed_FOUND)
- if (IMHEX_BUNDLE_DOTNET)
- install(FILES ${CoreClrEmbed_SHARED_LIBRARIES} DESTINATION ${CMAKE_INSTALL_LIBDIR})
- endif ()
--
-- add_subdirectory(dotnet)
-- add_dependencies(script_loader AssemblyLoader)
--
- endif ()
+@@ -2,7 +2,6 @@ cmake_minimum_required(VERSION 3.16)
+
+ include(ImHexPlugin)
+
+-find_package(CoreClrEmbed)
+ if (CoreClrEmbed_FOUND)
+ set(IMHEX_DOTNET_SCRIPT_SUPPORT ON)
+
+@@ -56,4 +55,4 @@ if (IMHEX_DOTNET_SCRIPT_SUPPORT)
+
+ add_subdirectory(support/dotnet)
+ add_dependencies(script_loader AssemblyLoader)
+-endif()
\ No newline at end of file
++endif()
+
diff --git a/app-editors/imhex/imhex-1.33.2-r1.ebuild b/app-editors/imhex/imhex-1.35.3.ebuild
index 93f9baee0..93f9baee0 100644
--- a/app-editors/imhex/imhex-1.33.2-r1.ebuild
+++ b/app-editors/imhex/imhex-1.35.3.ebuild