aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFerenc Erki <erkiferenc@gmail.com>2024-05-01 21:35:28 +0200
committerFerenc Erki <erkiferenc@gmail.com>2024-05-01 21:35:28 +0200
commit27f85ef9d818c03c7b5a4d98eb7358d3bcc8b0ca (patch)
treecb76250631d92376b8e9805999869f7191f2a930 /app-text
parentapp-misc/watchexec: drop 1.23.0, 1.24.0, 1.24.1, 1.25.0, 2.0.0 (diff)
downloadguru-27f85ef9d818c03c7b5a4d98eb7358d3bcc8b0ca.tar.gz
guru-27f85ef9d818c03c7b5a4d98eb7358d3bcc8b0ca.tar.bz2
guru-27f85ef9d818c03c7b5a4d98eb7358d3bcc8b0ca.zip
app-text/vale: add 3.4.2
Signed-off-by: Ferenc Erki <erkiferenc@gmail.com>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/vale/Manifest2
-rw-r--r--app-text/vale/vale-3.4.2.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/app-text/vale/Manifest b/app-text/vale/Manifest
index c72a535311..a7652a8746 100644
--- a/app-text/vale/Manifest
+++ b/app-text/vale/Manifest
@@ -2,3 +2,5 @@ DIST vale-2.28.3-gentoo-deps.tar.xz 138351324 BLAKE2B b457e78e8a5d4911abfd8e5310
DIST vale-2.28.3.tar.gz 9657963 BLAKE2B 0a8487b80b0da10eedb28ce3df11da296136250d4b275f97802a10bd3ee3f9d920e80253da6ce4cc3cab5314033439dfaceb286de366cf0c0c6658b569b92358 SHA512 e638fbddd6738c56739f9425ff2c63d9afe1c329d96bf18876a8f188ce5064bc30833a3ac046654a38211996d7f8865266d70241a9d5c5f9577c46331a93d4ec
DIST vale-3.4.1-deps.tar.xz 151263460 BLAKE2B 828348dc5e0447ba54cf9b4e369c4e2c63c50a6e72ff79c5a8fd0e8112241296d222e44943a9c5fcc34a4ea0807e7aebb0136a2a02c11bfc96303292d718fc2f SHA512 110a805b61084cbedd604550d5fe757d4df04cd89b1136a43d23b1bdf660c59bc4ad5d692174742aa7984e635ed50a30d43fb22480b01371152a77ea94c7bd67
DIST vale-3.4.1.tar.gz 10528911 BLAKE2B 1975806a212c9bf61f92ec5b4a12f625a7a1d0242ead91b602e57500126c8e635b725ed1072b5cb2907838d73822d8fa66266cf40df1f62f0dd50b678f083423 SHA512 93a70954fa67e8f1a7c3c3c8681784b06c32388c70eb6c75ae90292ae3a913dbb89a0539361b689470ee6a77fd9e0419312a98f64af4d1236d32dc436e3a4d9d
+DIST vale-3.4.2-gentoo-deps.tar.xz 146710436 BLAKE2B 62b1f122f6f29c9037762675e6efd2783317400ee18ae030c6346a14e614aaaa5a96157eab82881204602da6daf09496b06067de971cb0e4107897234968ea57 SHA512 0261b5c69ab095540077f084fccf96c22f81eb53070daf3425ded5c2716b197dc268e420429b89dd5ab87323c1c7ad3832e33bcee4ed9f19a032ff8683187a75
+DIST vale-3.4.2.tar.gz 10528649 BLAKE2B ddad91adc3a132d583df305501f0b80af7267ce249c17f54abe57c013e03463bd3a143a789148637a393cc479da257aabf06597fb9f70a1e961f8854d21cb9f3 SHA512 e6d6ec06d968ac35abf7f08eb5938b46f2e0162c511acef89f0307ba8a917cd7b9b9c3e0ddee50b720e845252991a88a5fa52f9cc3f9415130147db7c2256dac
diff --git a/app-text/vale/vale-3.4.2.ebuild b/app-text/vale/vale-3.4.2.ebuild
new file mode 100644
index 0000000000..47410dd3e7
--- /dev/null
+++ b/app-text/vale/vale-3.4.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module optfeature
+
+DESCRIPTION="A syntax-aware linter for prose built with speed and extensibility in mind"
+HOMEPAGE="https://vale.sh/docs/"
+
+SRC_URI="
+ https://github.com/errata-ai/vale/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/ferki/${PN}/releases/download/v${PV}-gentoo-deps/${P}-gentoo-deps.tar.xz
+"
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# tests require:
+# - various ruby gems: see testdata/Gemfile
+# - packaged optional runtime dependencies: asciidoctor, rst2html, xsltproc
+# - unpackaged optional runtime dependency: dita (may be removed in a patch)
+# - network access: sync subcommand tests (may be removed in a patch)
+RESTRICT="test"
+
+src_prepare() {
+ sed -i "s/\$(LAST_TAG)/v${PV}/" Makefile || die 'sed failed'
+ default
+}
+
+src_compile() {
+ emake build os=linux
+}
+
+src_install() {
+ dobin bin/vale
+ default_src_install
+}
+
+pkg_postinst() {
+ optfeature "AsciiDoc support" dev-ruby/asciidoctor
+ optfeature "reStructuredText support" dev-python/docutils
+ optfeature "XML support" dev-libs/libxslt
+}