aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucio Sauer <watermanpaint@posteo.net>2024-04-26 16:46:35 +0200
committerLucio Sauer <watermanpaint@posteo.net>2024-04-26 16:46:35 +0200
commitf2be215fb991955a99bceb9ba10e5abecd2147ea (patch)
tree1a6a06fb30d548e99fb8ba5182c0a96ad49d553d /app-text
parentdev-libs/libtypec: fix revision bump (7e6af504b7ecc) (diff)
downloadguru-f2be215fb991955a99bceb9ba10e5abecd2147ea.tar.gz
guru-f2be215fb991955a99bceb9ba10e5abecd2147ea.tar.bz2
guru-f2be215fb991955a99bceb9ba10e5abecd2147ea.zip
*/*: fix variable order
Manually went through some entries for `pkgcheck scan -c VariableOrderCheck`. Signed-off-by: Lucio Sauer <watermanpaint@posteo.net>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/lorien-bin/lorien-bin-0.6.0.ebuild8
-rw-r--r--app-text/lsp/lsp-0.5.0_rc4.ebuild5
-rw-r--r--app-text/pandoc-crossref-bin/pandoc-crossref-bin-0.3.17.0c-r1.ebuild12
-rw-r--r--app-text/pandoc-crossref-bin/pandoc-crossref-bin-0.3.17.0e.ebuild12
-rw-r--r--app-text/pandoc-crossref-bin/pandoc-crossref-bin-0.3.17.0f.ebuild12
-rw-r--r--app-text/the-platinum-searcher-bin/the-platinum-searcher-bin-2.2.0.ebuild6
6 files changed, 23 insertions, 32 deletions
diff --git a/app-text/lorien-bin/lorien-bin-0.6.0.ebuild b/app-text/lorien-bin/lorien-bin-0.6.0.ebuild
index 426b11c8a..4e482e8b3 100644
--- a/app-text/lorien-bin/lorien-bin-0.6.0.ebuild
+++ b/app-text/lorien-bin/lorien-bin-0.6.0.ebuild
@@ -4,17 +4,17 @@
EAPI=8
inherit desktop xdg
-SRC_URI="https://github.com/mbrlabs/Lorien/releases/download/v${PV}/Lorien_v${PV}_Linux.tar.xz -> ${P}.tar.xz"
+
DESCRIPTION="Infinite canvas drawing/whiteboarding. Made with Godot."
HOMEPAGE="https://github.com/mbrlabs/Lorien"
+SRC_URI="https://github.com/mbrlabs/Lorien/releases/download/v${PV}/Lorien_v${PV}_Linux.tar.xz -> ${P}.tar.xz"
+
+S="${WORKDIR}/Lorien_v${PV}_Linux"
LICENSE="GPL-3"
SLOT="0"
-
KEYWORDS="~amd64 ~x86"
-S="${WORKDIR}/Lorien_v${PV}_Linux"
-
src_install() {
#Copy Manual & Make a copy of the folder
cp "${FILESDIR}/manual_v${PV}.md" "${S}/manual_v${PV}.md"
diff --git a/app-text/lsp/lsp-0.5.0_rc4.ebuild b/app-text/lsp/lsp-0.5.0_rc4.ebuild
index f4743a069..4d65820d9 100644
--- a/app-text/lsp/lsp-0.5.0_rc4.ebuild
+++ b/app-text/lsp/lsp-0.5.0_rc4.ebuild
@@ -7,14 +7,17 @@ inherit meson
MY_PV="${PV/_/-}"
MY_P="lsp-${MY_PV}"
-S="${WORKDIR}/${MY_P}"
DESCRIPTION="The least significant pager"
HOMEPAGE="https://github.com/dgouders/lsp"
SRC_URI="https://github.com/dgouders/lsp/archive/refs/tags/v${MY_PV}.tar.gz"
+
+S="${WORKDIR}/${MY_P}"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64"
+
RDEPEND="
>=sys-apps/man-db-2.12.0
>=sys-libs/ncurses-6.4_p20230401
diff --git a/app-text/pandoc-crossref-bin/pandoc-crossref-bin-0.3.17.0c-r1.ebuild b/app-text/pandoc-crossref-bin/pandoc-crossref-bin-0.3.17.0c-r1.ebuild
index 89b7c5250..2d6b01fe1 100644
--- a/app-text/pandoc-crossref-bin/pandoc-crossref-bin-0.3.17.0c-r1.ebuild
+++ b/app-text/pandoc-crossref-bin/pandoc-crossref-bin-0.3.17.0c-r1.ebuild
@@ -3,18 +3,14 @@
EAPI=8
DESCRIPTION="Pandoc filter for cross-references"
-
HOMEPAGE="https://github.com/lierdakil/pandoc-crossref"
-
-
SRC_URI="https://github.com/lierdakil/pandoc-crossref/releases/download/v${PV}/pandoc-crossref-Linux.tar.xz -> ${P}.tar.xz"
-LICENSE="GPL-2"
+S="${WORKDIR}"
+LICENSE="GPL-2"
SLOT="0"
-
KEYWORDS="-* ~amd64"
-S=${WORKDIR}
RDEPEND="
|| ( =app-text/pandoc-bin-3.1.12.1 =app-text/pandoc-3.1.12.1 )
@@ -23,6 +19,6 @@ RDEPEND="
src_install() {
exeinto /usr/bin
- newexe ${WORKDIR}/pandoc-crossref pandoc-crossref
- newman ${WORKDIR}/pandoc-crossref.1 pandoc-crossref.1
+ newexe pandoc-crossref pandoc-crossref
+ newman pandoc-crossref.1 pandoc-crossref.1
}
diff --git a/app-text/pandoc-crossref-bin/pandoc-crossref-bin-0.3.17.0e.ebuild b/app-text/pandoc-crossref-bin/pandoc-crossref-bin-0.3.17.0e.ebuild
index eabfc8fb5..63c6021e8 100644
--- a/app-text/pandoc-crossref-bin/pandoc-crossref-bin-0.3.17.0e.ebuild
+++ b/app-text/pandoc-crossref-bin/pandoc-crossref-bin-0.3.17.0e.ebuild
@@ -3,18 +3,14 @@
EAPI=8
DESCRIPTION="Pandoc filter for cross-references"
-
HOMEPAGE="https://github.com/lierdakil/pandoc-crossref"
-
-
SRC_URI="https://github.com/lierdakil/pandoc-crossref/releases/download/v${PV}/pandoc-crossref-Linux.tar.xz -> ${P}.tar.xz"
-LICENSE="GPL-2"
+S="${WORKDIR}"
+LICENSE="GPL-2"
SLOT="0"
-
KEYWORDS="-* ~amd64"
-S=${WORKDIR}
RDEPEND="
|| ( =app-text/pandoc-bin-3.1.12.2 =app-text/pandoc-3.1.12.2 )
@@ -23,6 +19,6 @@ RDEPEND="
src_install() {
exeinto /usr/bin
- newexe ${WORKDIR}/pandoc-crossref pandoc-crossref
- newman ${WORKDIR}/pandoc-crossref.1 pandoc-crossref.1
+ newexe pandoc-crossref pandoc-crossref
+ newman pandoc-crossref.1
}
diff --git a/app-text/pandoc-crossref-bin/pandoc-crossref-bin-0.3.17.0f.ebuild b/app-text/pandoc-crossref-bin/pandoc-crossref-bin-0.3.17.0f.ebuild
index b5ff6700c..340403bb2 100644
--- a/app-text/pandoc-crossref-bin/pandoc-crossref-bin-0.3.17.0f.ebuild
+++ b/app-text/pandoc-crossref-bin/pandoc-crossref-bin-0.3.17.0f.ebuild
@@ -3,18 +3,14 @@
EAPI=8
DESCRIPTION="Pandoc filter for cross-references"
-
HOMEPAGE="https://github.com/lierdakil/pandoc-crossref"
-
-
SRC_URI="https://github.com/lierdakil/pandoc-crossref/releases/download/v${PV}/pandoc-crossref-Linux.tar.xz -> ${P}.tar.xz"
-LICENSE="GPL-2"
+S="${WORKDIR}"
+LICENSE="GPL-2"
SLOT="0"
-
KEYWORDS="-* ~amd64"
-S=${WORKDIR}
RDEPEND="
|| ( =app-text/pandoc-bin-3.1.12.3 =app-text/pandoc-3.1.12.3 )
@@ -23,6 +19,6 @@ RDEPEND="
src_install() {
exeinto /usr/bin
- newexe ${WORKDIR}/pandoc-crossref pandoc-crossref
- newman ${WORKDIR}/pandoc-crossref.1 pandoc-crossref.1
+ newexe pandoc-crossref pandoc-crossref
+ newman pandoc-crossref.1 pandoc-crossref.1
}
diff --git a/app-text/the-platinum-searcher-bin/the-platinum-searcher-bin-2.2.0.ebuild b/app-text/the-platinum-searcher-bin/the-platinum-searcher-bin-2.2.0.ebuild
index a7092781f..98819ddcd 100644
--- a/app-text/the-platinum-searcher-bin/the-platinum-searcher-bin-2.2.0.ebuild
+++ b/app-text/the-platinum-searcher-bin/the-platinum-searcher-bin-2.2.0.ebuild
@@ -7,11 +7,11 @@ DESCRIPTION="Fast CLI search tool, faster than grep, ack, silver_searcher (ag)"
HOMEPAGE="https://github.com/monochromegane/the_platinum_searcher"
SRC_URI="https://github.com/monochromegane/the_platinum_searcher/releases/download/v${PV}/pt_linux_amd64.tar.gz"
+S="${WORKDIR}/pt_linux_amd64"
+
LICENSE="MIT"
-KEYWORDS="~amd64"
SLOT="0"
-
-S="${WORKDIR}/pt_linux_amd64"
+KEYWORDS="~amd64"
src_install() {
dobin pt