aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuan Liao <liaoyuan@gmail.com>2023-06-02 13:24:49 -0700
committerYuan Liao <liaoyuan@gmail.com>2023-06-02 22:21:32 -0700
commit1bea7dd6e2a8265704c0893cab4781e3761e98c8 (patch)
tree7e7e05650f3d55a360dcc31e6804f4873f4d30ff /gnome-extra
parentsys-devel/just: add 1.14.0 (diff)
downloadguru-1bea7dd6e2a8265704c0893cab4781e3761e98c8.tar.gz
guru-1bea7dd6e2a8265704c0893cab4781e3761e98c8.tar.bz2
guru-1bea7dd6e2a8265704c0893cab4781e3761e98c8.zip
gnome-extra/extension-manager: Reinstate 0.3.2
Since version 0.4.0, this package depends on sys-libs/libbacktrace, which has been last-rited in ::gentoo. 0.3.2 is the last version without the dependency. Signed-off-by: Yuan Liao <liaoyuan@gmail.com>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/extension-manager/Manifest1
-rw-r--r--gnome-extra/extension-manager/extension-manager-0.3.2.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/gnome-extra/extension-manager/Manifest b/gnome-extra/extension-manager/Manifest
index 6e050af28..7da694ef1 100644
--- a/gnome-extra/extension-manager/Manifest
+++ b/gnome-extra/extension-manager/Manifest
@@ -1,2 +1,3 @@
+DIST extension-manager-0.3.2.tar.gz 1447521 BLAKE2B 55d09b54219804c1910a572953d7fee4b8a9131085260db1d4ef014bccf8b13fa2da0a8673c0d78643841d603878183c2b573b084bcd5cb1818721e8194c871b SHA512 84ff2f246d582cdae06a12e5e88309d67ae32502e9885675c08d75dc686fdea28b53bffa37d396ffface8515712f0b990603b5832704ae722342f0ad49748150
DIST extension-manager-0.4.0.tar.gz 1476951 BLAKE2B 9cf6ed74d30e22de8621ff9481de65295d9be07b82134b861192dfe3a9ebad4ea09be136beda0badc78d45cfd15a889b39b907ef4e258bc4229f6a342adde73d SHA512 9ec774c2dbd9476eeafbad19ea4d7d17ed9dd1de6cabe83511f372434cec11511dfd973cb5d67fba7e062314e2309150014ae83ce9768bb6f2e2f410909c8a1f
DIST extension-manager-0.4.1.tar.gz 1490668 BLAKE2B ca7c4dabc100d4a8aba8a41ecdec3c88676764b81c2e5fdb64785ca5031a31749d058c1a670867fd1028ae13721d8de0c648fd397f63a56871e11899bca4d4f5 SHA512 3da3ff3f42117ad52eecd99e92d65d8d72b95e07a5488f7184577ab10f749b1cee08a3322316bf2a92a8e2b878ca18e94ce7d986331688eafb520cdb8a0bbf1c
diff --git a/gnome-extra/extension-manager/extension-manager-0.3.2.ebuild b/gnome-extra/extension-manager/extension-manager-0.3.2.ebuild
new file mode 100644
index 000000000..0d67294c4
--- /dev/null
+++ b/gnome-extra/extension-manager/extension-manager-0.3.2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Note: This is the last upstream version that does not depend on
+# sys-libs/libbacktrace. ebuilds for version 0.4.0 and above would
+# have to be removed due to sys-libs/libbacktrace last rite.
+
+EAPI=8
+
+inherit gnome2-utils meson xdg
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mjakeman/extension-manager.git"
+else
+ SRC_URI="https://github.com/mjakeman/extension-manager/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A native tool for browsing, installing, and managing GNOME Shell Extensions"
+HOMEPAGE="https://mjakeman.github.io/extension-manager/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+BDEPEND="
+ dev-libs/glib:2
+ dev-util/blueprint-compiler
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/json-glib
+ gui-libs/gtk:4[introspection]
+ gui-libs/libadwaita:1[introspection]
+ gui-libs/text-engine
+ net-libs/libsoup:3.0
+"
+
+DEPEND="
+ ${RDEPEND}
+"
+
+src_configure() {
+ local emesonargs=()
+ if has live ${PROPERTIES}; then
+ # Produce a development build for live ebuild
+ emesonargs+=( -Ddevelopment=true )
+ fi
+ meson_src_configure
+}
+
+# Tests are skipped because as of version 0.3.0, the tests only validate
+# resource files and do not verify any functionality of the program. Those
+# validations are either already handled by QA checks or not relevant on
+# Gentoo. For more information about the rationale, please refer to:
+# https://github.com/gentoo/guru/commit/f896bee213fbb62c70e818c1bf503fee2a41919a#comments
+#
+# If tests are to be executed in the future because the upstream adds
+# functionality tests or for other reasons, and should there be no convenient
+# way to skip the validations, the following variable values need to be set:
+#
+# IUSE="test"
+# RESTRICT="!test? ( test )"
+# BDEPEND="test? ( dev-libs/appstream-glib dev-util/desktop-file-utils )"
+src_test() {
+ :
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}