aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuan Liao <liaoyuan@gmail.com>2023-12-08 16:05:54 -0500
committerYuan Liao <liaoyuan@gmail.com>2023-12-08 16:05:54 -0500
commitc5b808cd38089e7d150e6dadc4bb22d6a9546455 (patch)
treec6eef7f9069afc1d7c69a0f892b0b011ca89047c /gnome-extra
parentdev-python/ManimPango: add 0.4.3 (diff)
downloadguru-c5b808cd38089e7d150e6dadc4bb22d6a9546455.tar.gz
guru-c5b808cd38089e7d150e6dadc4bb22d6a9546455.tar.bz2
guru-c5b808cd38089e7d150e6dadc4bb22d6a9546455.zip
gnome-extra/extension-manager: Drop 0.3.2
Signed-off-by: Yuan Liao <liaoyuan@gmail.com>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/extension-manager/Manifest1
-rw-r--r--gnome-extra/extension-manager/extension-manager-0.3.2.ebuild83
2 files changed, 0 insertions, 84 deletions
diff --git a/gnome-extra/extension-manager/Manifest b/gnome-extra/extension-manager/Manifest
index 97d75161a5..3d2a6dd303 100644
--- a/gnome-extra/extension-manager/Manifest
+++ b/gnome-extra/extension-manager/Manifest
@@ -1,3 +1,2 @@
-DIST extension-manager-0.3.2.tar.gz 1447521 BLAKE2B 55d09b54219804c1910a572953d7fee4b8a9131085260db1d4ef014bccf8b13fa2da0a8673c0d78643841d603878183c2b573b084bcd5cb1818721e8194c871b SHA512 84ff2f246d582cdae06a12e5e88309d67ae32502e9885675c08d75dc686fdea28b53bffa37d396ffface8515712f0b990603b5832704ae722342f0ad49748150
DIST extension-manager-0.4.2.tar.gz 1469519 BLAKE2B 070016a50f48a89d39c760c7ec60fabc856dcdd7a8fc4a779253ede2354f7d9d6744fa7620e55a92f9ed671a00b8aff1fd9246d7dc919727893215d2f05e0658 SHA512 777c0d83f26064372a721681092ef7990ade028ea2d6bb8bb64aa8a4630cea60f2af07c1cf7d733a8f100fe5d7de5b1aeac2b99d8a585dc715ee469a874c0148
DIST extension-manager-0.4.3.tar.gz 1479403 BLAKE2B 5d183cf8af08b07878a65305f5b814f5e74a600a305845c9d953cb4debf8476e4e81e932dd645eb54e9c45e662c69c7f2c44e4e40698137d1724c23ab3b42e95 SHA512 036ee3f5c2b6e70e36060112744a760f7f6f29cd7dbc9eafa035942bb283b18b94d55c68285f5c546480e2683e2ceddb4f6e1d309002b18894bccb3b6b87a67d
diff --git a/gnome-extra/extension-manager/extension-manager-0.3.2.ebuild b/gnome-extra/extension-manager/extension-manager-0.3.2.ebuild
deleted file mode 100644
index c988a8ed22..0000000000
--- a/gnome-extra/extension-manager/extension-manager-0.3.2.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# Note: This is the last version in which the upstream had not introduced
-# dependency on sys-libs/libbacktrace, which has been last-rited in ::gentoo.
-#
-# ebuilds for newer upstream versions have to use an experimental patch that
-# makes the libbacktrace dependency optional; please keep this version for
-# reasonable time until the patch has been proven stable.
-
-EAPI=8
-
-inherit gnome2-utils meson xdg
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/mjakeman/extension-manager.git"
-else
- SRC_URI="https://github.com/mjakeman/extension-manager/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-DESCRIPTION="A native tool for browsing, installing, and managing GNOME Shell Extensions"
-HOMEPAGE="https://mattjakeman.com/apps/extension-manager"
-
-LICENSE="GPL-3+"
-SLOT="0"
-
-BDEPEND="
- dev-libs/glib:2
- dev-util/blueprint-compiler
- sys-devel/gettext
- virtual/pkgconfig
-"
-
-RDEPEND="
- dev-libs/glib:2
- dev-libs/json-glib
- gui-libs/gtk:4[introspection]
- gui-libs/libadwaita:1[introspection]
- gui-libs/text-engine
- net-libs/libsoup:3.0
-"
-
-DEPEND="
- ${RDEPEND}
-"
-
-src_configure() {
- local emesonargs=()
- if has live ${PROPERTIES}; then
- # Produce a development build for live ebuild
- emesonargs+=( -Ddevelopment=true )
- fi
- meson_src_configure
-}
-
-# Tests are skipped because as of version 0.3.0, the tests only validate
-# resource files and do not verify any functionality of the program. Those
-# validations are either already handled by QA checks or not relevant on
-# Gentoo. For more information about the rationale, please refer to:
-# https://github.com/gentoo/guru/commit/f896bee213fbb62c70e818c1bf503fee2a41919a#comments
-#
-# If tests are to be executed in the future because the upstream adds
-# functionality tests or for other reasons, and should there be no convenient
-# way to skip the validations, the following variable values need to be set:
-#
-# IUSE="test"
-# RESTRICT="!test? ( test )"
-# BDEPEND="test? ( dev-libs/appstream-glib dev-util/desktop-file-utils )"
-src_test() {
- :
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
- gnome2_schemas_update
-}
-
-pkg_postrm() {
- xdg_pkg_postrm
- gnome2_schemas_update
-}