aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTakuya Wakazono <pastalian46@gmail.com>2024-01-12 22:31:46 +0900
committerTakuya Wakazono <pastalian46@gmail.com>2024-01-12 22:38:02 +0900
commit39214c4d331d8c9983aa1697d617d9242d2476c0 (patch)
treeaa65c4dea14ad670fe945747bbfd8b27c84a9281 /gui-apps/coreaction
parentgui-libs/libcprime: add 4.5.0, sync live (diff)
downloadguru-39214c4d331d8c9983aa1697d617d9242d2476c0.tar.gz
guru-39214c4d331d8c9983aa1697d617d9242d2476c0.tar.bz2
guru-39214c4d331d8c9983aa1697d617d9242d2476c0.zip
gui-apps/coreaction: add 4.5.0, sync live
Closes: https://bugs.gentoo.org/921919 Signed-off-by: Takuya Wakazono <pastalian46@gmail.com>
Diffstat (limited to 'gui-apps/coreaction')
-rw-r--r--gui-apps/coreaction/Manifest1
-rw-r--r--gui-apps/coreaction/coreaction-4.5.0.ebuild32
-rw-r--r--gui-apps/coreaction/coreaction-9999.ebuild23
3 files changed, 44 insertions, 12 deletions
diff --git a/gui-apps/coreaction/Manifest b/gui-apps/coreaction/Manifest
index 9c926c355..d09c5d5a4 100644
--- a/gui-apps/coreaction/Manifest
+++ b/gui-apps/coreaction/Manifest
@@ -1 +1,2 @@
DIST coreaction-4.2.0.tar.gz 783597 BLAKE2B 499f94062512a92a728d0a3cc0cf2a07050bb6b20f4957e4a1bae73697f876ca2a5d11304b55e6b62882f8541ddfdb8fd693ed6d8f46affa95c67c3bad915c50 SHA512 006ffd4791084b56fa87ce3630ab84018915f2c986b5b4a50ec7a8e42cb52bca22eb42e5952b22bde67b80b1494c4459598cc544e3fb415d3cd5f22e6056a7a6
+DIST coreaction-v4.5.0.tar.bz2 792795 BLAKE2B 17d21c3b1dd4b80fb84c70efaadc9b9bbde0d36edd39b4f60db07d06233b192a430dae761a79ab2b9002e2181fb28ba14d6fbfb183ab8fe0afe1247bfd6db7bf SHA512 94de8182af9500f66eeb28f929833d4948a46be2a4f32b3dfe0ecbe311f150c16cb10b2f1650489ab8d316cb47b7dff96ddc986c67f40832172aef62b4547b33
diff --git a/gui-apps/coreaction/coreaction-4.5.0.ebuild b/gui-apps/coreaction/coreaction-4.5.0.ebuild
new file mode 100644
index 000000000..d4675d7b7
--- /dev/null
+++ b/gui-apps/coreaction/coreaction-4.5.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg cmake
+
+DESCRIPTION="A side bar for showing widgets for C Suite"
+HOMEPAGE="https://gitlab.com/cubocore/coreapps/coreaction"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/cubocore/coreapps/coreaction.git"
+else
+ SRC_URI="https://gitlab.com/cubocore/coreapps/coreaction/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-v${PV}"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ gui-libs/libcprime
+ gui-libs/libcsys
+"
+RDEPEND="${DEPEND}"
diff --git a/gui-apps/coreaction/coreaction-9999.ebuild b/gui-apps/coreaction/coreaction-9999.ebuild
index 3620e3c6c..d4675d7b7 100644
--- a/gui-apps/coreaction/coreaction-9999.ebuild
+++ b/gui-apps/coreaction/coreaction-9999.ebuild
@@ -1,9 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
-MY_PV="${PV/_/-}"
+EAPI=8
inherit xdg cmake
@@ -12,22 +10,23 @@ HOMEPAGE="https://gitlab.com/cubocore/coreapps/coreaction"
if [[ "${PV}" == *9999* ]]; then
inherit git-r3
- EGIT_REPO_URI="https://gitlab.com/cubocore/coreapps/${PN}.git"
+ EGIT_REPO_URI="https://gitlab.com/cubocore/coreapps/coreaction.git"
else
- SRC_URI="https://gitlab.com/cubocore/coreapps/${PN}/-/archive/v${MY_PV}/${PN}-v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://gitlab.com/cubocore/coreapps/coreaction/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
KEYWORDS="~amd64"
- S="${WORKDIR}/${PN}-v${MY_PV}"
+ S="${WORKDIR}/${PN}-v${PV}"
fi
-RESTRICT="test"
LICENSE="GPL-3"
SLOT="0"
DEPEND="
- dev-qt/qtsvg
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
gui-libs/libcprime
gui-libs/libcsys
"
-RDEPEND="
- ${DEPEND}
-"
+RDEPEND="${DEPEND}"