aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2024-08-06 11:21:51 +0200
committerDavid Roman <davidroman96@gmail.com>2024-08-06 11:22:10 +0200
commit6dcb5ea273d5aafe7f5486c036a1f689574dc470 (patch)
tree38b1f4d4b92e8b77541eeeec805333460626b021 /media-sound
parentdev-util/shellspec: revbump (diff)
downloadguru-6dcb5ea273d5aafe7f5486c036a1f689574dc470.tar.gz
guru-6dcb5ea273d5aafe7f5486c036a1f689574dc470.tar.bz2
guru-6dcb5ea273d5aafe7f5486c036a1f689574dc470.zip
media-sound/TauonMusicBox: add missing RDEPEND
Closes: https://bugs.gentoo.org/937441 Signed-off-by: David Roman <davidroman96@gmail.com>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/TauonMusicBox/TauonMusicBox-7.8.0-r1.ebuild127
1 files changed, 127 insertions, 0 deletions
diff --git a/media-sound/TauonMusicBox/TauonMusicBox-7.8.0-r1.ebuild b/media-sound/TauonMusicBox/TauonMusicBox-7.8.0-r1.ebuild
new file mode 100644
index 000000000..03bb63d6c
--- /dev/null
+++ b/media-sound/TauonMusicBox/TauonMusicBox-7.8.0-r1.ebuild
@@ -0,0 +1,127 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PLOCALES="cs de es fr_FR hu id it ja_JP nb_NO pl pt pt_BR pt_PT ru sv tr zh_CN"
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit cmake desktop distutils-r1 optfeature plocale xdg
+
+DESCRIPTION="The desktop music player of today!"
+HOMEPAGE="https://tauonmusicbox.rocks/"
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_SUBMODULES=()
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Taiko2k/${PN}"
+else
+ SRC_URI="https://github.com/Taiko2k/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+S="${WORKDIR}/Tauon-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+PHAZOR_DEPS="
+ dev-libs/miniaudio
+ media-libs/flac
+ media-libs/game-music-emu
+ media-libs/libopenmpt
+ media-libs/opus
+ media-libs/opusfile
+ media-libs/libsamplerate
+ media-libs/libvorbis
+ media-sound/mpg123
+ media-sound/wavpack
+ sci-libs/kissfft[-cpu_flags_x86_sse]
+"
+
+DEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/musicbrainzngs[${PYTHON_USEDEP}]
+ dev-python/natsort[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/PySDL2[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ dev-python/send2trash[${PYTHON_USEDEP}]
+ dev-python/unidecode[${PYTHON_USEDEP}]
+ media-video/ffmpeg
+ media-libs/mutagen[${PYTHON_USEDEP}]
+ media-libs/sdl2-image
+
+ ${PHAZOR_DEPS}
+"
+
+RDEPEND="
+ ${DEPEND}
+
+ dev-libs/libappindicator
+ media-sound/mpg123-base
+ x11-libs/libnotify
+"
+
+BDEPEND="sys-devel/gettext"
+
+src_prepare() {
+ # Workaround. If PATCHES is used it would be applied to times and fail
+ eapply "${FILESDIR}/${P}-phazor-fix.patch"
+ eapply "${FILESDIR}/${P}-unidecode-compat.patch"
+
+ distutils-r1_src_prepare
+ cmake_src_prepare
+}
+
+src_configure() {
+ distutils-r1_src_configure
+ cmake_src_configure
+}
+
+src_compile() {
+ distutils-r1_src_compile
+ cmake_src_compile
+
+ build_locale() {
+ msgfmt -o "locale/${1}/LC_MESSAGES/tauon.mo" "locale/${1}/LC_MESSAGES/tauon.po" || die
+ }
+
+ plocale_for_each_locale build_locale
+}
+
+src_test() {
+ distutils-r1_src_test
+ cmake_src_test
+}
+
+python_install() {
+ newbin tauon.py tauon
+ dolib.so "${WORKDIR}/Tauon-${PV}_build/libphazor.so"
+
+ install_locale() {
+ insinto "/usr/share/locale/${1}/LC_MESSAGES"
+ doins "locale/${1}/LC_MESSAGES/tauon.mo"
+ }
+
+ plocale_for_each_locale install_locale
+
+ insinto "/usr/share/${PN}"
+ doins -r assets theme templates
+ doins input.txt
+
+ sed -i 's/\/opt\/tauon-music-box\/tauonmb.sh/tauon/g' extra/tauonmb.desktop || die
+ domenu extra/tauonmb.desktop
+ doicon -s scalable extra/tauonmb.svg
+
+ distutils-r1_python_install
+}
+
+pkg_postinst() {
+ optfeature "last fm support" dev-python/pylast
+ optfeature "PLEX support" dev-python/plexapi
+
+ xdg_pkg_postinst
+}