aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2021-10-29 22:09:39 +0300
committerSergey Torokhov <torokhov-s-a@yandex.ru>2021-10-29 22:14:04 +0300
commit0415d65fa2cff41caef38402f6f09c00678aac28 (patch)
tree0e115401ef15f6c1d69262bb95965a53e8c096c0 /x11-libs
parentapp-admin/customrescuecd-x86_64: version bump to 0.12.3 (diff)
downloadguru-0415d65fa2cff41caef38402f6f09c00678aac28.tar.gz
guru-0415d65fa2cff41caef38402f6f09c00678aac28.tar.bz2
guru-0415d65fa2cff41caef38402f6f09c00678aac28.zip
x11-libs/gtk-fortran: pass LDFLAGS
Closes: https://bugs.gentoo.org/820494 Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gtk-fortran/gtk-fortran-3.24.18.ebuild5
-rw-r--r--x11-libs/gtk-fortran/gtk-fortran-3.24.30.ebuild5
-rw-r--r--x11-libs/gtk-fortran/gtk-fortran-4.1.0.ebuild5
3 files changed, 9 insertions, 6 deletions
diff --git a/x11-libs/gtk-fortran/gtk-fortran-3.24.18.ebuild b/x11-libs/gtk-fortran/gtk-fortran-3.24.18.ebuild
index e0c095bfbe..b83521beb9 100644
--- a/x11-libs/gtk-fortran/gtk-fortran-3.24.18.ebuild
+++ b/x11-libs/gtk-fortran/gtk-fortran-3.24.18.ebuild
@@ -39,9 +39,10 @@ pkg_setup() {
src_prepare() {
default
- # Fix library installation path and disable 'sketcher' build
+ # Fix library installation path, disable 'sketcher' build, pass LDFLAGS
sed -i -e "s:CMAKE_INSTALL_LIBDIR lib:CMAKE_INSTALL_LIBDIR $(get_libdir):" \
- -e "s: add_subdirectory(sketcher)::" CMakeLists.txt || die
+ -e "s: add_subdirectory(sketcher)::" \
+ -e 's:"-rdynamic":"-rdynamic '"${LDFLAGS}"'":' CMakeLists.txt || die
use !static-libs && eapply "${FILESDIR}/${P}_skip-static-build.patch"
diff --git a/x11-libs/gtk-fortran/gtk-fortran-3.24.30.ebuild b/x11-libs/gtk-fortran/gtk-fortran-3.24.30.ebuild
index 243d4c8fbb..f3ead55478 100644
--- a/x11-libs/gtk-fortran/gtk-fortran-3.24.30.ebuild
+++ b/x11-libs/gtk-fortran/gtk-fortran-3.24.30.ebuild
@@ -37,9 +37,10 @@ pkg_setup() {
src_prepare() {
default
- # Fix library installation path and disable 'sketcher' build
+ # Fix library installation path, disable 'sketcher' build, pass LDFLAGS
sed -i -e "s:CMAKE_INSTALL_LIBDIR lib:CMAKE_INSTALL_LIBDIR $(get_libdir):" \
- -e "s: add_subdirectory(sketcher)::" CMakeLists.txt || die
+ -e "s: add_subdirectory(sketcher)::" \
+ -e 's:"-rdynamic":"-rdynamic '"${LDFLAGS}"'":' CMakeLists.txt || die
cmake_src_prepare
}
diff --git a/x11-libs/gtk-fortran/gtk-fortran-4.1.0.ebuild b/x11-libs/gtk-fortran/gtk-fortran-4.1.0.ebuild
index b95e916966..3de8bf8320 100644
--- a/x11-libs/gtk-fortran/gtk-fortran-4.1.0.ebuild
+++ b/x11-libs/gtk-fortran/gtk-fortran-4.1.0.ebuild
@@ -37,9 +37,10 @@ pkg_setup() {
src_prepare() {
default
- # Fix library installation path and disable 'sketcher' build
+ # Fix library installation path, disable 'sketcher' build, pass LDFLAGS
sed -i -e "s:CMAKE_INSTALL_LIBDIR lib:CMAKE_INSTALL_LIBDIR $(get_libdir):" \
- -e "s: add_subdirectory(sketcher)::" CMakeLists.txt || die
+ -e "s: add_subdirectory(sketcher)::" \
+ -e 's:"-rdynamic":"-rdynamic '"${LDFLAGS}"'":' CMakeLists.txt || die
cmake_src_prepare
}