aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/junction/junction-1.6-r1.ebuild')
-rw-r--r--gnome-extra/junction/junction-1.6-r1.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnome-extra/junction/junction-1.6-r1.ebuild b/gnome-extra/junction/junction-1.6-r1.ebuild
index d7d8303e6..359c485fb 100644
--- a/gnome-extra/junction/junction-1.6-r1.ebuild
+++ b/gnome-extra/junction/junction-1.6-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit meson
+inherit xdg gnome2-utils meson
TROLL_COMMIT="8d7c2be66a4bf1cbb2081121997a33662fc19cd0"
DESCRIPTION="Application/browser chooser"
@@ -56,3 +56,15 @@ src_configure() {
src_test() {
:
}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ gnome2_schemas_update
+}