aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2023-05-06 11:34:15 -0700
committerorbea <orbea@riseup.net>2023-05-06 11:34:15 -0700
commitacdca69285809b17bc28ef39d42bc777967f80c5 (patch)
tree3be2272e54e8191b2079af9696d04b1e093e68f0 /dev-perl
parentdev-lang/python: sync ::gentoo (diff)
downloadlibressl-acdca69285809b17bc28ef39d42bc777967f80c5.tar.gz
libressl-acdca69285809b17bc28ef39d42bc777967f80c5.tar.bz2
libressl-acdca69285809b17bc28ef39d42bc777967f80c5.zip
dev-perl/Net-SSLeay: use the ::gentoo patch
Signed-off-by: orbea <orbea@riseup.net>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Net-SSLeay/Net-SSLeay-1.920.0.ebuild2
-rw-r--r--dev-perl/Net-SSLeay/files/Net-SSLeay-1.92-libressl.patch (renamed from dev-perl/Net-SSLeay/files/Net-SSLeay-1.920.0-libressl.patch)62
2 files changed, 53 insertions, 11 deletions
diff --git a/dev-perl/Net-SSLeay/Net-SSLeay-1.920.0.ebuild b/dev-perl/Net-SSLeay/Net-SSLeay-1.920.0.ebuild
index ee07373..fed81d3 100644
--- a/dev-perl/Net-SSLeay/Net-SSLeay-1.920.0.ebuild
+++ b/dev-perl/Net-SSLeay/Net-SSLeay-1.920.0.ebuild
@@ -35,7 +35,7 @@ BDEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}/${PN}-1.88-fix-network-tests.patch"
- "${FILESDIR}/${PN}-1.920.0-libressl.patch"
+ "${FILESDIR}/${PN}-1.92-libressl.patch"
)
PERL_RM_FILES=(
diff --git a/dev-perl/Net-SSLeay/files/Net-SSLeay-1.920.0-libressl.patch b/dev-perl/Net-SSLeay/files/Net-SSLeay-1.92-libressl.patch
index eb1c331..380fd15 100644
--- a/dev-perl/Net-SSLeay/files/Net-SSLeay-1.920.0-libressl.patch
+++ b/dev-perl/Net-SSLeay/files/Net-SSLeay-1.92-libressl.patch
@@ -1,13 +1,56 @@
-https://cvsweb.openbsd.org/cgi-bin/cvsweb/ports/security/p5-Net-SSLeay/patches/patch-SSLeay_xs
-
-https://github.com/radiator-software/p5-net-ssleay/commit/3dd2f101b8e15a59f66e22525b8d001d5ad6ce7d
+https://bugs.gentoo.org/903001
+https://github.com/radiator-software/p5-net-ssleay/pull/360
https://github.com/radiator-software/p5-net-ssleay/commit/4a886e06c1cac80e7fb3f8d52146a27ce557ba8c
+https://github.com/radiator-software/p5-net-ssleay/pull/362
https://github.com/radiator-software/p5-net-ssleay/commit/88c3bbc45399c8ef2c8879aada8bfa91d8bc6c10
+https://github.com/radiator-software/p5-net-ssleay/pull/363
+https://github.com/radiator-software/p5-net-ssleay/commit/3dd2f101b8e15a59f66e22525b8d001d5ad6ce7d
+
+From 4a886e06c1cac80e7fb3f8d52146a27ce557ba8c Mon Sep 17 00:00:00 2001
+From: Alexander Bluhm <alexander.bluhm@gmx.net>
+Date: Wed, 19 Jan 2022 14:56:22 +0100
+Subject: [PATCH] Use X509_get0_tbs_sigalg() for LibreSSL. (#360)
+
+* Use X509_get0_tbs_sigalg() for LibreSSL.
+
+LibreSSL 3.5.0 has removed access to internal data structures. Use
+X509_get0_tbs_sigalg() like in OpenSSL 1.1.
+
+* Start Changes for the next release.
+
+Co-authored-by: Heikki Vatiainen <hvn@radiatorsoftware.com>
+---
+ Changes | 5 +++++
+ SSLeay.xs | 2 +-
+ 2 files changed, 6 insertions(+), 1 deletion(-)
-Index: SSLeay.xs
---- a/SSLeay.xs.orig
+From 88c3bbc45399c8ef2c8879aada8bfa91d8bc6c10 Mon Sep 17 00:00:00 2001
+From: Alexander Bluhm <alexander.bluhm@gmx.net>
+Date: Wed, 19 Jan 2022 20:38:57 +0100
+Subject: [PATCH] Use OCSP_SINGLERESP_get0_id() for LibreSSL. (#362)
+
+LibreSSL 3.5.0 has removed access to internal ocsp data structures.
+Use OCSP_SINGLERESP_get0_id() like in OpenSSL 1.1.
+---
+ SSLeay.xs | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+From 3dd2f101b8e15a59f66e22525b8d001d5ad6ce7d Mon Sep 17 00:00:00 2001
+From: Alexander Bluhm <alexander.bluhm@gmx.net>
+Date: Thu, 20 Jan 2022 19:15:27 +0100
+Subject: [PATCH] Implement RSA_get_key_parameters() for newer LibreSSL. (#363)
+
+LibreSSL 3.5.0 has removed access to internal rsa data structures.
+Use RSA_get0... functions to provide RSA_get_key_parameters().
+---
+ SSLeay.xs | 25 +++++++++++++++++++++++--
+ 1 file changed, 23 insertions(+), 2 deletions(-)
+
+diff --git a/SSLeay.xs b/SSLeay.xs
+index b0667e2..58f1716 100644
+--- a/SSLeay.xs
+++ b/SSLeay.xs
-@@ -1914,7 +1914,7 @@ X509 * find_issuer(X509 *cert,X509_STORE *store, STACK
+@@ -1914,7 +1914,7 @@ X509 * find_issuer(X509 *cert,X509_STORE *store, STACK_OF(X509) *chain) {
return issuer;
}
@@ -16,7 +59,7 @@ Index: SSLeay.xs
{
return p_bn != NULL
? sv_2mortal(newSViv((IV) BN_dup(p_bn)))
-@@ -6283,9 +6283,29 @@ RSA_generate_key(bits,e,perl_cb=&PL_sv_undef,perl_data
+@@ -6283,8 +6283,28 @@ RSA_generate_key(bits,e,perl_cb=&PL_sv_undef,perl_data=&PL_sv_undef)
void
RSA_get_key_parameters(rsa)
RSA * rsa
@@ -32,7 +75,7 @@ Index: SSLeay.xs
+ RSA_get0_key(rsa, &n, &e, &d);
+ RSA_get0_factors(rsa, &p, &q);
+ RSA_get0_crt_params(rsa, &dmp1, &dmq1, &iqmp);
- /* Caution: returned list consists of SV pointers to BIGNUMs, which would need to be blessed as Crypt::OpenSSL::Bignum for further use */
++ /* Caution: returned list consists of SV pointers to BIGNUMs, which would need to be blessed as Crypt::OpenSSL::Bignum for further use */
+ XPUSHs(bn2sv(n));
+ XPUSHs(bn2sv(e));
+ XPUSHs(bn2sv(d));
@@ -42,10 +85,9 @@ Index: SSLeay.xs
+ XPUSHs(bn2sv(dmq1));
+ XPUSHs(bn2sv(iqmp));
+#else
-+ /* Caution: returned list consists of SV pointers to BIGNUMs, which would need to be blessed as Crypt::OpenSSL::Bignum for further use */
+ /* Caution: returned list consists of SV pointers to BIGNUMs, which would need to be blessed as Crypt::OpenSSL::Bignum for further use */
XPUSHs(bn2sv(rsa->n));
XPUSHs(bn2sv(rsa->e));
- XPUSHs(bn2sv(rsa->d));
@@ -6294,9 +6314,10 @@ PPCODE:
XPUSHs(bn2sv(rsa->dmp1));
XPUSHs(bn2sv(rsa->dmq1));