summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans Fredrik Nordhaug <hansfn@gmail.com>2022-06-10 14:52:11 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-14 19:26:09 +0300
commit2f01a1c640b30c87b08d53ced03556313a21a1ce (patch)
tree7a9c1d1dc0aa81890a3951630693dd9fea88e8b8
parentsys-kernel/gentoo-sources: add 4.19.247 (diff)
downloadgentoo-2f01a1c640b30c87b08d53ced03556313a21a1ce.tar.gz
gentoo-2f01a1c640b30c87b08d53ced03556313a21a1ce.tar.bz2
gentoo-2f01a1c640b30c87b08d53ced03556313a21a1ce.zip
app-editors/featherpad: add 1.2.0
Signed-off-by: Hans Fredrik Nordhaug <hansfn@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/25846 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--app-editors/featherpad/Manifest1
-rw-r--r--app-editors/featherpad/featherpad-1.2.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-editors/featherpad/Manifest b/app-editors/featherpad/Manifest
index 854a2b25463c..a7937f86cb79 100644
--- a/app-editors/featherpad/Manifest
+++ b/app-editors/featherpad/Manifest
@@ -1,3 +1,4 @@
DIST featherpad-1.0.0.tar.gz 1010200 BLAKE2B 22a11a0655ed57f7a7d53949e59c3b989a304b7c3db1f7308af0a52cc00a151cee505b02c19ece286da1be37e76c8874cee4102db3d881ef2c4ad48ecbb2f20a SHA512 9f7e24fa5e89e269693bc0a37f79d987e4914dde2d2b46bd0385886383dab8b35556fbc0f5c5b7b9a2c3a41694174ffa8532c48def87d2972fbc73c1e9c38bf3
DIST featherpad-1.0.1.tar.gz 1014744 BLAKE2B 1525b0894e47facdc51da0c6417d69b12d630bb0e6e8d7b3916b0c4e82380243b1b4dd0ddf82f7954d83edcd7b30346cff0305d98296b4aeccc1fe3cab325cd7 SHA512 8d1a07f8f32f63ec77e6bff8a39badd1eef87b0675096f964ff2fa770dda7c79ec9a1f788cbfa77528163aeb6c6067ca74e009293eca2e718dce92a48aef5f98
DIST featherpad-1.1.0.tar.gz 1061070 BLAKE2B 78c7ddf0b7961a300fe2e425876bfaf32a1186eb88c2619202cb2f07a780aed3c2f8d1ced0e963b1868c94e890d1d809baae534fe1f3d06b3f3036aeeccf7414 SHA512 c734619ea8eda2709ccfa4d1b3c2ac541f32d52f31f0896ddf3c1c5733f175da9d955458a62a34221400a73003970cf796f59cf574b499831267b6f4d1a28d21
+DIST featherpad-1.2.0.tar.gz 1091776 BLAKE2B f63ddcc8bf02b3f9ad5f6ad2b56b8f99cc8566f70351a293fbe339930b41542e9ba27888afabfcf98a04ec6a1087dd77aa35006ea33526e1a7d6c45f5fe3b7d9 SHA512 cf21ed9394444920fcf3a8ce3a8338814d69322389c4652e79f0754fe67ee61260f81604c91adf0a864fb1441307706c60ee1bd29efd2e617ab8e1f5fc254cdd
diff --git a/app-editors/featherpad/featherpad-1.2.0.ebuild b/app-editors/featherpad/featherpad-1.2.0.ebuild
new file mode 100644
index 000000000000..e82070d4a429
--- /dev/null
+++ b/app-editors/featherpad/featherpad-1.2.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg cmake
+
+DESCRIPTION="Lightweight Qt5 Plain-Text Editor for Linux"
+HOMEPAGE="https://github.com/tsujan/FeatherPad"
+SRC_URI="https://github.com/tsujan/FeatherPad/archive/V${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/FeatherPad-${PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="+X"
+
+RDEPEND="app-text/hunspell:=
+ >=dev-qt/qtcore-5.15.0
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ X? (
+ dev-qt/qtx11extras:5
+ x11-libs/libX11
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-qt/linguist-tools:5"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITHOUT_X11=$(usex !X)
+ )
+ cmake_src_configure
+}