summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-05-25 15:33:38 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-05-25 16:05:57 +0200
commit459401a2115ebf4c7429196c3c5e4fef67c0b1ef (patch)
treef7b44163ff8eab0dd2094e735f64d1b6eab6d77b
parentsci-electronics/nvc: bump to 1.12.2 (diff)
downloadgentoo-459401a2115ebf4c7429196c3c5e4fef67c0b1ef.tar.gz
gentoo-459401a2115ebf4c7429196c3c5e4fef67c0b1ef.tar.bz2
gentoo-459401a2115ebf4c7429196c3c5e4fef67c0b1ef.zip
app-misc/golly: bump to 4.3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-misc/golly/Manifest1
-rw-r--r--app-misc/golly/golly-4.3.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/app-misc/golly/Manifest b/app-misc/golly/Manifest
index 459f6dca7ea7..062bb1ad78b3 100644
--- a/app-misc/golly/Manifest
+++ b/app-misc/golly/Manifest
@@ -1 +1,2 @@
DIST golly-4.2-src.tar.gz 15348982 BLAKE2B 21ebed4c282a77a3f61aafa98936c0bb39b39a7c97505e96fc43ac720bd2eea4cf20996ca28c801f79a46577a0cf99ff60614ce134081605d14ca5972c841d50 SHA512 b9f5cfdfe9b96590411695805dd8b875329c81027fef98dff3f16b832018be2ad3a06583bb64e12fb305268feba2347ef63c4586ff0e645721a8085f04ab382a
+DIST golly-4.3-src.tar.gz 15488205 BLAKE2B 0789bc3e50f43083633f699c5e4ff20fd314cfa776d22463dce3169095e57daeadda4d9671f1b566d6786771caf029f98e4593b250cf29a73abff0c200e2f32b SHA512 daf3a0ef8b7d3f97df2c3a05a245c93eb124ebab4e7a7c0d267e22b4b7271a11cecced20b53fa88dfde145ce11450aac98e0e774f8b6419b3084952938e5a854
diff --git a/app-misc/golly/golly-4.3.ebuild b/app-misc/golly/golly-4.3.ebuild
new file mode 100644
index 000000000000..24219cbdfaf1
--- /dev/null
+++ b/app-misc/golly/golly-4.3.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER=3.2-gtk3
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit desktop python-single-r1 toolchain-funcs wxwidgets xdg
+
+DESCRIPTION="simulator for Conway's Game of Life and other cellular automata"
+HOMEPAGE="http://golly.sourceforge.net/
+ https://sourceforge.net/projects/golly/"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${P}-src.tar.gz"
+S="${WORKDIR}/${P}-src"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ sys-libs/zlib
+ virtual/opengl
+ x11-libs/wxGTK:${WX_GTK_VER}[X,curl,opengl,sdl,tiff]
+ ${PYTHON_DEPS}
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+PATCHES=( "${FILESDIR}/${PN}-4.0-CFLAGS.patch" )
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ setup-wxwidgets
+}
+
+src_compile() {
+ local -a mymakeopts=(
+ ENABLE_SOUND=yes
+ GOLLYDIR="${EPREFIX}/usr/share/${PN}"
+ PYTHON=${EPYTHON}
+ WX_CONFIG=${WX_CONFIG}
+ AR="$(tc-getAR)"
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ CXXC="$(tc-getCXX)"
+ RANLIB="$(tc-getRANLIB)"
+ )
+ emake -C gui-wx -f makefile-gtk "${mymakeopts[@]}"
+}
+
+src_install() {
+ # Has no 'make install', let's install files manually.
+ exeinto /usr/bin
+ doexe golly bgolly
+
+ insinto "/usr/share/${PN}"
+ doins -r Help Patterns Scripts Rules docs
+
+ newicon --size 32 gui-wx/icons/appicon.xpm "${PN}.xpm"
+ make_desktop_entry "${PN}" "Golly" "${PN}" "Science"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}