summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-12 12:29:31 +0100
committerSam James <sam@gentoo.org>2022-06-12 12:30:17 +0100
commit86bafbfc91e43cddef7bf3d4a1a82e6da6a5b61e (patch)
treef58c12223d214b424de5d164ba52d25be24b4a02
parentsci-libs/gloo: add to tree (diff)
downloadgentoo-86bafbfc91e43cddef7bf3d4a1a82e6da6a5b61e.tar.gz
gentoo-86bafbfc91e43cddef7bf3d4a1a82e6da6a5b61e.tar.bz2
gentoo-86bafbfc91e43cddef7bf3d4a1a82e6da6a5b61e.zip
sys-apps/pcsc-lite: add 1.9.8
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/pcsc-lite/Manifest1
-rw-r--r--sys-apps/pcsc-lite/pcsc-lite-1.9.8.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/sys-apps/pcsc-lite/Manifest b/sys-apps/pcsc-lite/Manifest
index f04c8fba3b43..09496ea11f1e 100644
--- a/sys-apps/pcsc-lite/Manifest
+++ b/sys-apps/pcsc-lite/Manifest
@@ -1 +1,2 @@
DIST pcsc-lite-1.9.7.tar.bz2 784685 BLAKE2B 74848b06ce9e497287cc4a8f307a194d766091a35af46300bd1dcdbf730c3f86f14928ff2e576ac83c07a37234b866e0b2cb3afd3d963b8570051c5c4880f4b9 SHA512 0c7f6c0efcfd6f6996e9e751dd0dd9969590b19144099aa6003c089d95d5ffdfddf3a50b82ece31e0f22e8213317dd827e5fbb4cdde614818b81a80c434788dd
+DIST pcsc-lite-1.9.8.tar.bz2 787198 BLAKE2B ba7297e567e5ad7fdb8041d6cddd61e772795d725d91be7f041493a2404a42acf51b41a4e0e82765f4d2a93517d8d9345abd7520dc03eeb48d2eb83bb6082390 SHA512 6275eee849c5572264f5a1ef1ea2a2db5fec9c4129b348bd6e2c1d4444c46c945b8ecab682c003913e9d06da7034b383199b6e392ae178ffae296017e7c61812
diff --git a/sys-apps/pcsc-lite/pcsc-lite-1.9.8.ebuild b/sys-apps/pcsc-lite/pcsc-lite-1.9.8.ebuild
new file mode 100644
index 000000000000..d5a422386bb8
--- /dev/null
+++ b/sys-apps/pcsc-lite/pcsc-lite-1.9.8.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit python-single-r1 systemd udev multilib-minimal
+
+DESCRIPTION="PC/SC Architecture smartcard middleware library"
+HOMEPAGE="https://pcsclite.apdu.fr https://github.com/LudovicRousseau/PCSC"
+
+SRC_URI="https://pcsclite.apdu.fr/files/${P}.tar.bz2"
+
+# GPL-2 is there for the init script; everything else comes from
+# upstream.
+LICENSE="BSD ISC MIT GPL-3+ GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+# This is called libusb so that it doesn't fool people in thinking that
+# it is _required_ for USB support. Otherwise they'll disable udev and
+# that's going to be worse.
+IUSE="doc embedded libusb policykit selinux systemd +udev"
+
+REQUIRED_USE="^^ ( udev libusb ) ${PYTHON_REQUIRED_USE}"
+
+# No dependencies need the MULTILIB_DEPS because the libraries are actually
+# standalone, the deps are only needed for the daemon itself.
+DEPEND="libusb? ( virtual/libusb:1 )
+ udev? ( virtual/libudev:= )
+ policykit? ( >=sys-auth/polkit-0.111 )
+ acct-group/openct
+ acct-group/pcscd
+ acct-user/pcscd
+ ${PYTHON_DEPS}"
+
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-pcscd )"
+
+BDEPEND="sys-devel/flex
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.8.11-polkit-pcscd.patch
+)
+
+DOCS=( AUTHORS HELP README SECURITY ChangeLog )
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-maintainer-mode \
+ --disable-strict \
+ --enable-usbdropdir="${EPREFIX}/usr/$(get_libdir)/readers/usb" \
+ --enable-ipcdir=/run/pcscd \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
+ $(use_enable doc documentation) \
+ $(multilib_native_use_enable embedded) \
+ $(multilib_native_use_enable systemd libsystemd) \
+ $(multilib_native_use_enable udev libudev) \
+ $(multilib_native_use_enable libusb) \
+ $(multilib_native_use_enable policykit polkit)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ newinitd "${FILESDIR}"/pcscd-init.7 pcscd
+
+ if use udev; then
+ exeinto "$(get_udevdir)"
+ newexe "${FILESDIR}"/pcscd-udev pcscd.sh
+
+ insinto "$(get_udevdir)"/rules.d
+ newins "${FILESDIR}"/99-pcscd-hotplug-r1.rules 99-pcscd-hotplug.rules
+ fi
+
+ python_fix_shebang "${ED}"/usr/bin/pcsc-spy
+
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog "Starting from version 1.6.5, pcsc-lite will start as user nobody in"
+ elog "the pcscd group, to avoid running as root."
+ elog ""
+ elog "This also means you need the newest drivers available so that the"
+ elog "devices get the proper owner."
+ elog ""
+ elog "Furthermore, a conf.d file is no longer installed by default, as"
+ elog "the default configuration does not require one. If you need to"
+ elog "pass further options to pcscd, create a file and set the"
+ elog "EXTRA_OPTS variable."
+ elog ""
+ if use udev; then
+ elog "Hotplug support is provided by udev rules."
+ elog "When using OpenRC you additionally need to tell it to hotplug"
+ elog "pcscd by setting this variable in /etc/rc.conf:"
+ elog ""
+ elog " rc_hotplug=\"pcscd\""
+ fi
+}