summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-15 11:37:00 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-15 12:51:03 +0200
commit894e52d4ca562ff8fce8100954b6f4ee2c5d787c (patch)
treeeef865b1e691ebab2048cd47a31bb9a69e5aa523
parentgames-emulation/mupen64plus-core: Bump to 2.6.0 (diff)
downloadgentoo-894e52d4ca562ff8fce8100954b6f4ee2c5d787c.tar.gz
gentoo-894e52d4ca562ff8fce8100954b6f4ee2c5d787c.tar.bz2
gentoo-894e52d4ca562ff8fce8100954b6f4ee2c5d787c.zip
games-emulation/mupen64plus-audio-sdl: Bump to 2.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--games-emulation/mupen64plus-audio-sdl/Manifest1
-rw-r--r--games-emulation/mupen64plus-audio-sdl/mupen64plus-audio-sdl-2.6.0.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/games-emulation/mupen64plus-audio-sdl/Manifest b/games-emulation/mupen64plus-audio-sdl/Manifest
index 2ff374efa5f7..708188100e27 100644
--- a/games-emulation/mupen64plus-audio-sdl/Manifest
+++ b/games-emulation/mupen64plus-audio-sdl/Manifest
@@ -1 +1,2 @@
DIST mupen64plus-audio-sdl-src-2.5.9.tar.gz 28884 BLAKE2B a32aeff100e86f610e3b514718c6a4a786c6f88911f8782dcbc9b8a2d238c31984e5d119e31533363d8f848bf840ff7350ba41dea70e716d50cce14f2398c836 SHA512 624f7061b4909a5de071fbb8cf6432fd4b6ad390ea3f7dc7ae7a874dc922afee55352e53d48fba43d45a3282e9382e6b5774814c2a7d9724e134a01188596ea9
+DIST mupen64plus-audio-sdl-src-2.6.0.tar.gz 32210 BLAKE2B 285c8b5f04d989bbee69c043458451cf24b6989537dfa0aa755bbfdb399984e8a0a059dc30991926ca383730a75a17401f089de7d18579f6881908d969c3f71d SHA512 5a38150a296b9b493552386ff07c5c0ea6794e7d8e5331b8158d9190d9e95dc3d07f962e6ac57080aa07e00197637a5aa6019d35d0d06dcb141cdfe11500c3a0
diff --git a/games-emulation/mupen64plus-audio-sdl/mupen64plus-audio-sdl-2.6.0.ebuild b/games-emulation/mupen64plus-audio-sdl/mupen64plus-audio-sdl-2.6.0.ebuild
new file mode 100644
index 000000000000..c93672a67003
--- /dev/null
+++ b/games-emulation/mupen64plus-audio-sdl/mupen64plus-audio-sdl-2.6.0.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_P=${PN}-src-${PV}
+DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, SDL audio plugin"
+HOMEPAGE="https://www.mupen64plus.org/"
+SRC_URI="
+ https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libsamplerate oss speex"
+
+DEPEND="
+ >=games-emulation/mupen64plus-core-${PV}:=
+ media-libs/libsdl2:0=[sound]
+ libsamplerate? ( media-libs/libsamplerate:= )
+ speex? (
+ media-libs/speex:=
+ media-libs/speexdsp:=
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ # avoid implicitly appending CPU flags
+ sed -i -e 's:-mmmx::g' -e 's:-msse::g' projects/unix/Makefile || die
+}
+
+src_compile() {
+ MAKEARGS=(
+ # Note: please keep this in sync in all of mupen64plus-* packages
+
+ -C projects/unix
+
+ # this basically means: GNU userspace
+ UNAME=Linux
+
+ # verbose output
+ V=1
+
+ CROSS_COMPILE="${CHOST}-"
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+ # usual CFLAGS, CXXFLAGS and LDFLAGS are respected
+ # so we can leave OPTFLAGS empty
+ OPTFLAGS=
+
+ # paths, some of them are used at compile time
+ PREFIX=/usr
+ LIBDIR=/usr/$(get_libdir)
+
+ # disable unwanted magic
+ LDCONFIG=:
+ INSTALL_STRIP_FLAG=
+
+ # Package-specific stuff
+
+ # CROSS_COMPILE causes it to look for ${CHOST}-sdl2-config...
+ SDL_CFLAGS="$($(tc-getPKG_CONFIG) --cflags sdl2)"
+ SDL_LDLIBS="$($(tc-getPKG_CONFIG) --libs sdl2)"
+
+ NO_SPEEX=$(usex speex 0 1)
+ NO_SRC=$(usex libsamplerate 0 1)
+ NO_OSS=$(usex oss 0 1)
+ # not packaged (https://github.com/nemomobile/libaudioresource)
+ USE_AUDIORESOURCE=0
+ )
+
+ use amd64 && MAKEARGS+=( HOST_CPU=x86_64 )
+ use x86 && MAKEARGS+=( HOST_CPU=i386 )
+
+ emake "${MAKEARGS[@]}" all
+}
+
+src_install() {
+ emake "${MAKEARGS[@]}" DESTDIR="${D}" install
+ dodoc RELEASE
+}