summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2021-03-20 18:53:41 -0700
committerPatrick McLean <chutzpah@gentoo.org>2021-03-20 18:54:00 -0700
commitc1a4f6fdf5931b099fb442d966fe0234bf3dc102 (patch)
tree1eb6232fe9ca716a94a2d6ad093e4ccb34a1e472
parentgnome-extra/gucharmap: Re-add lost REQUIRED_USE (diff)
downloadgentoo-c1a4f6fdf5931b099fb442d966fe0234bf3dc102.tar.gz
gentoo-c1a4f6fdf5931b099fb442d966fe0234bf3dc102.tar.bz2
gentoo-c1a4f6fdf5931b099fb442d966fe0234bf3dc102.zip
sys-process/bpytop-1.0.63: Version bump
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--sys-process/bpytop/Manifest1
-rw-r--r--sys-process/bpytop/bpytop-1.0.63.ebuild33
-rw-r--r--sys-process/bpytop/files/bpytop-1.0.63-tests.patch35
3 files changed, 69 insertions, 0 deletions
diff --git a/sys-process/bpytop/Manifest b/sys-process/bpytop/Manifest
index 8e28c20d0866..a3bb080533fc 100644
--- a/sys-process/bpytop/Manifest
+++ b/sys-process/bpytop/Manifest
@@ -1 +1,2 @@
DIST bpytop-1.0.61.tar.gz 626468 BLAKE2B 84a9bbaec6af27b06af53acbe2e735421de3bc4567fcf7fb29d05f801f7414b4e035e67a2fecb27a45d4d91c1d6ef527a16775f44c2e5620ecf797794969a2d2 SHA512 639e0d94bd500477b8288400c6fa1769f1b7327733bec8292e72eb3024e26f6242901970dfc539d9fb309f69299ea934e02ab93226f907ddbbefb670bffb027c
+DIST bpytop-1.0.63.tar.gz 627729 BLAKE2B a61d7c101c05d8e706b5c89f3c52dd02cf99e126d73f4cdb58adf8e474774e618abce7184a6fcf1c1b69f4c491b088c4c715d7b803c56933e1a8eeb8efa77fec SHA512 85334a43137466992fe3003f7f29b6a66b41732d1953fd5653ce277d35735127eef97607599906c0d0cfc7323852da75541b2ae79db22f843892097a2d3398e4
diff --git a/sys-process/bpytop/bpytop-1.0.63.ebuild b/sys-process/bpytop/bpytop-1.0.63.ebuild
new file mode 100644
index 000000000000..5b1ac4dd6d6a
--- /dev/null
+++ b/sys-process/bpytop/bpytop-1.0.63.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+DESCRIPTION="Linux/OSX/FreeBSD resource monitor"
+HOMEPAGE="https://github.com/aristocratos/bpytop"
+SRC_URI="https://github.com/aristocratos/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/psutil-5.7.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/bpytop-1.0.63-tests.patch"
+)
+
+src_install() {
+ insinto "/usr/share/${PN}/themes"
+ doins bpytop-themes/*.theme
+ distutils-r1_src_install
+}
diff --git a/sys-process/bpytop/files/bpytop-1.0.63-tests.patch b/sys-process/bpytop/files/bpytop-1.0.63-tests.patch
new file mode 100644
index 000000000000..3085c3e19ef5
--- /dev/null
+++ b/sys-process/bpytop/files/bpytop-1.0.63-tests.patch
@@ -0,0 +1,35 @@
+diff --git a/bpytop.py b/bpytop.py
+index 16482c0..a2b18d6 100755
+--- a/bpytop.py
++++ b/bpytop.py
+@@ -63,16 +63,21 @@ args.add_argument("-b", "--boxes", action="store", dest="boxes", help = "which
+ args.add_argument("-lc", "--low-color", action="store_true", help = "disable truecolor, converts 24-bit colors to 256-color")
+ args.add_argument("-v", "--version", action="store_true", help = "show version info and exit")
+ args.add_argument("--debug", action="store_true", help = "start with loglevel set to DEBUG overriding value set in config")
+-stdargs = args.parse_args()
+
+-if stdargs.version:
+- print(f'bpytop version: {VERSION}\n'
+- f'psutil version: {".".join(str(x) for x in psutil.version_info)}')
+- raise SystemExit(0)
+-
+-ARG_BOXES: str = stdargs.boxes
+-LOW_COLOR: bool = stdargs.low_color
+-DEBUG: bool = stdargs.debug
++if __name__ == "__main__":
++ stdargs = args.parse_args()
++ if stdargs.version:
++ print(f'bpytop version: {VERSION}\n'
++ f'psutil version: {".".join(str(x) for x in psutil.version_info)}')
++ raise SystemExit(0)
++
++ ARG_BOXES: str = stdargs.boxes
++ LOW_COLOR: bool = stdargs.low_color
++ DEBUG: bool = stdargs.debug
++else:
++ ARG_BOXES = None
++ LOW_COLOR = False
++ DEBUG = False
+
+ #? Variables ------------------------------------------------------------------------------------->
+